Subject: Re: draft-mirtorabi-ospf-tunnel-adjacency-01.txt

From: "Li, Ke Qin (Peter)" <[email-masked]>
Date: Tue, 13 Jan 2004 11:20:45 +0800

Hi,

I've a question related to the first application of TA, i.e., use backbone
area as high speed path for non-backbone area. In my opinion, the reason of
using TA to do this is that, in OSPF intra-area path is preferred over
inter-area path.

My question is, what will happen if we remove the preference? When there are
one intra-area path and one inter-area path to the same destination, we
choose one by comparing their metrics. Is there any serious consequence?

Thank you.

Keqin Li

> -----Original Message-----
> From: Sina Mirtorabi [mailto:[email-masked]]
> Sent: Monday, January 12, 2004 12:54
> To: [email-masked]
> Subject: draft-mirtorabi-ospf-tunnel-adjacency-01.txt
>
>
> Folks,
>
> A new version of TA has been published
>
> http://www.ietf.org/internet-drafts/draft-mirtorabi-ospf-tunne
> l-adjacenc
> y-01.txt
>
>
> There was some concerns regarding the recursive TA, discussed
> during the
> last ietf meeting. We had some discussion with Acee and we
> decided that
> the best way to prevent recursive TA is to allow only
> backbone to be the
> transit area.
>
> This still honor what TA was initially designed for, namely
>
> 1) Use Backbone area as high speed path for non-backbone area (
> Intra-area / Inter-area preference )
> 2) Use automatic partition repair for non-backbone area when
> summarization is performed
> 3) Use TA for multiple non-backbone area path and prevent the cost of
> adding additional link ( e.g. Hub and Spoke topology)
>
> This change will prevent TA to be used for backbone partition repair
> however there is already a solution for this i.e. VL and having a
> redundant solution is not required.
>
>
> Comments are welcome,
>
> Sina
>

---

From: Sina Mirtorabi <[email-masked]>
Date: Mon, 12 Jan 2004 21:13:51 -0800

Kequin,

->-----Original Message-----
->From: Mailing List [mailto:[email-masked]] On
->Behalf Of Li, Ke Qin (Peter)
->Sent: Monday, January 12, 2004 7:21 PM
->To: [email-masked]
->Subject: Re: draft-mirtorabi-ospf-tunnel-adjacency-01.txt
->
->
->Hi,
->
->I've a question related to the first application of TA, i.e.,
->use backbone area as high speed path for non-backbone area.
->In my opinion, the reason of using TA to do this is that, in
->OSPF intra-area path is preferred over inter-area path.
->
->My question is, what will happen if we remove the preference?
->When there are one intra-area path and one inter-area path to
->the same destination, we choose one by comparing their
->metrics. Is there any serious consequence?

Since the summary cost is based on the intra-area cost theoretically you
should not have a routing loop however there are few problems

- All routers must behave the same which means that you have a backward
compatibility problem to resolve as otherwise you encounter routing
loops

- When you summarize you will hide detail cost information and can
easily go back to routing loop. For example imagine that you want to go
from R1 to R2 in area 1 and have both intra-area and Inter-area path.
When you chose your Inter-area path and send the packet via backbone, If
the backbone routers receive only summary for area 1 then the path can
go back to the ABR that R1 chose to send the packet in first place and
you have a routing loop

Thanks
Sina

->
->Thank you.
->
->Keqin Li
->
->> -----Original Message-----
->> From: Sina Mirtorabi [mailto:[email-masked]]
->> Sent: Monday, January 12, 2004 12:54
->> To: [email-masked]
->> Subject: draft-mirtorabi-ospf-tunnel-adjacency-01.txt
->>
->>
->> Folks,
->>
->> A new version of TA has been published
->>
->> http://www.ietf.org/internet-drafts/draft-mirtorabi-ospf-tunne
->> l-adjacenc
->> y-01.txt
->>
->>
->> There was some concerns regarding the recursive TA,
->discussed during
->> the last ietf meeting. We had some discussion with Acee and we
->> decided that
->> the best way to prevent recursive TA is to allow only
->> backbone to be the
->> transit area.
->>
->> This still honor what TA was initially designed for, namely
->>
->> 1) Use Backbone area as high speed path for non-backbone area (
->> Intra-area / Inter-area preference )
->> 2) Use automatic partition repair for non-backbone area when
->> summarization is performed
->> 3) Use TA for multiple non-backbone area path and prevent
->the cost of
->> adding additional link ( e.g. Hub and Spoke topology)
->>
->> This change will prevent TA to be used for backbone
->partition repair
->> however there is already a solution for this i.e. VL and having a
->> redundant solution is not required.
->>
->>
->> Comments are welcome,
->>
->> Sina
->>
->