Subject: Re: draft-mirtorabi-ospf-tunnel-adjacency-01.txt

From: "Li, Ke Qin (Peter)" <[email-masked]>
Date: Tue, 13 Jan 2004 16:04:43 +0800

Hi,

I've constructed an example according to your description about routing loop
caused by summarization.

          ---
      5---|w|---5
       |  ---  |
       |       |
      ---     ---
======|x|=====|y|=====
      ---     ---
       |       |
       |  ---  |
     20---|t|---5
          ---

In this graph, '=' is the border of area. Above the border is area 0, below
it is area 1. x and y are ABRs. Link costs are depicted in the graph.

Case 1: no range is configured in x and y.

In this case, x advertises summary-LSA with destination t and metric 20. y
advertises summary-LSA with destination t and metric 5. Thus, x has an
intra-area route to t with cost 20, and an inter-area route to t with cost
15. x chooses the inter-area route. w chooses inter-area route to t throught
y. So, there is no routing loop.

Case 2: a range m is configure in y. m covers t.

In this case, x has an intra-area route to t, and an inter-area route to m.
When forward packet destined to t, x chooses the intra-area route according
to the longest match rule. So, there is no routing loop.

Thus, in my opionion, there is no routing loop, but still suboptimal
routing.

What's your opinion about this?

Thank you.

Keqin Li

>Since the summary cost is based on the intra-area cost theoretically you
>should not have a routing loop however there are few problems
>
>- All routers must behave the same which means that you have a backward
>compatibility problem to resolve as otherwise you encounter routing
>loops
>
>- When you summarize you will hide detail cost information and can
>easily go back to routing loop. For example imagine that you want to go
>from R1 to R2 in area 1 and have both intra-area and Inter-area path.
>When you chose your Inter-area path and send the packet via backbone, If
>the backbone routers receive only summary for area 1 then the path can
>go back to the ABR that R1 chose to send the packet in first place and
>you have a routing loop
>
>Thanks
>Sina

Keqin Li
Bell Labs Research China
Tel: 86-10-68748088-8438

---

From: Sina Mirtorabi <[email-masked]>
Date: Tue, 13 Jan 2004 09:09:17 -0800

Kequin,

->-----Original Message-----
->From: Mailing List [mailto:[email-masked]] On
->Behalf Of Li, Ke Qin (Peter)
->Sent: Tuesday, January 13, 2004 12:05 AM
->To: [email-masked]
->Subject: Re: draft-mirtorabi-ospf-tunnel-adjacency-01.txt
->
->
->Hi,
->
->I've constructed an example according to your description
->about routing loop caused by summarization.
->
->          ---
->      5---|w|---5
->       |  ---  |
->       |       |
->      ---     ---
->======|x|=====|y|=====
->      ---     ---
->       |       |
->       |  ---  |
->     20---|t|---5
->          ---
->
->In this graph, '=' is the border of area. Above the border is
->area 0, below it is area 1. x and y are ABRs. Link costs are
->depicted in the graph.
->
->Case 1: no range is configured in x and y.
->
->In this case, x advertises summary-LSA with destination t and
->metric 20. y advertises summary-LSA with destination t and
->metric 5. Thus, x has an intra-area route to t with cost 20,
->and an inter-area route to t with cost 15. x chooses the
->inter-area route. w chooses inter-area route to t throught y.
->So, there is no routing loop.

Yes, As I said since the cost of the summary is based on intra-area cost
you should not have routing loop

->
->Case 2: a range m is configure in y. m covers t.
->
->In this case, x has an intra-area route to t, and an
->inter-area route to m. When forward packet destined to t, x
->chooses the intra-area route according to the longest match
->rule. So, there is no routing loop.
->
->Thus, in my opionion, there is no routing loop, but still
->suboptimal routing.

Actually if you summarize you would install a discard route and ignore
the remote summary in that case you would only have an intra-area path

Any way the main idea is to create a path through backbone _visible_ to
internal routers in the non-backbone area. Since the ABR will not
generate summary back to the internal area, the Inter-area path is only
visible to border routers and not very useful to internal routers...

Sina

->
->What's your opinion about this?
->
->Thank you.
->
->Keqin Li
->
->>Since the summary cost is based on the intra-area cost theoretically
->>you should not have a routing loop however there are few problems
->>
->>- All routers must behave the same which means that you have
->a backward
->>compatibility problem to resolve as otherwise you encounter routing
->>loops
->>
->>- When you summarize you will hide detail cost information and can
->>easily go back to routing loop. For example imagine that you
->want to go
->>from R1 to R2 in area 1 and have both intra-area and
->Inter-area path.
->>When you chose your Inter-area path and send the packet via
->backbone,
->>If the backbone routers receive only summary for area 1 then
->the path
->>can go back to the ABR that R1 chose to send the packet in
->first place
->>and you have a routing loop
->>
->>Thanks
->>Sina
->
->Keqin Li
->Bell Labs Research China
->Tel: 86-10-68748088-8438
->