Subject: Re: Proposal for OSPF MANET Extensions Design Points

From: "Naidu, Venkata" <[email-masked]>
Date: Fri, 16 Jan 2004 11:59:38 -0500

Hi Acee,

  Your proposal is reasonable.

-> I believe that for the foreseeable future the vast majority of
-> networks will be fixed (although they may support wireless hosts).
-> Based on this belief and the fact that what is being proposed for
-> MANET is very different from base OSPFv3 I'd like to propose the
-> following design points for the work:
->
->     1. A fixed network OSPFv3 implementation shouldn't require
->        changes to fully interoperate with an OSPFv3 implementation
->        supporting the MANET extensions.
->     2. The MANET extensions should be limited to wireless
-> interfaces (or
->        whatever level of segregation we end up with).
->     3. As much as possible, an OSPFv3 implementation with the MANET
->        extensions should be a proper subset of an OSPFv3
-> implementation
->        without the extensions. In other words, we should be extremely
->        suspect of changes to basic OSPFv3 mechanisms.

  I don't know whether my proposal has already been suggested.
  Here it is: If OSPFv3 changes to support MANET is so harmful
  for existing fixed OSPFv3 operation. And if MANET thinks that
  OSPF is a suitable protocol for their requirements, then it
  will be a good idea to start OSPFv4 targeted only to support
  IPv6 MANET requirements.

  In such a case, OSPFv4 will satisfy all the above design
  requirements proposed by you. Everybody will be happy.
  What is your opinion ?

Venkata.

---

From: Acee Lindem <[email-masked]>
Date: Fri, 16 Jan 2004 13:01:20 -0500

Hi Venkata,

----- Original Message -----
From: "Naidu, Venkata" <[email-masked]>
To: <[email-masked]>
Sent: Friday, January 16, 2004 11:59 AM
Subject: Re: Proposal for OSPF MANET Extensions Design Points

>   requirements proposed by you. Everybody will be happy.

I'm not convinced we need a new protocol at this point. There are
a number of disadvantages of a new protocol including 1) Migration
of fixed networks in environments containing both MANET and
fixed nodes 2) Dual protocol maintenance for new features (standards,
development, deployment).