Subject: Re: TOS field removal in OSPF for IPv6

From: Vishwas Manral <[email-masked]>
Date: Mon, 12 Jan 2004 05:05:01 -0800

Hi Olaf,

I guess the reason was that TOS routing was probably never used in production networks.

Is there any particular scenario in mind wrt mobility where TOS might be useful and current mechanisms dont suffice? Could you elaborate them for us?

Thanks,
Vishwas

-----Original Message-----
From: Mailing List [mailto:[email-masked]]On Behalf Of Olaf
Menzel
Sent: Monday, January 12, 2004 2:49 PM
To: [email-masked]
Subject: TOS field removal in OSPF for IPv6

Dear OSPF-Group,
--------------------
I am working in a EU project called "Daidalos"
(http://www.ist-daidalos.org) and I am responsible for
routing stuff in fixed and ad-hoc network based on IPv6. For multipath
routing path decission I wanted to
use OSPF first with DS- field (TOS in IPv4)  tracking and later update
to IPv6 QOSPF (QoS based OSPF)
I just recognized the TOS based routing  has been removed in the OSPF
IPv6 specification .
I wanted to use this feature from OSPF v2 with some enhancements from
RFC2676  -
"QoS Routing Mechanisms and OSPF Extensions"  and port this to IPv6.
The routing protocol
should support path selection based on the service class of the
delivered content.

RFC2740:

"Type of Service (TOS) has been removed from
the OSPFv2 specification [Ref1], and is not encoded within OSPF for
IPv6's LSAs."

Are there any serious reasons why the OPSF WG has decited to remove
"Type of Service - routing" from OSPF for IPv6 ?

with regards

Olaf Menzel

--
Dipl. Ing. Olaf Menzel - System Engineer
FOKUS - Fraunhofer Institute for Open Communication Systems:
- Competence Center for Advanced Satellite Communication
Schloss Birlinghoven, 53754 Sankt Augustin, Germany
Phone: +49-2241-14-3494 Mobile: +49-175-2616161 Fax:+49-2241-14-43494

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.560 / Virus Database: 352 - Release Date: 1/8/2004

---

From: Arkadiusz Binder <[email-masked]>
Date: Mon, 12 Jan 2004 17:12:29 +0100

> Is there any particular scenario in mind wrt mobility where TOS
> might be useful and current mechanisms dont suffice? Could you
> elaborate them for us?

Hi, i have some needs for that.

I have a network with different ISP (about 4).

Any of them prohibit traffic with sources IP different than they provide.

Here is my diagram:

A--B--C--ISP1
|  |  |
|  |  |
D--E--F--ISP2
|
|
ISP3

How to use all of accessible IP-spaces provided by ISP1,2,3 ?

My solution was to use ip-precendence/TOS for marking all traffic arriving
at any A,B,C...F router LAN interfaces - with 0x1 for ISP1, 0x2 for ISP2,
0x3 for ISP3.

Every C,D,F router distribute default route - router C distribute default
route 0x1 , D=0x3, F=0x2.

In such situation every incomming packet with different routes per
different TOS could exit from our IGP properly (to correct ISP).

I have problem in my network, i use the biggest ISP1 link in my IGP (OSPF),
any other ISP2,3 is used only at the router D or router F, without any
redistribution.

I can't see any other possibility of solving my problem within single IGP.

Sure, i can have different route-tags and several default routes, then
distribute them to different kernel-routing-tables, then put ingress
packets in correct tables at every hop.

What is the best solution for that?

I use zebra/quagga routing daemon and cisco's.

Arkadiusz Binder

---

From: Jing Shen <[email-masked]>
Date: Tue, 13 Jan 2004 09:07:17 +0800

Hi,

> any other ISP2,3 is used only at the router D or

I don't understand here clearly.  Have you really
implemented solution above in your network? or you
just set up traffic classification on router to ISP1
and redirect those traffic with IP from ISP2 ( ISP3)
to appropriate router?  If so, that does not relate to
OSPF.

I'm not familiar with zebra, but in cisco OSPF FAQ it
states:
"
Q: Does the Cisco OSPF implementation support IP
TOS-based routing?

A: Cisco OSPF only supports TOS 0. This means that
routers route all packets on the TOS 0 path,
eliminating the need to calculate non-zero TOS paths.
"

I don't know wether your network is one with hundreds
of routers, if it just consist of less than 10 router
policy based routing could be set up easily at each
router. And, it could be easily set up two or more
optional routes for each destination.

To ToS based routing in OSPF, I don't think it should
be based on ToS/"traffic class" but to based on DSCP
which is under hot discussion now.

regards

Jing Shen

'spam control'

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around
http://mail.yahoo.com