Subject: Priority in Link Lsa

From: query OSPF <[email-masked]>
Date: Thu, 5 Feb 2004 11:38:42 -0000

For OSPFv3, why is the router priority specified on the link-LSA in addition to the hello packets?

same question is asked by mike but don't find any answer?

regards
Manish

---

From: Acee Lindem <[email-masked]>
Date: Thu, 5 Feb 2004 08:11:36 -0500

Hi Manish,

I don't see any reason. I don't use it in my implementation (other
than setting it, using it to determine if a link LSA has changed, and 
displaying it. 

Thanks,
Acee  
  ----- Original Message ----- 
  From: query OSPF 
  To: [email-masked] 
  Sent: Thursday, February 05, 2004 6:38 AM
  Subject: Priority in Link Lsa

  regards
  Manish

---

From: Richard Ogier <[email-masked]>
Date: Thu, 5 Feb 2004 09:32:35 -0800

Hi Manish,

My guess is that this is for use on NBMA links, since each router attached
to an NBMA link does not receive Hellos from all other routers attached
to the NBMA link, but does receive link-LSAs.  This way, each router
on the NBMA link will know the router priority of every other router on
the NBMA link, and will thus know which routers are eligible to become
Designated Router.  (OSPFv2 requires some configuration information
for the Hello Protocol.)

Richard

---

From: Acee Lindem <[email-masked]>
Date: Thu, 5 Feb 2004 12:50:04 -0500

----- Original Message -----
From: "Richard Ogier" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, February 05, 2004 12:32 PM
Subject: Re: Priority in Link Lsa

> Designated Router.  (OSPFv2 requires some configuration information

Richard,
I thought about this possibility but the router priority is really an imperfect
solution. On an NBMA network, you need to elect a DR initially in order
for the first link LSA to be flooded. So, the router priority in the link LSA
doesn't buy you anything other than being able to check for inconsistencies
in your NBMA neighbor configuration (I haven't implemented this).

Thanks,
Acee