Subject: Re: Highly Available OSPF Router.

From: Vishwas Manral <[email-masked]>
Date: Sun, 15 Feb 2004 23:11:02 -0800

Mukesh,

I know and have worked on one such implementation http://mcg.motorola.com/netplane/.

I do not see any reason why things should be standardized in OSPF working group at all. You may however want to have a look at the SAForum site http://www.saforum.org/home.

Thanks,
Vishwas

-----Original Message-----
From: Mailing List [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Monday, February 16, 2004 12:33 PM
To: [email-masked]
Subject: Highly Available OSPF Router.

Has anyone implemented an OSPF HA where two or more OSPF routers
appear as one OSPF router to the OSPF neighbors. One of the routers 
(the Master) talks to the external world (OSPF neighbors) and the 
others (the Backups) keep all the dynamic OSPF state (neighbors,
database etc) in sync with the Master. When the Master dies, one of
the backup router takes over immediately without the neighbors
realizing any change in the network ?

If anyone has implemented any such thing, I would like to hear about
how they do it. I would also like to know if the WG would be interested
in standardizing such a mechanism ? At least I think that it will be
a useful thing !!

Regards
Mukesh

---

From: "Ramalingam, Swaminathan (Swaminathan)" <[email-masked]>
Date: Mon, 16 Feb 2004 12:53:44 +0530

Mukesh,
Do u mean multi-level hierarchy in OSPF?. Present two-level hierarchy in
OSPF is too good enough to achieve scalability in any big network. Do you
really see any necessity for this?. If so, could you explain where it can be
useful?.

Swami

>From: [email-masked] [mailto:[email-masked]]

---

From: Vishwas Manral <[email-masked]>
Date: Sun, 15 Feb 2004 23:28:40 -0800

Hi Mukesh,

This thing is not OSPF specific at all, and can be done applications. As Dave said its pretty standard stuff done by a lot of vendors, why dont you have a look at the link I provided?

Thanks,
Vishwas

-----Original Message-----
From: Mailing List [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Monday, February 16, 2004 12:56 PM
To: [email-masked]
Subject: Re: Highly Available OSPF Router.

Thanks for the quick responses :)

Ok let me take the word "standardized" back !

I meant to ask "will it be useful to write an informational
document on how to do this implementation trick for OSPF" ?
I am sure every implementor will have to think about the same
issues like:

- what are the tasks that are just performed by the Master and
  not by the backups.
- How to synchronize the initial state between the master and 
  the member.
- How to keep the state in sync.
- What actions to perform at the time of the swithover (master
  dying and backup taking over).
etc. etc.

Why not write a document and make it easier for everyone ??

Regards
Mukesh

> From: Mailing List [mailto:[email-masked]]On Behalf Of ext
> Dave Katz
> Sent: Sunday, February 15, 2004 11:19 PM
> Subject: Re: Highly Available OSPF Router.
> 
> 
> I suspect a number of folks are working on things like this.
> 
> However, the way you describe it says that it in fact is not 
> subject to
> standardization, since it does what it does without the neighbors
> realizing (nothing outside the "black box.")  Therefore it is only an
> implementation trick, not something to be standardized.
> 
> --Dave
> 
> On Sunday, Feb 15, 2004, at 23:03 US/Pacific, [email-masked]
> wrote:
>