Subject: Re: Configured default route or OSPF default route

From: Durai R <[email-masked]>
Date: Mon, 2 Feb 2004 12:25:45 +0530

Hi All,

If the route is learned by OSPF, then its administrative distance is 110 by
default. This can be changed by the administrator. But the administrative
distance  of the default route which is configured by the administrator is
by default 1. This also can be changed by the administrator. So under
normal situations ie.,with default values, configured static route will
always have higher precedence than the learned route(ospf default route).

Lower the administrative distance means higher the trustness of the route.

Regards,
Durai

                      Mukesh.Gupta@NOKI
                      A.COM                    To:       [email-masked]
                      Sent by: Mailing         cc:
                      List                     Subject:  Re: Configured default route or OSPF default
                      <[email-masked].         route
                      LSOFT.COM>

                      02/02/2004 12:15
                      PM
                      Please respond to
                      Mailing List

Acee/Pawan,

When you refer to "OSPF learned routes", do you mean OSPF External
routes or ALL ospf routes ? Because Nokia routers prefer all OSPF
routes except the OSPF External routes over the static routers but
prefer static routes over the OSPF External routes and IMHO that
is a sensible thing to do.

Ofcourse an administrator is allowed to changes all these preferences.

Regards
Mukesh

> -----Original Message-----
> From: Mailing List [mailto:[email-masked]]On Behalf Of ext
> Bhatia Pawan-CPB101
> Sent: Wednesday, January 28, 2004 3:23 PM
> To: [email-masked]
> Subject: Re: Configured default route or OSPF default route
>
>
> 3COM (and now Motorola) routers also prefer static routes
> over OSPF learned routes. However, there is an option to
> configure a static route such that the OSPF learned route
> takes precedence.
>
> regards,
> Pawan
>
> -----Original Message-----
> From: Mailing List [mailto:[email-masked]] On
> Behalf Of Acee Lindem
> Sent: Tuesday, January 27, 2004 3:31 PM
> To: [email-masked]
> Subject: Re: Configured default route or OSPF default route
>
>
> ----- Original Message -----
> From: "Abhijit Kumbhare" <[email-masked]>
> To: <[email-masked]>
> Sent: Tuesday, January 27, 2004 5:25 PM
> Subject: Configured default route or OSPF default route
>
>
> > Hello,
> >
> > If the user has not configured anything - what is the generally
> > accepted default preference in most implementations - should the
> > configured default route take precedence or the learned
> (OSPF) default
> > route?
> >
> > I believe Cisco uses the static (configured) default route over the
> > learned default route - how do others handle it?
>
> Hi Abhijit,
>
> We, Redback, also will prefer a static route over an OSPF
> learned route. I think this is the right default since the
> static route is explicit.  We do allow the preference (aka,
> administrative distance) to be configured for individual
> static routes. Additionally, we'll install the a backup OSPF
> external route (default or otherwise) even if we are
> advertising an external route ourselves and let the defaulted
> or configued route preferences sort themselves out in RIB. If
> we install an OSPF intra or inter area route, we will
> discontinue advertising an OSPF external route. I think this
> approach offers the most flexibility.
>
> Thanks,
> Acee
>
> >
> > Thanks,
> > Abhijit Kumbhare
>

---

From: [email-masked]
Date: Mon, 2 Feb 2004 01:42:51 -0600

Sean,

You are right. The default route will be an ospf external route and 
a static default route will be (and should be) preferred over the
default route learned through OSPF.

I raised the point because I thought people were saying that the
static routes (All and not just the default) are preferred over
OSPF learned routes (All and not just the OSPF External).

Regards
Mukesh

> Farshad Tavallaei
> Sent: Sunday, February 01, 2004 11:12 PM
> Mukesh,
> I am assuming you are asking about transit areas (some call 
> them normal
> areas). In a transit area, the default route is an external route
> anyway. e.g OSPF default route is an external route in area 0.
> 
> sean
> 
> 
> From: Mailing List [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Sunday, February 01, 2004 10:45 PM

---

From: Bhatia Pawan-CPB101 <[email-masked]>
Date: Mon, 2 Feb 2004 12:26:22 -0600

Hi Mukesh,
In Motorola Pathbuilder routers, Static routes have the highest precedence (even higher than OSPF Internal routes).

Regards,
Pawan

-----Original Message-----
From: Mailing List [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Sunday, February 01, 2004 10:45 PM
To: [email-masked]
Subject: Re: Configured default route or OSPF default route

Acee/Pawan,

When you refer to "OSPF learned routes", do you mean OSPF External routes or ALL ospf routes ? Because Nokia routers prefer all OSPF routes except the OSPF External routes over the static routers but
prefer static routes over the OSPF External routes and IMHO that
is a sensible thing to do.

Regards
Mukesh