Subject: Re: Configured default route or OSPF default route

From: [email-masked]
Date: Mon, 2 Feb 2004 00:45:23 -0600

Acee/Pawan,

When you refer to "OSPF learned routes", do you mean OSPF External
routes or ALL ospf routes ? Because Nokia routers prefer all OSPF
routes except the OSPF External routes over the static routers but 
prefer static routes over the OSPF External routes and IMHO that 
is a sensible thing to do.

Ofcourse an administrator is allowed to changes all these preferences.

Regards
Mukesh

> -----Original Message-----
> From: Mailing List [mailto:[email-masked]]On Behalf Of ext
> Bhatia Pawan-CPB101
> Sent: Wednesday, January 28, 2004 3:23 PM
> To: [email-masked]
> Subject: Re: Configured default route or OSPF default route
> 
> 
> 3COM (and now Motorola) routers also prefer static routes 
> over OSPF learned routes. However, there is an option to 
> configure a static route such that the OSPF learned route 
> takes precedence.
> 
> regards,
> Pawan
> 
> -----Original Message-----
> From: Mailing List [mailto:[email-masked]] On 
> Behalf Of Acee Lindem
> Sent: Tuesday, January 27, 2004 3:31 PM
> To: [email-masked]
> Subject: Re: Configured default route or OSPF default route
> 
> 
> ----- Original Message -----
> From: "Abhijit Kumbhare" <[email-masked]>
> To: <[email-masked]>
> Sent: Tuesday, January 27, 2004 5:25 PM
> Subject: Configured default route or OSPF default route
> 
> 
> > Hello,
> >
> > If the user has not configured anything - what is the generally
> > accepted default preference in most implementations - should the
> > configured default route take precedence or the learned 
> (OSPF) default
> > route?
> >
> > I believe Cisco uses the static (configured) default route over the
> > learned default route - how do others handle it?
> 
> Hi Abhijit,
> 
> We, Redback, also will prefer a static route over an OSPF 
> learned route. I think this is the right default since the 
> static route is explicit.  We do allow the preference (aka, 
> administrative distance) to be configured for individual 
> static routes. Additionally, we'll install the a backup OSPF 
> external route (default or otherwise) even if we are 
> advertising an external route ourselves and let the defaulted 
> or configued route preferences sort themselves out in RIB. If 
> we install an OSPF intra or inter area route, we will 
> discontinue advertising an OSPF external route. I think this 
> approach offers the most flexibility.
> 
> Thanks,
> Acee
> 
> >
> > Thanks,
> > Abhijit Kumbhare
>

---

From: Farshad Tavallaei <[email-masked]>
Date: Sun, 1 Feb 2004 23:12:11 -0800

Mukesh,

I am assuming you are asking about transit areas (some call them normal
areas). In a transit area, the default route is an external route
anyway. e.g OSPF default route is an external route in area 0.

sean

-----Original Message-----
From: Mailing List [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Sunday, February 01, 2004 10:45 PM
To: [email-masked]
Subject: Re: Configured default route or OSPF default route

Acee/Pawan,

Regards
Mukesh

---

From: Acee Lindem <[email-masked]>
Date: Mon, 2 Feb 2004 08:42:25 -0500

Hi Mukesh,

Our implementation is modular in that the OSPF routing
calculation and the RIB are separate. Within OSPF,
we always prefer OSPF internal routes (i.e., intra-area
and inter-area routes) over external routes and will not
advertise a redistributed route if there is an OSPF internal
route. Within the RIB, our default administrative
distance (or preference) for static routes is lower (more
preferred) than OSPF internal routes.

Acee

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Sent: Monday, February 02, 2004 1:45 AM
Subject: Re: Configured default route or OSPF default route

Acee/Pawan,

Regards
Mukesh