Subject: Re: Highly Available OSPF Router.

From: [email-masked]
Date: Mon, 16 Feb 2004 01:26:02 -0600

Thanks for the quick responses :)

Ok let me take the word "standardized" back !

I meant to ask "will it be useful to write an informational
document on how to do this implementation trick for OSPF" ?
I am sure every implementor will have to think about the same
issues like:

- what are the tasks that are just performed by the Master and
  not by the backups.
- How to synchronize the initial state between the master and 
  the member.
- How to keep the state in sync.
- What actions to perform at the time of the swithover (master
  dying and backup taking over).
etc. etc.

Why not write a document and make it easier for everyone ??

Regards
Mukesh

> -----Original Message-----
> From: Mailing List [mailto:[email-masked]]On Behalf Of ext
> Dave Katz
> Sent: Sunday, February 15, 2004 11:19 PM
> To: [email-masked]
> Subject: Re: Highly Available OSPF Router.
> 
> 
> I suspect a number of folks are working on things like this.
> 
> However, the way you describe it says that it in fact is not 
> subject to
> standardization, since it does what it does without the neighbors
> realizing (nothing outside the "black box.")  Therefore it is only an
> implementation trick, not something to be standardized.
> 
> --Dave
> 
> On Sunday, Feb 15, 2004, at 23:03 US/Pacific, [email-masked]
> wrote:
> 
> > Has anyone implemented an OSPF HA where two or more OSPF routers
> > appear as one OSPF router to the OSPF neighbors. One of the routers
> > (the Master) talks to the external world (OSPF neighbors) and the
> > others (the Backups) keep all the dynamic OSPF state (neighbors,
> > database etc) in sync with the Master. When the Master dies, one of
> > the backup router takes over immediately without the neighbors
> > realizing any change in the network ?
> >
> > If anyone has implemented any such thing, I would like to hear about
> > how they do it. I would also like to know if the WG would 
> be interested
> > in standardizing such a mechanism ? At least I think that it will be
> > a useful thing !!
> >
> > Regards
> > Mukesh
> >
>

---

From: Dave Katz <[email-masked]>
Date: Sun, 15 Feb 2004 23:47:13 -0800

> Why not write a document and make it easier for everyone ??

Competitive advantage.

--Dave