Subject: Intra-Area-Prefix LSA's on P2P interface

From: Nitin Kakkar <[email-masked]>
Date: Thu, 20 May 2004 19:11:52 -0700

Hello,
   In RFC 2740 Page 33, Paragraph 3

      "Router RTX examines its list of interfaces to the area. If the interface is in state Down, its prefixes are not included. If the
interface has been reported in RTX's router-LSA as a Type 2 link description (link to transit network), its prefixes are not included (they will be included in the intra-area-prefix-LSA for the link instead). If the interface type is Point-to-MultiPoint,or the interface is in state Loopback, or the interface connects to a point-to-point link which has not been assigned a prefix,then the site-local and global scope IPv6 addresses associated with the interface (if any) are copied into the intra-area-prefix-LSA, setting the LA-bit in the PrefixOptions field, and setting the PrefixLength to 128 and the Metric to 0. Otherwise,the list of site-local and global prefixes configured in RTX for the link are copied into the intra-area-prefix-LSA by specifying the PrefixLength, PrefixOptions, and Address Prefix fields. The Metric field for each of these prefixes is set to the interface's
output cost".

In the above paragraph please refer to the lines in bold,  they seem to indicate that, if a P2P interface is NOT assigned a global ipv6 address  then its corresponding inter-area-prefix LSA should send the site local address for that interface.

My questions are
   1) Where & how to use this site local address ?
   2) Is this condition for IPV6 unnumbered interfaces ?

Regards
Nitin

---

From: Acee Lindem <[email-masked]>
Date: Thu, 20 May 2004 10:10:01 -0400

Hi Nitin,
I believe the clause "or the interface connects to a point-to-point link which
has not been assigned a prefix"  is referring to interfaces which only have
global IPv6 address(es) with a prefix length of /128. This should be
clarified if the RFC is revised. Any other interpretations?

Note that site local addresses have been deprecated.  

Hope this helps, 
Acee
  ----- Original Message ----- 
  From: Nitin Kakkar 
  To: [email-masked] 
  Sent: Thursday, May 20, 2004 10:11 PM
  Subject: Intra-Area-Prefix LSA's on P2P interface

  Hello,

  My questions are 

  Regards
  Nitin