Subject: Re: How to test

From: Vishwas Manral <[email-masked]>
Date: Mon, 19 Jul 2004 06:41:28 -0700

Hi Vishnu,

Though I am thoroughly out of touch with OSPF, this sounds very simple.

1. First make a topology that has as an intra area route 10.0.0.0/24. Check if all is well?
2. Now add an interface to the topology such that there is another intra area route 10.0.0.0/16. Check again?
3. etc etc.

Thanks,
Vishwas

-----Original Message-----
From: vis reddy [mailto:[email-masked]]
Sent: Monday, July 19, 2004 7:03 PM
To: Vishwas Manral
Subject: How to test

I am testing the algorithm as described under appendix
E of rfc 2328.

It says that for assigning link-state ID's as an
example consider its 
operation when the following sequence of events occurs
in a single router 
(Router A).

    (1) Router A wants to originate an summary-LSA for
        [10.0.0.0,255.255.255.0]:

        (a) A Link State ID of 10.0.0.0 is used.

    (2) Router A then wants to originate an
summary-LSA for
        [10.0.0.0,255.255.0.0]:

        (a) The LSA for [10.0.0,0,255.255.255.0] is
reoriginated using a
            new Link State ID of 10.0.0.255.

        (b) A Link State ID of 10.0.0.0 is used for
            [10.0.0.0,255.255.0.0].

    (3) Router A then wants to originate an
summary-LSA for
        [10.0.0.0,255.0.0.0]:

        (a) The LSA for [10.0.0.0,255.255.0.0] is
reoriginated using a
            new Link State ID of 10.0.255.255.

        (b) A Link State ID of 10.0.0.0 is used for
            [10.0.0.0,255.0.0.0].

        (c) The network [10.0.0.0,255.255.255.0] keeps
its Link State ID
            of 10.0.0.255.

So can you help me for step 2) configuration, how do i
make router-A to originate an summary-LSA for
[10.0.0.0,255.255.0.0]

Thanks in Advance
vishnu

---

From: Acee Lindem <[email-masked]>
Date: Tue, 27 Jul 2004 22:15:07 -0400

> ----- Original Message -----
> From: "Vishwas Manral" <[email-masked]>
> To: <[email-masked]>
> Sent: Monday, July 19, 2004 9:41 AM
> Subject: Re: How to test

Hi Vishwas,

> 2. Now add an interface to the topology such that there is another intra area route 10.0.0.0/16. Check again?

I'd add that you need at least 2 areas with the DUT being the ABR between
them since the LSA ID assignment algorithm is applied to type 3 and 5 LSAs.
Note that appendix E is just one way of generating unique LSA IDs - other
algorithms yielding the desired effect of generating unique IDs with some of
the host bits set are valid. Also note that you should test more than 2 LSA IDs
and should add and delete them in different sequences to hit all the variations. You
also might want to do the same with redistributed routes to test type 5 LSAs.

Thanks,
Acee
-----Original Message-----
From: vis reddy [mailto:[email-masked]]
Sent: Monday, July 19, 2004 7:03 PM
To: Vishwas Manral
Subject: How to test

Thanks in Advance
vishnu