Subject: LSDB Overflow Limitation?

From: Charles Yi-tung Liang <[email-masked]>
Date: Thu, 8 Jul 2004 17:11:42 +0800

Hi,

Here below is my understanding from RFC1765
to process lsdb overflow condition.

Goal: Make every OSPF router to be awared of
the overflow state, and thus reduce the number
of lsdb.  That's why we required all the OSPF
routers setup the same limited lsdb threshold.

Process: As mentioned in RFC1765.

Limitation?/Problem?:
Since the new LSA update from someone triggers
overflow state (when currentLSACount == limitedLSACount)
via flooding, there is chance that certain OSPF router
will miss such a critial event.  Moreover, the following
premature actions may make someone else believing
there is not yet an overflow event.  Why don't we just set
up a beacon bit to notify everyone?  For example,
using a reserved filed in HELLO-Option to notify
overflow.  Afterward, when all the neighbors acked
with overflow beacon-bit, reset (clear) such a bit.

Could anyone help clearing my doubt?

BTW, if the overflow process needs to be applied
to Inter-AS LSAs (Area-Oriented), what kind of
LSA is suggested to be prematured?  Can I leave
RTRLink, NetLink, and ASSummary alone?
Will OSPF WG include the overflow process as
a part of OSPFv3?

Thanks in advance.

Charles

---

From: Erblichs <[email-masked]>
Date: Thu, 8 Jul 2004 09:07:38 -0700

Charles,

        The number really has to do with
        the number of non default AS-external
        LSAs.

        These are believed to represent the
        maj of LSAs in the LSDB.

        In my experience, this only occurs
        with memory limited routers and
        routers within the same area are
        normally set to the same values.

        Realize that in memory limited routers,
        you are pre-allocating enough memory
        to cover the limit and that memory will
        not be available for other functions.

        Mitchell Erblich
        -----------------

> Charles Yi-tung Liang wrote:
>
> Hi,
>