Subject: stub area in a vrf

From: John Pecola <[email-masked]>
Date: Wed, 28 Jul 2004 16:52:36 -0700

Hi,

With the 2547 VPNs, a CE router may receive type 3
LSAs from a PE for redistributed routes. Assuming that
2547 BGP routes are redistributd into ospf on the PE
in the vrf (ASBR), can there be a scenario where it is
desired to configure the PE-CE link as part of a stub
area? Should it be even allowed?

Thanks
John

__________________________________
Do you Yahoo!?
Yahoo! Mail - 50x more storage than other providers!
http://promotions.yahoo.com/new_mail

---

From: Acee Lindem <[email-masked]>
Date: Wed, 28 Jul 2004 20:31:55 -0400

Hi John,

Note that this draft (draft-ietf-l3vpn-ospf-2547-01.txt) is a product
of the L3VPN WG and not the OSPF WG. Perhaps Eric or Padma
could respond.  Although I know how I would handle it
I don't think the stub area case is covered in the draft.

Thanks,
Acee

---

From: Mani Devarajan <[email-masked]>
Date: Wed, 28 Jul 2004 17:55:37 -0700

Hi Jonh,
 I tried to do similar kind of testing, that is configuring PE-CE link as
 stub. But as PE will be ASBR, we cannot configure  it in a stub.

rfc 2328: Section 3.6
 AS boundary routers cannot be placed internal to stub  areas.

Thanks,
Mani