Subject: Re: Regarding route calculation over Vlink in case of O

From: Vivek Dubey <[email-masked]>
Date: Thu, 22 Jul 2004 09:27:34 -0000

Is RTA an ABR? Your topology doesnt specifies that. Vlink should not be operational.
In any case next hop should be RTB.

-Vivek

On Wed, 21 Jul 2004 prasanna s wrote :
>Iam running OSPFv3 in the following topology
>
>                vlink
>     ++++++++++++++++++++++++++
>    +                                                        +
>   RTA(e1)-------(e1)RTB(e2)------(e2)RTC(e3)------|2000:cccc::1/128
>                 area 1                     area 1                  area 0
>
>In this scenario, What should be the next hop for the route 2000:cccc::1/128
>in the routing table of RTA
>Is it link-local address of e1 of RTB or
>Global/site-local ipv6 address of e2 of RTC or
>Null
>
>Thanx and regards
>
>Prasanna Kumar A.S
>Software Engineer
>Huawei Technologies India Pvt Ltd
>Level-3 & 4 ,Leela Galleria,
>The Leela Palace,No.23 Airport Road.
>Bangalore-560 008
>Mobile :  98803-34587
>phone(0ff): 5217474/5217152 ext 701
>
>
>*****************************************************************
>This e-mail and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this mail in error, please notify the sender by phone or email immediately and delete it!
>*****************************************************************
>
>

---

From: Acee Lindem <[email-masked]>
Date: Tue, 27 Jul 2004 22:48:39 -0400

> Is RTA an ABR?
I think the configuration of a virtual link implies that.

> Your topology doesnt specifies that. Vlink should not be operational.

I agree. Specifically, it should be the link local address of
interface e1 on RTB.

OSPF and OSPFv3 implemenations do not normally install any
recursive routes. An exception may be OSPF sham links (depending
on how one interprets the  L3VPN draft).

Thanks,
Acee

On Wed, 21 Jul 2004 prasanna s wrote :
>This e-mail and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose
address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial
disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this mail
in error, please notify the sender by phone or email immediately and delete it!