Subject: Re: My virtual-link question

From: Don Goodspeed <[email-masked]>
Date: Fri, 30 Jul 2004 17:25:18 -0700

All,

My excite account was on the fritz so I resubscribed with my work account.

Mitchell, the last email I saw said advertise the link with MAXAGE.

Did you mean to say MaxMetric (aka 0xffff)?

-don

---

From: Erblichs <[email-masked]>
Date: Fri, 30 Jul 2004 18:19:30 -0700

Don,

        MAXAGE is used to withdraw a link from the LSDB.
        It is normally done when the SEQ is Maxed out.

        If a router is indeed OVERLOADED and unable to
        route even the fewest of transit packets and/or
        dst packets, then it is easily concieveable not
        to waste the bandwidth of to the destinations
        knowing those packets are going to be dropped
        anyway. Worst case is a drop at the last hop.

        You are in effect voluntering blackholing those
        routes until your router is able to advertise them
        again. It is a very drastic move which forces a new
        convergence to take place. It also assumes that
        you can still generate the advertisement. The same
        will happen if you don't refresh the routes in
        1 hours timeframe.

        Please be aware that this is different from DNA
        (do not age) LSAs.

        The MAXCOST metric via the Stub Router Advertisement
        only minimizes the number of transit pkts, but with
        no alternatives does not decrease the amount of
        transit traffic. It does not effect pkts that are
        routed only to a dst that is attached thru the
        router.

        I thought you would like to see how to do both of
        your items.

        Mitchell Erblich
        -------------------

---

From: Don Goodspeed <[email-masked]>
Date: Fri, 30 Jul 2004 18:25:23 -0700

Mitchell,

Why would a router advertising a virtual-link as one of it's
possibly many links MaxAge it's entire router LSA?

And in the example that I gave, the router with the virtual-
link was not the one in overload.  In fact, I made a note
at the end of my original description that one could have
a virtual-link path where the total path cost exceeded 65535
and my question applied to that scenario as well.

Should the end-points of the virtual-link tear down the
virtual-link in this case, or advertise the virtual-link
with the largest advertisable cost in a TOSMetric field
of a router LSA which is 65535.

I think you and I are thinking of two different scenarios.

Cheers,
Don

-----Original Message-----
From: Mailing List [mailto:[email-masked]]On Behalf Of
Erblichs
Sent: Friday, July 30, 2004 6:20 PM
To: [email-masked]
Subject: Re: My virtual-link question

Don,

        Mitchell Erblich
        -------------------

---

From: Erblichs <[email-masked]>
Date: Fri, 30 Jul 2004 18:37:29 -0700

Don,

        I was talking about two general methods
        of handling overload, thus it was a FYI...

        Doing one, both, or none is a implimentation
        issue for your company.

        Mitchell Erblich
        ----------------

---

From: Don Goodspeed <[email-masked]>
Date: Fri, 30 Jul 2004 18:49:18 -0700

Mitchell,

Knowing that, I can now re-read your email and it makes
complete sense now.  MaxAge'ing the LSA on the "overload"
router so NO paths are built thru it.

Thanks,
Don

-----Original Message-----
From: Mailing List [mailto:[email-masked]]On Behalf Of
Erblichs
Sent: Friday, July 30, 2004 6:37 PM
To: [email-masked]
Subject: Re: My virtual-link question

Don,

        Mitchell Erblich
        ----------------