Subject: Detecting inactive neighbors over demand circuit

From: armstrong mathiayalagan <[email-masked]>
Date: Mon, 9 Aug 2004 09:02:59 -0500

Hi,
        This draft recommends (May clause) Router LSA to be flooded for Neighbor
probing.
        With respect to the applicability of this draft to OSPFv3, I feel Link LSA
is a good choice for using in neighbor probing than Router LSA.
        In Demand Circuit, there are more chances for having LSAs of different
sequence number at both ends.
        If neighbor probing uses Router LSA, if the Router LSA is having higher
sequence number than the neighbors database, then the neighbor will flood
these LSA in all the non demand circuit interface. This can be avoided by
using Link LSA.
        Comments are welcome.

Regards,
Anu
--
___________________________________________________________
Sign-up for Ads Free at Mail.com
http://promo.mail.com/adsfreejump.htm

---

From: Erblichs <[email-masked]>
Date: Mon, 9 Aug 2004 13:57:32 -0700

Anu,

        Assuming that the Router LSA needs to be flooded
        in the near future (Not a DNA LSA), what is the harm
        to having it being flooded earlier?

        Assuming that a numbers of routers were
        booted at the same time, to minimize sychronization
        of flooding updates (assuming this is considered
        a problem), flooding a LSA earlier makes some
        sense to spread out the flooding.

        Assuming that the initial origination of the
        LSA is a active probe, the flooding to other
        routers florcefully verifies that all links
        are still active at this one point in time...

        Assuming that a non-floodable LSA is originated,
        the router LSA still needs to be flooded and
        not all the links are known to be in the same
        state at the same time..

        Lastly, if a scan identified a checksum corrupted LSA,
        this pre-flood could/would resych the LSDB at a
        earlier point in time. Could, because some routers
        would just go down into maintainance mode..

        Mitchell Erblich
        ----------------

---

From: Acee Lindem <[email-masked]>
Date: Wed, 18 Aug 2004 17:02:29 -0400

Hi Anu,
The draft doesn't specify that you have to use a router LSA, it simply uses
it as an example (draft-ietf-ospf-dc-07.txt). Also note
that link LSAs are not flooded over virtual links (which are demand
circuits by default). Having said that, a link LSA would seem like a good
choice for probing on a non-virtual OSPFv3 interface.

Note that this draft has been around for quite some time and is currently
in the RFC editor's queue.

Thanks,
Acee