Subject: Type 5 LSA Forwarding Address

From: Mohit Gurnani <[email-masked]>
Date: Mon, 18 Oct 2004 09:18:56 -0400

Hi,

I have the following topology:

  _ _ _ _ _
 |         |
 1         1
 DUT-----RT2
  2   |    2
      |
      |2     1
      RT3-------

DUT#
!
interface eth1
 ip address 1.1.1.1/24
!
interface eth2
 ip address 2.2.2.1/24
 ip ospf network non-broadcast
!
router ospf
 ospf router-id 10.70.0.112
!

rtr2#
!
interface eth1
 ip address 1.1.1.2/24
!
interface eth2
 ip address 2.2.2.2/24
 ip ospf network non-broadcast
!
router ospf
 ospf router-id 10.70.0.113
 network 2.2.2.0/24 area 0
 neighbor 2.2.2.1
 neighbor 2.2.2.3
!

rtr3#
interface eth1
 ip address 3.3.3.1/24
!
interface eth2
 ip address 2.2.2.3/24
 ip ospf network non-broadcast
!
router ospf
 ospf router-id 10.70.0.114
 redistribute static
 network 2.2.2.0/24 area 0
 network 3.3.3.0/24 area 0
 neighbor 2.2.2.2 priority 10
!
ip route 100.100.100.0/24 3.3.3.10
ip route 200.200.200.0/24 eth1
!

RT3 is generating the following two AS External LSAs:
-----------------------------------------------------

  LS age: 651
  Options: 0x2 (*|-|-|-|-|-|E|-)
  LS Type: AS-external-LSA
  Link State ID: 100.100.100.0
  Advertising Router: 10.70.0.114
  LS Seq Number: 80000002
  Checksum: 0x4971
  Length: 36
  Network Mask: /24
        Metric Type: 2
        TOS: 0
        Metric: 20
        Forward Address: 3.3.3.10
        External Route Tag: 0

LS age: 4
  Options: 0x2 (*|-|-|-|-|-|E|-)
  LS Type: AS-external-LSA
  Link State ID: 200.200.200.0
  Advertising Router: 10.70.0.114
  LS Seq Number: 80000001
  Checksum: 0x346d
  Length: 36
  Network Mask: /24
        Metric Type: 2
        TOS: 0
        Metric: 20
        Forward Address: 0.0.0.0
        External Route Tag: 0

The LSA for the route 100.100.100.0 has forwarding address set to 3.3.3.10.
Is this the correct behaviour. Or should the forwarding address be set to
default - 0.0.0.0?

I couldnt find the rules to set External Routes forwarding address in the
RFC. Could someone guide me to that?

---

From: Acee Lindem <[email-masked]>
Date: Mon, 18 Oct 2004 12:23:28 -0400

Mohit,

Since the behavior isn't precisely specified in RFC 2328 and this is
the second list post with this same topology I'm going to go out on a limb
and say either is correct. In your topology, rtr3 could safely suppress the
specification of a forwarding address since there are no other OSPF routers
on the 3.3.3.0 subnet. However, specifying one doesn't impact forwarding and
will save a re-origination if a neighbor becomes adjacent at a different time.

Hope this helps,
Acee