Subject: forwrding address in ospfv3

From: kishoreky <[email-masked]>
Date: Fri, 8 Oct 2004 14:09:01 +0530

Hi,

according to rfc 2328 to calculate and external route,

router must have the reachability to ASBR (who generates that external lsa)

+ router should have an INTER AREA or INTRA AREA path to the forwarding

address

(in case of non zero forwarding address).

i feel the same logic is applicable for ospfv3 also.

in that case whenever there is a route deletion (Both intra area and Inter

area) we need to see all the

External lsa in our database and check whether any frowrding address belongs

to this route.

if so delete the external route. is my understanding correct ?

if yes isn't it too costly to check the entire external lsdb database

whenever there is

a route deletion because most implementation will probably go for

incremental route calculation.

(Separating the IPv6 prefixes from the router LSA helps in incremental route

calculation for intra area route and that could be one of the reason for the

separation)

Also light on when should we set the forwarding address as Non Zero in

OSPFv3 helps.

CISCO does not set the forwarding address to non zero even if the nexthop of

the redistributed route belongs to OSPFv3 intra area route. (Sorry for

discussing about a specific implementation)

regards

Manish Gupta
Indiatimes Email now powered by APIC Advantage. Help!
HelpClick on the image to chat with me

---

From: Acee Lindem <[email-masked]>
Date: Fri, 8 Oct 2004 09:04:44 -0400

Manish,
A couple points:

  1. You can be smarter than searching your entire LSA external 
      database everytime there is a change to an OSPFv3 intra or i
      inter area route. 

  2. In actuality, you won't set the forwarding address for OSPFv3
      external LSAs very often. This is due to the fact that most of the
      time your next-hop address is link-local address. If we ever re-spin
      RFC 2740, I'll clarify this. 

Hope this helps,
Acee 
  ----- Original Message ----- 
  From: kishoreky 
  To: [email-masked] 
  Sent: Friday, October 08, 2004 4:39 AM
  Subject: forwrding address in ospfv3

  Hi,

  address

  to this route.

  whenever there is

  separation)

  OSPFv3 helps.

  regards

  Manish Gupta

------------------------------------------------------------------------------
  Indiatimes Email now powered by APIC Advantage. Help! 

  Help
  Click on the image to chat with me