Subject: Receiving Self Originated Network LSA

From: [email-masked]
Date: Thu, 7 Oct 2004 19:05:49 -0500

Hi All,

Consider this topology..
           b
() -- R1 ===== R2 -- ()
           a

Where R1 and R2 are connected by 2 interfaces a and b
and running OSPF on both of them.  () is network with
more routers.  Let say everything is in area backbone.
R1 is DR for network a and R2 is DR for network b.

Now R2 crashes and comes back up.  It establishes 
adjacency with R1 and generates a network LSA for 
network b with sequence number 1.  Now let say R2 
receives a self originated network LSA for network b 
with sequence number 7 on interface a.  What should
it do ?

1) silently drop the packet because the packet was
   received on the wrong interface ?  The LSA will
   be flushed or reoriginated when the same LSA will
   be received on network b.

2) or look up the interface that has the ip address
   mentioned in the ls id of the LSA and reoriginate
   the LSA if it is DR on that interface or flush the 
   LSA if it is not.

Regards
Mukesh

---

From: Acee Lindem <[email-masked]>
Date: Thu, 7 Oct 2004 20:33:30 -0400

Hi Mukesh,
If I understand your question, R2 should do #2 as long
as R1 and R2 are in a state >= EXCHANGE on interface a.
If R1 and R2 area in a state < EXCHANGE on interface a
R2 will drop the LS Update.

Hope this helps,
Acee
----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Sent: Thursday, October 07, 2004 8:05 PM
Subject: Receiving Self Originated Network LSA

Hi All,

Consider this topology..
           b
() -- R1 ===== R2 -- ()
           a

Regards
Mukesh

---

From: Sina Mirtorabi <[email-masked]>
Date: Fri, 8 Oct 2004 02:00:26 -0400

Mukesh,

->
->Hi Mukesh,
->If I understand your question, R2 should do #2 as long
->as R1 and R2 are in a state >= EXCHANGE on interface a.
->If R1 and R2 area in a state < EXCHANGE on interface a
->R2 will drop the LS Update.
->
->Hope this helps,
->Acee
->----- Original Message -----
->From: <[email-masked]>
->To: <[email-masked]>
->Sent: Thursday, October 07, 2004 8:05 PM
->Subject: Receiving Self Originated Network LSA
->
->
->Hi All,
->
->Consider this topology..
->           b
->() -- R1 ===== R2 -- ()
->           a
->
->Where R1 and R2 are connected by 2 interfaces a and b
->and running OSPF on both of them.  () is network with
->more routers.  Let say everything is in area backbone.
->R1 is DR for network a and R2 is DR for network b.
->
->Now R2 crashes and comes back up.  It establishes
->adjacency with R1 and generates a network LSA for
->network b with sequence number 1.

As a side note, R2 can generate network LSA if it is DR however in
normal circumstances, R1 will do a NeighborChange event (because R2 adj
goes to Init or lower) and R1 elect itself as DR. Therefore R2 cannot
become DR when it comes back up...

Sina

->Now let say R2
->receives a self originated network LSA for network b
->with sequence number 7 on interface a.  What should
->it do ?
->
->1) silently drop the packet because the packet was
->   received on the wrong interface ?  The LSA will
->   be flushed or reoriginated when the same LSA will
->   be received on network b.
->
->2) or look up the interface that has the ip address
->   mentioned in the ls id of the LSA and reoriginate
->   the LSA if it is DR on that interface or flush the
->   LSA if it is not.
->
->Regards
->Mukesh
->