Subject: RFC 3137 question

From: John Pecola <[email-masked]>
Date: Thu, 14 Oct 2004 12:06:10 -0700

Hi,

The intent of the stub router advertisement is to
advertise a path with a very high cost in the hope
that it will not be used for transiting traffic. The
same is not done for stub links. Can there be any
issues if the cost of stub links is also set to
0xFFFF?

Thanks
John

_______________________________
Do you Yahoo!?
Declare Yourself - Register online to vote today!
http://vote.yahoo.com

---

From: Sina Mirtorabi <[email-masked]>
Date: Thu, 14 Oct 2004 15:44:36 -0400

John,

->
->Hi,
->
->The intent of the stub router advertisement is to
->advertise a path with a very high cost in the hope
->that it will not be used for transiting traffic. The
->same is not done for stub links. Can there be any
->issues if the cost of stub links is also set to
->0xFFFF?

Yes you can take a suboptimal path to reach the router's stub link,
consider the following example

    R4
   /  \
  /    \
 /      \
R1--R2--R3

R2 is doing stub router advertisement, say S is the subnet for R2-R3
link.
If you advertise R2's stub link with infinity cost, R1 will take the
path R1-R4-R3-R2 to reach R2's IP address for subnet S instead of R1-R2
path.

Sina

->
->Thanks
->John
->
->
->
->
->_______________________________
->Do you Yahoo!?
->Declare Yourself - Register online to vote today!
http://vote.yahoo.com

---

From: Acee Lindem <[email-masked]>
Date: Sat, 16 Oct 2004 22:10:10 -0400

----- Original Message -----
From: "John Pecola" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, October 14, 2004 3:06 PM
Subject: RFC 3137 question

> issues if the cost of stub links is also set to

Hi John,
If there are true stub networks (i.e., not advertised in any
other router's router LSA) then I can't think of any implications.
LSInfinity is 0xFFFFFF so the total path cost to reach
the stub network shouldn't be influenced by the advertised
cost. My question for you is why should it matter? If you
know the network is a stub it is just as easy to advertise the
real cost.

Hope this helps,
Acee

---

From: Erblichs <[email-masked]>
Date: Sun, 17 Oct 2004 00:15:01 -0700

Group,

        Sorry... my two cents

        stub router advertisement...

        it will not be used for transiting
        traffic where another normal/lower
        path cost exists..

        If a path is advertised and it is the
        ONLY path available, it still is going
        to be used, no matter the cost..

        Mitchell Erblich
        ---------------------

---

From: John Pecola <[email-masked]>
Date: Mon, 18 Oct 2004 11:27:28 -0700

Hi Acee,

I was thinking of the true stub router scenario and in
that case, as you have pointed out, there are no
implications if the cost is set to 0xFFFF. But there
can be a case, like the one pointed out by Sina in
this thread, where it is important to set the stub
link cost to its actual value. The rfc doesnt mention
this and I coulnt think of it :-)

Thanks
John