Subject: Re: Vlink Question

From: Naresh Paliwal <[email-masked]>
Date: Tue, 21 Dec 2004 17:15:36 +0530

Nitin,
Every Virtual link belongs to Backbone, and when the cost of a virtual
link changes, a new router-LSA should be originated for the backbone
area. 

This should be enough to convey the change to other routers. There is no
need to MaxAge the last LSA, the INCREASED SEQUENCE NUMBER should be
enough to solve the purpose.

And as far as I know, none of the implementation manually allows to
choose/switch the virtual-link interface.

Regards
-Naresh

-----Original Message-----
From: Mailing List [mailto:[email-masked]] On Behalf Of Nitin
Kakkar
Sent: Tuesday, December 21, 2004 2:42 PM
To: [email-masked]
Subject: Vlink Question

Hello,
  I have a vlink related question. Please consider the following
topology.
Two routers (RTA & RTB) have two interfaces connected between them. A
VLINK
is configured between RTA & RTB. Initially the interface cost of e1 was
1000
and interface cost of e0 was 100. So while establishing VLINK the
interface
e0 was chosen as outgoing interface.

       vlink with area 1 as the transit
          ********************************
       cost 100
      e0                  	               e0
                      area 1
          -------------------------------
	RTA    			   		   RTB
         -------------------------------
                    area 1
      e1		                           e1
      cost 1000

Now the cost of interface e1 has been changed from 1000 to 1. So now it
offers the best out going interface for VLINK.
To update the VLINK and change the out going interface to e0. should we
1) Bring down the VLINK & Bring it UP again.
2) Should we flush LSA's previously originated while establishing VLINK
over
interface e0
3) Is there any mechanism defined to switch over VLINK interface.

Thanks & Regards
Nitin

---

From: Naresh Paliwal <[email-masked]>
Date: Tue, 21 Dec 2004 17:15:36 +0530

Nitin,

Regards
-Naresh

-----Original Message-----

Hello,

Thanks & Regards
Nitin