Subject: Re: draft-ietf-ospf-te-node-addr-01

From: Vivek Dubey <[email-masked]>
Date: Sat, 29 Jan 2005 07:19:01 -0000

Hi Acee,
Pls see comments inline.

>Quite the contrary, the address is to be used as an endpoint for TE >tunnels
vivek> Agreed. Let me clarify what i meant (probably conveyed it wrongly). To quote from draft:

Section 1: 3rd Para
--------------------
Currently routers in an OSPF network can only use CSPF to
compute MPLS TE LSPs to the router ID or the local addresses of TE
enabled links of a remote router. This restriction arises because
OSPF TE extensions [OSPF-TE, OSPFv3-TE] only advertise the router ID
and the local addresses of TE enabled links of a given router. Other
routers in the network can populate their traffic engineering
database (TED) with these local addresses belonging to the
advertising router. However they cannot populate the TED with other
local addresses of the advertising router i.e. loopback and non-TE
interface addresses.

vivek> Than this information falls more in the domain of "router information" instead of router(s) TE info/capabilities. Further is there any particular reason to limit this information to area scope?

>Not on this list, the shortest path always wins ;^)
vivek> Agreed.

Thanks
Vivek

---

From: Acee Lindem <[email-masked]>
Date: Sat, 29 Jan 2005 08:40:12 -0500

Hi Vivek,

Vivek Dubey wrote:

> Hi Acee,
> Pls see comments inline.
>
> >Quite the contrary, the address is to be used as an endpoint for TE 
> >tunnels
I'm not sure what part of this is confusing. It says the local addresses 
are used
to populate the traffic engineering database. Hence, I don't see why 
this TLV shouldn't
be included in the TE LSAs. Can you indicate specifically what text you 
think needs to
be changed? IMHO, there is value to keeping the TE information together 
in the
TE LSAs.

>
> vivek> Than this information falls more in the domain of "router 
> information" instead of router(s) TE info/capabilities. Further is 
> there any particular reason to limit this information to area scope?
>
The current TE LSAs are area scoped. This is to be used for the TE 
application.

> <http://clients.rediff.com/signature/track_sig.asp>

---

From: Rahul Aggarwal <[email-masked]>
Date: Sat, 29 Jan 2005 11:45:32 -0800

Hi Vivek,

Pls see comments inline.

Section 1: 3rd Para
--------------------

vivek> Than this information falls more in the domain of "router information" instead of router(s) TE
>info/capabilities. Further is there any particular reason to limit this
> information to area scope?

This is TE specific information and should be advertised as
part of the TE LSAs.  It is limited to area scope as TE information, as
defined currently, is area scoped.

rahul

vivek> Agreed.

Thanks
Vivek