Subject: Equal-cost path

From: Ilan Bercovich <[email-masked]>
Date: Sun, 10 Apr 2005 15:12:27 +0300

Hi,

When not using "equal-cost multipath",
Which equal-cost path should be selected?

Thanks -
Ilan

---

From: Kireeti Kompella <[email-masked]>
Date: Tue, 12 Apr 2005 15:40:29 -0700

> Which equal-cost path should be selected?

The one that's more equal than the rest.

Kireeti.
-------

---

From: Yasuhiro Ohara <[email-masked]>
Date: Wed, 13 Apr 2005 08:01:09 +0900

Ahahaha,
what are you talking about Kireeti !? ;p)

The correct answer would be "It's an implementation specific issue".

One should recognize ECMP as a property of OSPF (dijkstra) algorithm,
rather than a feature. It means "you can use either path as far as
those paths are equal cost". Which path to use actually is totally left
to the calculating router. Whichever the path is selected by the router
whole OSPF domain will work fine (in terms of issue regarding routing loops).

OSPF does not specify which path (out of ECMP) should be used/preferred,
it's totally left to a implementor.

regards,
yasu

From: Kireeti Kompella <[email-masked]>
Subject: Re: Equal-cost path
Date: Tue, 12 Apr 2005 15:40:29 -0700

---

From: Kireeti Kompella <[email-masked]>
Date: Tue, 12 Apr 2005 17:12:58 -0700

> what are you talking about Kireeti !? ;p)

Four legs good, two legs better, one path best.

> The correct answer would be "It's an implementation specific issue".
...
> Whichever the path is selected by the router whole OSPF domain will
> work fine (in terms of issue regarding routing loops).

I think we're saying the same thing, just using different words.
But you said it somewhat more clearly.

Kireeti.
-------