Subject: Re: Update to OSPF Hello procedure[draft-kou-ospf-immediately-replying-hello-00.txt]

From: Zengjie Kou <[email-masked]>
Date: Wed, 4 Jan 2006 09:58:38 +0800

----- Original Message ----- 
From: "Paul Jakma" <[email-masked]>
To: <[email-masked]>
Sent: Sunday, January 01, 2006 12:05 AM
Subject: Re: Update to OSPF Hello procedure[draft-kou-ospf-immediately-replying-hello-00.txt]

> Hi,
> 
> On Thu, 29 Dec 2005, Kouzengjie wrote:
> 
>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>> The draft can be found here:
>> http://www.ietf.org/internet-drafts/draft-kou-ospf-immediately-replying-hello-00.txt
> 
> GNU Zebra's (and hence Quagga's) ospfd has done something like this 
> for a long time now (a subset at least, send hello immediately if 
> neighbour state changes into state Init).
> 
> One thing, might it be an idea to specify that the Immediate Hello be 
> /independent/ of the Hello-Interval timer? (ie dont set or reset the 
> interface's Hello timer because of any Immediate Hello sent). 
> Otherwise, there'll be strong tendency for the HelloInterval timers 
> across routers to latch. Not sure how much this matters.
>
Yes, Immediate Hello is independent of HelloInterval timer.
It is in favor of compatibility.
 
> Also, it might be an idea to add some state (e.g. a delay factor, 
> some arbitrary protocol constant, 100ms or somesuch) to prevent 
> Immediate-Hello storms if, for whatever reason, neighbour states fail 
> to progress pass ExStart and fall back to Init. Some types of links 
> are quite sensitive to L2 congestion for example.
> 
Yes, this may be a good idea. We consider that it is a option of Immediate Hello.

> 6.1.1. Is there a good reason why pre-2-Way Immediate-Hellos are to 
> be sent unicast?
> 
> If you happen to process multiple neighbour state changes (e.g. 
> because of the delay factor on a previous immediate hello, or because 
> the implementation chooses to define 'immediate' as 'very small 
> delay'), one Immediate-Hello to AllSPFRouters can take care of all of 
> them - rather than having to send multiple unicast hellos to each 
> neighbour.
> 
> I.e. it might be an idea to just drop the modifications proposed in 
> 6.1.1.
> 
If Immediate Hello is multicast, all routers attached the ospf networks will handle
all Immediate hellos,which consumes lots of cost. So, unicast is an appropriate mechanism 
which finishes all in the peer of sending hello.

Thanks
Kou.

> regards,
> -- 
> Paul Jakma [email-masked] [email-masked] Key ID: 64A2FF6A
> Fortune:
>  Earth men are real men!

---

From: Paul Jakma <[email-masked]>
Date: Wed, 4 Jan 2006 19:37:49 +0000

On Wed, 4 Jan 2006, Zengjie Kou wrote:

>> /independent/ of the Hello-Interval timer? (ie dont set or reset 
>> the interface's Hello timer because of any Immediate Hello sent). 
>> Otherwise, there'll be strong tendency for the HelloInterval 
>> timers across routers to latch. Not sure how much this matters.

> It is in favor of compatibility.

Ok, should the draft then explicitely note that Immediate-Hello 
ideally should not affect (e.g. reset) any hello timer? (so as to 
avoid the timed-interval hello synchronising).

> If Immediate Hello is multicast, all routers attached the ospf 
> networks will handle all Immediate hellos,which consumes lots of 
> cost. So, unicast is an appropriate mechanism which finishes all in 
> the peer of sending hello.

It will have a higher cost though.

regards,
-- 
Paul Jakma	[email-masked]	[email-masked]	Key ID: 64A2FF6A
Fortune:
"Well hello there Charlie Brown, you blockhead."
-- Lucy Van Pelt

---

From: Erblichs <[email-masked]>
Date: Wed, 4 Jan 2006 13:26:12 -0800

Paul Jakama, et al,

> avoid the timed-interval hello synchronising).

	Could I add that, independent of whether a hello is
	immediately sent upon link up... That the hello timer's
	t1 (2nd hello) pkt be randomly picked between 0 and
	the hello interval. Then the subsequent hellos be sent
	at the agreed upon interval.

	This should allow a group of routers to independently ramdomize
	their hello pkts during the agreed upon hello interval.

	Mitchell Erblich