Subject: draft-ietf-ospf-mib-update-08.txt

From: Vivek Dubey <[email-masked]>
Date: Mon, 30 Jan 2006 11:35:17 -0000

Hi,
Few queries on "draft-ietf-ospf-mib-update-08.txt"

1) MAX-ACCESS for Table index is mentioned as "read-only"

   Shouldn't it be: "not-accessible"

E.g: 
    ospfHostIpAddress OBJECT-TYPE 
         SYNTAX       IpAddress 
         MAX-ACCESS   read-only 
         STATUS       current 
         DESCRIPTION 
            "The IP Address of the Host." 
         REFERENCE 
            "OSPF Version 2, Appendix C.7 Host route parameters" 
         ::= { ospfHostEntry 1 }

2) OSPF Trap

ospfVirtIfStateChange NOTIFICATION-TYPE 
         OBJECTS { ospfRouterId, -- The originator of the trap 
            ospfVirtIfAreaId, 
            ospfVirtIfNeighbor, 
            ospfVirtIfState  -- The new state 
            } 

Object "ospfVirtIfState" is a column in ospfVirtIfTable 
And "ospfVirtIfAreaId" , "ospfVirtIfNeighbor" index in same table.

Inofrmation about "ospfVirtIfState" implies knowledge of "ospfVirtIfAreaId" , "ospfVirtIfNeighbor".

Should than these ("ospfVirtIfAreaId" , "ospfVirtIfNeighbor") be part of Trap Object.

Thanks
Vivek

---

From: Don Goodspeed <[email-masked]>
Date: Mon, 30 Jan 2006 11:25:12 -0800

Vivek,
 
On #1 yes it "should" be but this is a grand-fathered MIB originally created
before that
rule became mandatory so it would remain until the MIB (or the MIB table) is
deprecated
and replaced.
 
On #2, once again, this is how it existed in the original MIB.  If this MIB
were to be written
from scratch today, yes those extra OIDs would be deemed redundant.  But
once again
since this was in the original MIB definition, the NOTIFICATION would need
to be replaced
for this to occur (can only add to NOTIFICATIONs, not delete or modify).
 
-don

  _____  

From: [email-masked]
[mailto:[email-masked]] On Behalf Of Vivek Dubey
Sent: Monday, January 30, 2006 3:35 AM
To: Mailing List
Subject: draft-ietf-ospf-mib-update-08.txt

Hi,

E.g: 

2) OSPF Trap

Inofrmation about "ospfVirtIfState" implies knowledge of "ospfVirtIfAreaId"
, "ospfVirtIfNeighbor".

Should than these ("ospfVirtIfAreaId" , "ospfVirtIfNeighbor") be part of
Trap Object.

Thanks
Vivek

<http://adworks.rediff.com/cgi-bin/AdWorks/sigclick.cgi/www.rediff.com/signa
ture-home.htm/1507191490@Middle5?PARTNER=3>