Subject: Re: Detecting router id change in p2p-over-lan connection

From: Kalyan Bade <[email-masked]>
Date: Mon, 20 Feb 2006 11:57:40 -0800

Hi Acee,

> As Dave points out, a point-to-point network is explicitly defined as
a
> connection between
> a single pair of routers. Also, RFC 2328 dictates that router-id be
used
> to identify neighbors
> on point-to-point links. Hence, what
> draft-ietf-isis-igp-p2p-over-lan-05.txt is recommending
> is to take the path of least resistance and handle router-id changes
by
> letting the current
> adjacency time out before forming a new one. 

This might not work if the interface is defined as demand circuit.

Thanks,
Kalyan.

---

From: Acee Lindem <[email-masked]>
Date: Mon, 20 Feb 2006 16:49:09 -0500

Hi Kalyan,

>This might not work if the interface is defined as demand circuit.
Good point - We're in the process of discussing whether this behavior 
should be in the
draft. Possibly, handling detection of a router-id change on a P2P over 
LAN link
differently than a normal P2P link may be a bad idea.

Thanks,
Acee