Subject: Re: Cost calculating in the OSPF area

From: "Jevos, Peter" <[email-masked]>
Date: Thu, 9 Feb 2006 10:55:41 +0100

Thanks for your answers,

I think I was wrong when I specified my question. I'm looking for some
tool or program , which calculate shortest path. Every cost on the links
is defined but I'd like to know if something happened (changed ) when I
add a new router into system. I know it is matter of Dijsktra's
algorithm, all I'm asking if somenone's using some program to calulate
the shortest path

Thanks 

Pet  

-----Original Message-----
From: Mailing List [mailto:[email-masked]] On Behalf Of Dave
Katz
Sent: Thursday, February 09, 2006 7:30 AM
To: [email-masked]
Subject: Re: Cost calculating in the OSPF area

The short version is that OSPF is a lousy mechanism for doing traffic
engineering.  You can influence path selection by the use of areas
and/or link costs, but at the end of the day it will do what it does.

If you really need engineered paths, there are more appropriate
mechanisms than OSPF.

--Dave

On Feb 8, 2006, at 3:33 PM, Erblichs wrote:

> Pet,
>
> 	First, it doesn't matter what the costs are if their
> 	is only one path from each source to each destination.
> 	
> 	Second, if their is only one BB ABR (some ABRs don't have
> 	a BB area), paths to the BB will transit the BB ABR and
> 	again, it doesn't make a diff as to the cost of those paths.
>
> 	Third, if you admin set the priority so that more than 1
> 	router can be a DR, then output costs come into play,
> 	else the output cost of the DR is irrevalent.
>
> 	So, all we need to determine the say X routes that
> 	each have alternate paths.
>
> 	The preferred paths should have a lowest summed costs, how much
> 	lower is irrelevent.
>
> 	The key is that primary paths SHOULD use as one or more
> 	key values as to bandwidth capacity of the line, delays
> 	introduced, costs thru a link, etc. But again this only
> 	makes a diff for the paths that have alternates.
>
> 	Thus Peter, if this doesn't simplify what you are asking,
> 	because you have a large number of alternate possible paths
> 	and all routers can be DR/BRS, and you have multiple BB ABRs,
> 	then you need a consultant.
>
> 	Mitchell Erblich
> 	-------------------
>
> 	
>
> 	
> "Jevos, Peter" wrote:
>>
>> Hello all,
>>
>> I have one questions about ospf metric. I designed a big network with

>> at least one hundred routers with ospf. I'd like to know if exists 
>> some utility, tool, program, software, excel sheet or whatever, which

>> simulate or calculate ospf cost.
>> My problem is following. When I add one or more router into this 
>> system, traffic could change because of lower value of added links 
>> and it could affect almost entire traffic.
>> Thanks a lot
>> Pet
>

---

From: "Naidu, Venkata" <[email-masked]>
Date: Fri, 10 Feb 2006 16:51:03 -0500

-> I think I was wrong when I specified my question. I'm 
-> looking for some tool or program , which calculate shortest path. 
-> Every cost on the links is defined but I'd like to know if 
-> something happened (changed ) when I add a new router into system. 

 Yes, there are programs to compute the difference in SPT for a
 single change in topology (like an edge metric change, adding a
 new node etc.) 

-> I know it is matter of Dijsktra's algorithm, all I'm asking if 

 This is called Dynamic Shortest Paths in algorithms literature.
 You could also do Static Dijkstra from scratch with the change
 in topology and compare new SPT vs old SPT. But that is lot of 
 work.

-> somenone's using some program to calulate the shortest path

 For a simulation and evaluation of different dynamic shortest path
 algorithms: http://www.dis.uniroma1.it/~demetres/experim/dsp/ 

 Original version of Ramalingam/Rep's algorithm is called,
 "An incremental algorithm for a generalization of the shortest path
 problem". http://citeseer.ist.psu.edu/ramalingam92incremental.html

Hope this helps,
Venkata.