Subject: Cost calculating in the OSPF area

From: "Jevos, Peter" <[email-masked]>
Date: Wed, 8 Feb 2006 10:30:28 +0100

Hello all,

I have one questions about ospf metric. I designed a big network with at
least one hundred routers with ospf. I'd like to know if exists some
utility, tool, program, software, excel sheet or whatever, which
simulate or calculate ospf cost.
My problem is following. When I add one or more router into this system,
traffic could change because of lower value of added links and it could
affect almost entire traffic.
Thanks a lot 
Pet

---

From: Erblichs <[email-masked]>
Date: Wed, 8 Feb 2006 15:33:09 -0800

Pet,

	First, it doesn't matter what the costs are if their
	is only one path from each source to each destination.
	
	Second, if their is only one BB ABR (some ABRs don't have
	a BB area), paths to the BB will transit the BB ABR and
	again, it doesn't make a diff as to the cost of those paths.

	Third, if you admin set the priority so that more than 1
	router can be a DR, then output costs come into play,
	else the output cost of the DR is irrevalent.

	So, all we need to determine the say X routes that
	each have alternate paths.

	The preferred paths should have a lowest summed costs, how much
	lower is irrelevent.

	The key is that primary paths SHOULD use as one or more
	key values as to bandwidth capacity of the line, delays
	introduced, costs thru a link, etc. But again this only
	makes a diff for the paths that have alternates.

	Thus Peter, if this doesn't simplify what you are asking,
	because you have a large number of alternate possible paths
	and all routers can be DR/BRS, and you have multiple BB ABRs,
	then you need a consultant.

	Mitchell Erblich
	-------------------

---

From: Dave Katz <[email-masked]>
Date: Wed, 8 Feb 2006 22:29:34 -0800

The short version is that OSPF is a lousy mechanism for doing traffic  
engineering.  You can influence path selection by the use of areas  
and/or link costs, but at the end of the day it will do what it does.

If you really need engineered paths, there are more appropriate  
mechanisms than OSPF.

--Dave