Subject: [OSPF] LS Updated and Ack on multi access network

From: "Amit Grover" <[email-masked]>
Date: Sun, 9 Apr 2006 15:58:15 -0700

Hi all,

I was reading OSPF rfc 2328 and Section 13.5 and I got confused little
bit.

If I have four routers on multi access network let's say R1-R4. R1 and
R2 are DR and BDR respectively.

R3 and R4 will form adjacency with R1 and R2.  So in R1's neighbor table
there are three neighbors which are FULL (R2 R3 and R4)

Now R1 receives new LSA from outside and it decides to flood it on this
multi access network. Since R1 knows that it is DR or network it sends
the LS Update to AllSPFRouter (224.0.0.5)

My question is that in whose neighbor's retransmission list does it put
this LS update? R2, R3 or R4?

Since R1 is only going to receive one ACK who will generate this ACK R2
or R3 or R4?

Any ideas?

Thanks

Amit

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: Erblichs <[email-masked]>
Date: Sun, 09 Apr 2006 16:59:48 -0700

Amit Grover,

	First, you missed that R1 needs to somehow ack that
	it has recieved the LSA from the outside.

	To verify that each nbr recieves a LSA, all nbrs that need
	the LSA should have the LSA placed on their retransmion
	list when the LSA is first sent to them.

	FYI: All OSPF speaking routers need a rexmit list or one
	that is emulated for each router.

	If acks are not then recived from one or more nbrs, the LSA can
	then be retransmited to the ones that have not acked the LSA
	to R1.

	Mitchell Erblich
	-----------------------

> Amit Grover wrote:
> If I have four routers on multi access network lets say R1-R4. R1 and
> R3 and R4 will form adjacency with R1 and R2.  So in R1s neighbor
> table there are three neighbors which are FULL (R2 R3 and R4)
> 
> 
> 
> Now R1 receives new LSA from outside and it decides to flood it on
> this multi access network. Since R1 knows that it is DR or network it
> sends the LS Update to AllSPFRouter (224.0.0.5)
> 
> 
> 
> My question is that in whose neighbors retransmission list does it
> put this LS update? R2, R3 or R4?
> 
> 
> 
> Since R1 is only going to receive one ACK who will generate this ACK
> R2 or R3 or R4?
> 
> 
> 
> Any ideas?
> 
> Thanks
> 
> Amit
> 
> 
> 
>     ---------------------------------------------------------------