Subject: [OSPF] Ospfv3 Options

From: "Vivek Dubey" <[email-masked]>
Date: 19 Apr 2006 07:56:56 -0000

draft-ietf-ospf-ospfv3-update-08:
A.2  The Options field - V6 bit and R-bit

How does Ospf for Ipv6 decides whether to "set/clear" these bits in Options advertised. Are they part of configuration? 
Or "draft-ietf-ospf-cap-08.txt" could be used to advertise these capabilities.

Thanks
Vivek

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: Acee Lindem <[email-masked]>
Date: Wed, 19 Apr 2006 05:45:53 -0400

Hi Vivek,

>How does Ospf for Ipv6 decides whether to "set/clear" these bits in Options advertised. Are they part of configuration? 
The R bit allows a router to be reachable via it's stub networks without 
being used
for transit traffic. I would expect this to be a configuration option 
for multi-homed
hosts. It also could be set in situations where the router is running 
BGP and it has
not yet converged (ala, RFC 3137).

The V6 bit was an attempt at supporting multiple address families in 
OSPFv3. However,
more protocol constructs than this bit are needed. You can reference the 
drafts we are
currently considering for support of multiple topologies/address families.

>Or "draft-ietf-ospf-cap-08.txt" could be used to advertise these capabilities.
This draft wouldn't be applicable here. It is for optional OSPFv2/OSPFv3 
capabilities.

Hope this helps,
Acee

>Thanks
>Vivek
>
> 
>
>
>
>
>
>
>  
>
>------------------------------------------------------------------------
>