Subject: Re: [OSPF] question about generating default route NSSA

From: "badvel vishnu reddy" <[email-masked]>
Date: 24 Apr 2006 22:41:50 -0000

Hi 
  Have a question regarding the router that generates the NSSA default. 

I have two ABR's generating default NSSA LSA. I know that the one with the highest routerID should continue generating and the one with lowest routerID stop generating. I am not able to understand the advantage in choosing the router that generates the TYPE7 default. 
If both of them continue generating the default type7 LSA then the routers near to the first ABR will choose the first ABR as next hop and the routers near to the second ABR can choose the second ABR as the next hop.Instead if only one of them generates the type7 default then the routers need to select this ABR only even if there is one more ABR very near to it. Appreciate the responses.

Thanks

Regards,
Vishnu

Regards,
Vishnu

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: Acee Lindem <[email-masked]>
Date: Mon, 24 Apr 2006 19:11:14 -0400

Hi Vishnu,

>I have two ABR's generating default NSSA LSA. I know that the one with the highest routerID should continue generating and the one with lowest routerID stop generating. I am not able to understand t…
I also see no advantage. The rule you quote is from RFC 2328, 12.4.4.1.
It only applies if the AS external (type 5) or NSSA (type 7) LSAs have the
same non-zero forwarding addresses. In the case of the type 7 default LSAs
injected by the ABRs, the forwarding address should be zero.

Thanks,
Acee

>------------------------------------------------------------------------
>