Subject: [OSPF] Ospfv2-Multiple Interfaces Same subnet

From: "Vivek Dubey" <[email-masked]>
Date: 19 Apr 2006 07:06:49 -0000

Reposting for views. How open is WG to usage of "ospfNbrAddressLessIndex" MIB object as differentiator (when NBR IP is same) to represent the neighbor on each of the interface.

On Fri, 24 Mar 2006 Vivek Dubey wrote :
>Broadcast Interfaces (Multiple interfaces in the same subnet):
>Router R1:
>----------
>Interfaces: I11(198.10.10.1/24) and I12(198.10.10.2/24)
>
>Router R2:
>----------
>Interface I21(198.10.10.3/24)
>
>At R1 two NBR FSM's can be run for NBR IP:198.10.10.3 (i.e R2) as per
>RFC 2328 Appendix F(one possible solution).
>
>Wondering which of the two NBR FSM(s) would be used to represent "OSPF Neighbor Table" of the standard OSPFv2 MIB.
>
>Looks like "ospfNbrAddressLessIndex" defined in MIB would be of help
>but its definition as of now dont allow its usage.
>
>Any thoughts?
>
>-Vivek
_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: Acee Lindem <[email-masked]>
Date: Wed, 19 Apr 2006 15:42:03 -0400

>Reposting for views. How open is WG to usage of "ospfNbrAddressLessIndex" MIB object as differentiator (when NBR IP is same) to represent the neighbor on each of the interface.
Hi Vivek,
Do you actually have an implementation that allows this or is it a 
hypothetical question?
Anyway, since the technique is documented in an appendix and there are 
multiple options,
I'd prefer we don't try and solve the problem in the OSPF WG. As for 
your suggestion,
it appears to me that it would be compatible but you may confuse 
programs that query
the MIB.

Thanks,
Acee

>------------------------------------------------------------------------
>