Subject: RE: [OSPF] LS Updated and Ack on multi access network

From: "Amit Grover" <[email-masked]>
Date: Sun, 9 Apr 2006 21:14:37 -0700

-----Original Message-----
From: Erblichs [mailto:[email-masked]] 
Sent: Sunday, April 09, 2006 5:00 PM
To: Amit Grover
Cc: [email-masked]
Subject: Re: [OSPF] LS Updated and Ack on multi access network

Amit Grover,

	First, you missed that R1 needs to somehow ack that
	it has recieved the LSA from the outside.
[Amit Grover] yeah I didn't mention this explicitly but you are right.

	To verify that each nbr recieves a LSA, all nbrs that need
	the LSA should have the LSA placed on their retransmion
	list when the LSA is first sent to them.

 [Amit Grover] Hi, what I am missing here is that neighbors do not know about this LSA until R1 sends LS Update (with DA = 224.0.0.5). So why does neighbor put this LSA in their retransmission list. It's R1 who should put this LSA in each of it's neighbor's retransmission list so that if any of the neighbor (R2, R3, R4) doesn't ACK back then it can retransmit this LSA only to that neighbor. Isn't it?

	FYI: All OSPF speaking routers need a rexmit list or one
	that is emulated for each router.

	If acks are not then recived from one or more nbrs, the LSA can
	then be retransmited to the ones that have not acked the LSA
	to R1.

	Mitchell Erblich
	-----------------------

> Amit Grover wrote:
> 
> Hi all,
> 
> 
> 
> I was reading OSPF rfc 2328 and Section 13.5 and I got confused little
> bit.
> 
> 
> 
> If I have four routers on multi access network let’s say R1-R4. R1 and
> R2 are DR and BDR respectively.
> 
> 
> 
> R3 and R4 will form adjacency with R1 and R2.  So in R1’s neighbor
> table there are three neighbors which are FULL (R2 R3 and R4)
> 
> 
> 
> Now R1 receives new LSA from outside and it decides to flood it on
> this multi access network. Since R1 knows that it is DR or network it
> sends the LS Update to AllSPFRouter (224.0.0.5)
> 
> 
> 
> My question is that in whose neighbor’s retransmission list does it
> put this LS update? R2, R3 or R4?
> 
> 
> 
> Since R1 is only going to receive one ACK who will generate this ACK
> R2 or R3 or R4?
> 
> 
> 
> Any ideas?
> 
> Thanks
> 
> Amit
> 
> 
> 
>     ---------------------------------------------------------------
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ospf

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: Erblichs <[email-masked]>
Date: Sun, 09 Apr 2006 19:57:15 -0700

Inline..

	Mitchell Erblich

>  [Amit Grover] Hi, what I am missing here is that neighbors do not know about this LSA until R1 sends LS Update (with DA = 224.0.0.5). So why does neighbor put this LSA in their retransmission list…

	R1 has separate rexmit lists for each nbr (R2, R3, R4)..
	They reside on R1.

	R1 then "repeatedly" resends the LSAs to each nbr, 
	if the nbr (R2, R3, R4) doesn't ack..

	Note, some implementations CAN limit the number of rexmits
	to a specific nbr. This is implementation specific.

	ONLY if the then recieved LSA is then acked back to
	R1 does the Nbr (R2, R3, R4) then decide whether it will 
	forward the LSA. If it decides that it will then forward the
	LSA, does it then place the LSA again on its nbr's
	rexmit lists and is then sent. This process repeats
	based on the LSA type and the flooding scope of the
	LSA.

> > If I have four routers on multi access network lets say R1-R4. R1 and
> > R3 and R4 will form adjacency with R1 and R2.  So in R1s neighbor
> > My question is that in whose neighbors retransmission list does it