Subject: [OSPF] draft-ietf-pce-disco-proto-ospf-03.txt

From: "Greg Mirsky" <[email-masked]>
Date: Thu, 12 Apr 2007 17:03:52 -0700

Dear Editors,
I think that wording of chapter 3.3 Flooding Scope can use some refinement. Currently it reads:
"   The flooding scope for PCE information advertised through OSPF can be 
   limited to one or more OSPF areas the PCE belongs to, or can be 
   extended across the entire OSPF routing domain.  
    
   Note that some PCEs may belong to multiple areas, in which case the 
   flooding scope may comprise these areas. This could be the case for 
   an ABR for instance advertising its PCE information within the 
   backbone area and/or a subset of its attached IGP area(s). "

But the scope of OSPFv2 or OSPFv3 Router Information LSA can be either an Area or Autonomous System, but it can not be several areas. If PCED TLV needs to be flooded through some but not all areas, the proper Router Information LSA must be originated by the PCE into each area. And here I have a question - would PCED TLV MUST be the same in all areas or it MAY be different?

Regards,
Greg

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: JP Vasseur <[email-masked]>
Date: Thu, 12 Apr 2007 20:13:23 -0400

On Apr 12, 2007, at 8:03 PM, Greg Mirsky wrote:

> But the scope of OSPFv2 or OSPFv3 Router Information LSA can be  
> either an Area or Autonomous System, but it can not be several  
> areas. If PCED TLV needs to be flooded through some but not all  
> areas, the proper Router Information LSA must be originated by the  
> PCE into each area. And here I have a question - would PCED TLV  
> MUST be the same in all areas or it MAY be different?
If a PCE acting as an ABR (attached to area 0 and area 1) originates  
an LSA Type 10 in area 0 and area 1, each LSA could be different indeed.

Thanks.

JP.