Subject: [OSPF] IETF 69 OSPF WG Meeting Minutes

From: Acee Lindem <[email-masked]>
Date: Thu, 26 Jul 2007 11:06:28 -0400

Thanks to Michael Barnes for taking these minutes.

OSPF WG Meeting - Chicago - July 24, 2007
     Scribe: Michael Barnes ([email-masked])

13:22 Review agenda - Acee Lindem

13:25 Review working group progress - Abhay Roy

     OSPFv3 MTR draft needs more discussion
     OSPFv2 HMAC-SHA1 draft needs more discussion

13:30 OSPFv3 MIB - Acee presenting slides for Dan Joyal

     Want to do WG Last Call soon

13:35 Draft Authentication/Confidentiality for OSPFv2- Suresh Melam

Acee:
     A single hop virtual-link packets could have the same src/dst as  
non-VL
     packets on the link.

Vishwas Manral:
     SPD is defined by IPSec, but is internal to an
     implementation so not limited to what RFC specifies. But
     implementations don't support it.

Bill Atwood:
     Work being presented in routing security WG for
     automatic  rekeying. Work going on in PIM for rekeying to protect
     link-local addressing. The last slide references the automatic
     rekeying, it should be linked to the other work.

Acee: Straw poll as to whether to make WG document, some support, a
          couple of folks against. Taking it to the list.

13:54 Extensions to OSPF for Inter-AS TE - Mach Chen

Dave Ward:
     Asking if the working groups feels a new link type is required

Acee:
     Doesn't seem like this is a link

Kireeti Kompella:
     Should just be a TE LSA. Do not have adj or hellos, but want to  
add into
     database to do calculations.

Dave Ward:
    Do we need to carry the AS number and what is it used for?

Adrian:
    Can be used for signalling (details lost here)

Kireeti:
    Useful to carry the Router ID, ambivilent about the AS number

Dave:
    Would like to see why, where, when and applicability for carrying  
the
    AS number.  Router ID is sufficient but necessary. AS number is  
not necessary

Adrian:
    From CCAMP: close to last calling it.

Acee:
     Seems like this is a connection to an AS as opposed to a link.  
Do we really
     want to call it a link, or should be a top level TLV? Two top  
levels now:
         Link TLV and Router Address TLV.

Mach:
    ?

Acee:
     So it is tied to the link.

Abhay:
    The link in a TE LSA are additional attributes to the physical link.

Kireeti
    There is a link, it's passive

Acee:
     AS Number is passive information

Kireeti:
     Since no adjacency want full TE info, can't do calculation if  
don't have
     A2-B1 link

     Would like explicit statement saying no hellos and no adjacency.
     Draft implies that. Do not want an inter-AS adjacency.

Abhay:
    Need a new link type?

Kireeti:
    Could be point to point

Dave:
    Doesn't matter because it's passive

Kireeti:
    Don't think a new type is needed.

Mach:
    Need a new type to indicate that is inter-AS

Adrian:
    Point was that inter-AS TE how careful do you want to be to avoid  
confusion,
    A new type avoids any ambiguity. If not worried about ambiguity a  
new
    type may not be needed

14:15 OSPF Charter Update - Acee

Decided to make an incremental update this time around.

Dave W:
     Solution to separate routing from non-routing information

Abhay:
     Okay to solve in v3 only?

Dave:
    Advise to solve in v2 since it's so widely deployed
    Convergence is highest priority, so need a way to prioritize routing
    over non-routing.

Acee:
     Reason?

Dave:
     Protect, preserve fastest possible convergence time.
     It's something that's been worked on in ISIS for a while now.

Acee:
     Multiple instaces supported by OSPFv3

Dave:
     Think we need to have a solution for OSPFv2, not sufficient to  
require
     changing to OSPFv3.

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: "Michael Barnes" <[email-masked]>
Date: Thu, 26 Jul 2007 08:12:18 -0700

FYI Times are PDT