Subject: [OSPF] About the self-originated LSAs

From: fuchao <[email-masked]>
Date: Mon, 22 Oct 2007 21:39:10 +0800

Hi All,
 
RFC 2740 says 
"3.6.  Definition of self-originated LSAs   In IPv6 the definition of a self-originated LSA has been simplified   from the IPv4 definition appearing in Sections 13.4 and 14.1 of   [Ref1]. For IPv6, self-originated LSAs are those LSAs whose   Advertising Router is equal to the router's own Router ID."
 
Because the link local address on one link is unique, we also can know the Link-LSA is self-originated if the link local address in the LSA's header is same as the interface's which receives the LSA. It is useful when the router id changes. If we do so, OSPFv3 will work better, won't it?
 
Regards
Fu Chao
_________________________________________________________________
用 Live Search 搜尽天下资讯！
http://www.live.com/?searchOnly=true

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: Acee Lindem <[email-masked]>
Date: Mon, 22 Oct 2007 09:58:49 -0400

Hi Fu,

On Oct 22, 2007, at 9:39 AM, fuchao wrote:

> Hi All,
>
> RFC 2740 says
> "3.6.  Definition of self-originated LSAs
>
>    In IPv6 the definition of a self-originated LSA has been simplified
>    from the IPv4 definition appearing in Sections 13.4 and 14.1 of
>    [Ref1]. For IPv6, self-originated LSAs are those LSAs whose
>    Advertising Router is equal to the router's own Router ID."
>
> Because the link local address on one link is unique, we also can  
> know the Link-LSA is self-originated if the link local address in  
> the LSA's header is same as the interface's which receives the LSA.  
> It is useful when the router id changes. If we do so, OSPFv3 will  
> work better, won't it?

The details of how dynamic configuration changes are handled have  
typically not been documented. As an implementer, you are free to  
take advantage of this assertion above. However, I personally  
wouldn't do much to optimize for the router ID change event since it  
should be rare. Rather, I'd optimize to avoid Router ID changes  
unless necessary.

Thanks,
Acee

>
> Regards
> Fu Chao
>
>
>
> 使用新一代 Hotmail，更强大、更安全、更多存储空 
> 间！ 立刻体验！