Subject: [OSPF] next hop determination

From: [email-masked]
Date: Wed, 24 Oct 2007 10:55:53 EDT

It may sound like a newbie question and therefore I would be grateful if  
someone will help with clarification:
 
How is the next hop wrt to destination node d inside an OSPF-network  
determined?
 
Assumption: At first the current (=root) node computes the Dijkstra SPT and  
then navigates from each network node, e.g. from node d, towards the root of 
the  SPT as to determine the respective root adjacent link.
 
Can anyone confirm/correct me?
 
Many thanks,
Heiner

   
_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: Dave Katz <[email-masked]>
Date: Wed, 24 Oct 2007 09:35:57 -0600

Take a look at the algorithm in the RFC.

Basically, as the SPT is calculated, the first hop from the root  
determines the next hop(s) for everything deeper in the tree, and the  
identity of the next hop(s) is carried along as the algorithm goes  
deeper into the tree.  There's no need to walk the tree after it's  
calculated (in fact, most implementations don't even bother storing  
the tree as it's calculated.)

--Dave

On Oct 24, 2007, at 8:55 AM, [email-masked] wrote:

> It may sound like a newbie question and therefore I would be  
> grateful if someone will help with clarification:
>
> How is the next hop wrt to destination node d inside an OSPF- 
> network determined?
>
> Assumption: At first the current (=root) node computes the Dijkstra  
> SPT and then navigates from each network node, e.g. from node d,  
> towards the root of the SPT as to determine the respective root  
> adjacent link.
>