Subject: Re: [OSPF] Unnumbered PtoP router LSA question.

From: Joakim Tjernlund <[email-masked]>
Date: Wed, 14 Jan 2009 15:55:58 +0100

"Dave Katz" <[email-masked]> wrote on 09/01/2009 16:40:25:

> To: Joakim Tjernlund/Transmode@TM
> Cc: "Richard Ogier" <[email-masked]>, [email-masked]
> Date: 09/01/2009 16:42
> Subject: Re: [OSPF] Unnumbered PtoP router LSA question.
> 
> On Jan 9, 2009, at 4:46 AM, Joakim Tjernlund wrote:
> >
> > I believe that if one pull the cable from an Ethernet interface, the
> > router should turn the announced subnet into a host route of type Loop
> > back instead, this is actually my next point I want to discuss
> > so any comments on this would be much appreciated.
> 
> And that's an implementation decision that should be outside the scope 
> of the spec.
> 
> I'll fall on my sword here and say that there is no fundamental need 
> to announce any router address by anybody unless the router wants to 
> be reachable (a useful thing indeed, but not necessary to the 
> functioning of the protocol.)
> 
> --Dave

So I tried to announce a host route via the loopback interface:
In bash:
  ifconfig lo:0 192.168.1.16 netmask 255.255.255.255

Then the only thing I could think of to announce it in OSPF was:
 configure terminal
   router ospf
     network 192.162.1.16/32 area 0

But this will only work for one area.
Any ideas on how to announce a particular host route in
all areas?
Can you do that in Juniper?

 Jocke
_______________________________________________
OSPF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ospf

---

From: Dave Katz <[email-masked]>
Date: Wed, 14 Jan 2009 09:30:47 -0700

> Can you do that in Juniper?

Seems like all implementations should generate a summary at the ABRs  
and announce them throughout, just like any other destination in the  
area.

---

From: Joakim Tjernlund <[email-masked]>
Date: Wed, 14 Jan 2009 18:59:56 +0100

Dave Katz <[email-masked]> wrote on 14/01/2009 17:30:47:

> To: Joakim Tjernlund <[email-masked]>
> Date: 14/01/2009 17:35

I found that I could specify on address to the passive-interface command:
 passive-interface lo 192.168.1.16
and that appears to work somewhat, but the semantics of the passive
command is a bit unclear to me. The docs suggest that this should
be enough add an entry in the router LSA but it isn't unless I also
do a "network 192.162.1.16/32 area 0" too. Removing the network:
"no network 192.162.1.16/32 area 0" doesn't remove anything from the 
router
LSA. I smell a bug a two. Should the passive-interface command alone
be enough to announce a host route in the router LSA?

    Jocke

---

From: Dave Katz <[email-masked]>
Date: Wed, 14 Jan 2009 19:22:59 -0700

> be enough to announce a host route in the router LSA?

This is vendor-specific and probably does not belong on this list...

--Dave