Subject: [OSPF] Fwd: Preliminary idea: OSPF Database Exchange : Pre-Step

From: Mitchell Erblich <[email-masked]>
Date: Mon, 27 Apr 2009 13:19:10 -0700

Begin forwarded message:

> From: Mitchell Erblich <[email-masked]>
> Date: April 27, 2009 12:20:58 PM PDT
> To: "Joel M. Halpern" <[email-masked]>
> Subject: Re: [OSPF] Preliminary idea: OSPF Database Exchange : Pre- 
> Step
>
> Group and Joel,
>
> 		50K was a conservative number.
>
> 		And if you are saying that ASBRs no longer insert ExternalLSAs  
> into a OSPF area,
> 		then may I ask how do  OSPF routers route to destinations outside  
> of the OSPF area?
>
> 		Mitchell Erblich
> 		=========================
> 		
> On Apr 27, 2009, at 8:58 AM, Joel M. Halpern wrote:
>
>> Why would an OSPF domain typically have 90% External LSAs?  The  
>> only way you could get that is if you were injecting your BGP  
>> prefixes into OSPF.  Such injection is generally considered a bad  
>> practice.  (Yes, it can be done.  Yes, we have the tools to do it.   
>> But it makes a mess.
>>
>> Details:
>> ISPs almost never operate that way.
>> Enterprises which are multi-connectded, but are moderate sized,  
>> typically confine the external connections to a single part of the  
>> net, and do not inject BGP prefixes into their enterprise routing,  
>> even if they exchange BGP with their providers.
>> Very large enterprises use a BGP overlay, and avoid injecting BGP  
>> routes into OSPF.
>>
>> Yes, there are cases where they get injected.  Note that if you do  
>> so, you get a LOT more than 50K routes.
>>
>> Yours,
>> Joel M. Halpern
>>
>> Mitchell Erblich wrote:
>>> Group,
>>> First my thoughts are currently in the inception phase
>>> and COULD apply to both wired and wireless environments and I  
>>> applogize for my verboseness.
>>> My initial assumptions are that a OSPF area will be
>>> majority built using the common Ethernet (BMA) environment
>>> and once a OSPF area is formed major LSA changes are rare.
>>> Second is that the LSDB is comprised of say 50k LSAs
>>> which are mostly/90% ExternalLSAs.
>> ...
>

---

From: Dave Katz <[email-masked]>
Date: Mon, 27 Apr 2009 18:21:56 -0500

It's called "BGP".  *Nobody* injects external routing into OSPF,  
except by mistake (and then most routers melt under the load.)

--Dave

On Apr 27, 2009, at 3:19 PM, Mitchell Erblich wrote:

>>> practice.  (Yes, it can be done.  Yes, we have the tools to do  
>>> it.  But it makes a mess.
>>>
>>> Details:
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf