Subject: [OSPF] OSPF Multi Process ECMP Prblem

From: Pranjal Chakravarty <[email-masked]>
Date: Thu, 23 Apr 2009 10:42:56 +0530 (IST)

Dear all,
 
I have one doubt regarding OSPF Multi-Process.
 
R1-------R2-------R3
 
In Router R1 there is a static route 10.1.1.0/24 ,I have redistribute static into ospf in R1,OSPF Process is 100
 
In Router R3 the same static route is there ,i have redistribute static into ospf in Router R3 also.OSPF Process is 200
 
In Router R2 ,there is two process router ospf 100 and router ospf 200,
Now when we do show ip route there should have seen two next hop showing for the route 10.1.1.0/24 because it is learnt from both R1 and R3 via OSPF.
But in actualy only one route is showing .
 
My question is why it is not giving ECMP for the route though it is learnt from two different ospf process.
 
I am attaching one diagram and configuration for reference.
 
Also i would be delighted if someone points to some useful link about multi-procees ospf.
 
Regards
Pranjal

      Own a website.Get an unlimited package.Pay next to nothing.*Go to http://in.business.yahoo.com/

---

From: Acee Lindem <[email-masked]>
Date: Thu, 23 Apr 2009 05:28:00 -0400

Hi Pranjal,

This really isn't an OSPF protocol issue. Rather, it relates to the  
RIB implementation on R2. If you are not pleased with the behavior,  
then you should take it up with the R2 vendor.

Hope this Helps,
Acee

On Apr 23, 2009, at 1:12 AM, Pranjal Chakravarty wrote:

> In Router R1 there is a static route 10.1.1.0/24 ,I have  
> redistribute static into ospf in R1,OSPF Process is 100
>
> In Router R3 the same static route is there ,i have redistribute  
> static into ospf in Router R3 also.OSPF Process is 200
>
> Now when we do show ip route there should have seen two next hop  
> showing for the route 10.1.1.0/24 because it is learnt from both R1  
> and R3 via OSPF.
> Own a website.Get an unlimited package.Pay next to nothing.* Click  
> here!.<OSPF Multi Process ECMP problem.vsd>
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf