Subject: [OSPF] Changes to OSPFv3 MIB I-D from MIB doctor review

From: "Daniel Joyal" <[email-masked]>
Date: Sun, 19 Apr 2009 12:17:24 -0400

The following changes were made to draft-ietf-ospf-ospfv3-mib
between revision 12 and revision 14 based on comments
from the MIB doctor review.

1. Updated boilerplate to latest version.
2. Renamed ospfv3Compliance to ospfv3FullCompliance
    and added ospfv3ReadOnlyCompliance.
3. Expanded description of ospfv3CfgNbrTable
4. Move restrictions on InetAddress and InetAddressType
    to the Conformance Section.
5. Remove StorageType object from ospfv3HostTable.
6. Rename Ospfv3LsidTC to Ospfv3LsIdTC for
    consistency with other TCs.
7. Added DEFVAL clause to more writable objects.
8. Added more Reference clauses.
9. Changed ospfv3AreaNssaTranslatorStabInt to
    ospfv3AreaNssaTranslatorStabInterval.
10. Added reference to RFC 3413 for fine-grain
     control of notification enabling and disabling
     in description of ospfv3NotificationEnable object.
11. For objects with a syntax of TruthValue, added
     text in the Description clause to descibed what
     a value of true(1) means.
12. Changed objects with syntax of RowStatus to
     have RowStatus in the object name.
13. Changed ospfv3AdminStat to ospfv3AdminStatus.
14. Some object's syntax changed from signed integer
      to unsigned integer.
15. Removed last sentence in Description clause for
      ospfv3PacketSrc object.
16. Use DISPLAY-HINT of "d" rather than "d-0" throughout
      the MIB.
17. In graceful restart objects, changed "ExitRc" to
      "ExitReason".

-Dan

---

From: Acee Lindem <[email-masked]>
Date: Mon, 20 Apr 2009 08:58:48 -0400

OSPF WG,
Dan has provided a list of changes to the OSPFv3 MIB during the MIB  
doctor review. Dave, Abhay, and I decided on a short review period  
for these changes before we move forward. Given the amount of work  
and review we've put into this document, we're going to be very  
careful as to what comments we accept. Please post any comments on  
the latest version (-14) to this list by Tuesday, April 28th, 2009.

Thanks Joan, Dan, and Vishwas for all the hard work during the MIB  
doctor review,
Acee