Subject: [OSPF] Group pacing delay

From: Mukul Goyal <[email-masked]>
Date: Sun, 3 May 2009 11:16:38 -0500 (CDT)

Hi

I apologize for this out-of-scope query. 

I am confused regarding the use of group pacing timers implemented in Cisco routers. This timer specifies "the interval at which LSAs are collected into a group and refreshed, checksummed, or aged". One of the objectives is "to improve the LSA packing density for the refreshes in large topologies", which I understand to be reducing the number of LSAs that are refreshed together, i.e. reducing the chances of LSA refresh storms.

The way I understand group pacing timer to be is that the firing of this timer allows LSA ages to be increased and if some of the self-originated LSAs have reached the max age (or will reach the max age before the next firing of the timer), they are refreshed.

Since most routers do not originate too many LSAs, the group pacing delay value seems to be important only for area/AS border routers that do originate multiple LSAs. 

I will appreciate it if a knowledgable person could confirm/correct the above (off-list if considered more appropriate).

Regards
Mukul Goyal

---

From: Mitchell Erblich <[email-masked]>
Date: Sun, 3 May 2009 21:14:08 -0700

Hi,

	I may be in the minority of this, but this is how I see it.

	The grouping of LSAs allows a single interrupt per
	set of LSAs.

	Thus, if you could group 50 LSAs within a single packet,
	you have removed the processing overhead associated
	with 49 interrupts. Later systems can implement polling
	to decrease the interrupt load processing.

	Secondly, grouping the LSAs allows one to process only
	1 IP header per set of LSAs.

	In addition, if more than 1 LSA would force new routing
	computations, and you are aware of more than 1 LSA
	immediately outstanding, you can delay the computation
	based on the processing of the entire packet.

	The act of "grouping" adds a delay and this delay
	may increase the latency before routing changes NEED
	to be done.

	With respect to grouping, the work is forced to be done
	at the receiving router in bursts of each packet of LSAs,
	versus the ability to process them over the grouping
	period. Would you rather have your router be forced to
	process say 500 LSAs within say 2 secs, or recieve 100
	LSAs per sec for 5 secs within 5 groups? So, it is not a
	panacea in the extreme, IMO.

	IMO, the former use of LSA groups CAN add to the
	possibility of LSA bursts with short time periods and thus
	create an artifiical LSA storm.

	Thus, there are tradeoffs.

	Mitchell Erblich
	==================

On May 3, 2009, at 9:16 AM, Mukul Goyal wrote:

> I am confused regarding the use of group pacing timers implemented  
> in Cisco routers. This timer specifies "the interval at which LSAs  
> are collected into a group and refreshed, checksummed, or aged". One  
> of the objectives is "to improve the LSA packing density for the  
> refreshes in large topologies", which I understand to be reducing  
> the number of LSAs that are refreshed together, i.e. reducing the  
> chances of LSA refresh storms.
>
> The way I understand group pacing timer to be is that the firing of  
> this timer allows LSA ages to be increased and if some of the self- 
> originated LSAs have reached the max age (or will reach the max age  
> before the next firing of the timer), they are refreshed.
>
> Since most routers do not originate too many LSAs, the group pacing  
> delay value seems to be important only for area/AS border routers  
> that do originate multiple LSAs.
>
> I will appreciate it if a knowledgable person could confirm/correct  
> the above (off-list if considered more appropriate).
>
> Regards
> Mukul Goyal
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf

---

From: "Thomas, Matthew R" <[email-masked]>
Date: Mon, 4 May 2009 08:02:06 +0100

Hi Mukal,
 
I agree with you. The router must be the originator of the LSA or it would be unable to change the age. So I guess that ABR's are the focus here. When you get your offlist pls feel free to copy me as I am interested in the authoritative answer too.
 
MT

________________________________

From: [email-masked] on behalf of Mukul Goyal
Sent: Sun 03/05/2009 17:16
To: [email-masked]
Subject: [OSPF] Group pacing delay

Hi

Regards
Mukul Goyal