Subject: [OSPF] OSPF Memory full problem

From: Pranjal Chakravarty <[email-masked]>
Date: Mon, 6 Jul 2009 14:17:46 +0530 (IST)

IS RFC 4222 support mandatory in OSPF implementaion ,Does LSA storm and subsequently memory full and CPU load occur without it ?
Attached along a doc regarding memory full problem in OSPF .
 
Regards

      Looking for local information? Find it on Yahoo! Local http://in.local.yahoo.com/

---

From: Mitchell Erblich <[email-masked]>
Date: Mon, 6 Jul 2009 10:34:39 -0700

Group,

	IMO,

	By definition, a Best Current Practices document is to suggest
	to resolve possible issues.

	External LSAs using memory is not an issue with stub routers.

	IMO, the best routers don't have a external LSA issue due to
	the fact that they support other routing protocols and thus not
	import the routes.

	Router flapping is implementation dependent where some router
	will keep down the adjacency after a number of flaps in as short
	period of time.

	High density SIMMS are popular and I assume that only legacy
	routers had / have the issue or due to a mis- configuration problem.

	Etc..

	Mitchell Erblich
	=====================

On Jul 6, 2009, at 1:47 AM, Pranjal Chakravarty wrote:

> IS RFC 4222 support mandatory in OSPF implementaion ,Does LSA storm  
> and subsequently memory full and CPU load occur without it ?
> Looking for local information? Find it on Yahoo! Local<OSPF Memory  
> Full Problem.doc>_______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf

---

From: Vishwas Manral <[email-masked]>
Date: Mon, 6 Jul 2009 14:50:57 -0700

Hi Pranjal,

Like Mitchell mentioned the problem cannot be caused by the support
for RFC4222. LSA storm does not have to do with RFC4222 at all, but
the fact that one of the events you mentioned has occured.

Ideally the memory utilization should not increase either (though for
some of the cases it could by a bit - though it should not be the
cause of memory hog).

Thanks,
Vishwas

On Mon, Jul 6, 2009 at 1:47 AM, Pranjal
Chakravarty<[email-masked]> wrote:
> IS RFC 4222 support mandatory in OSPF implementaion ,Does LSA storm and
> subsequently memory full and CPU load occur without it ?
> ________________________________
> Looking for local information? Find it on Yahoo! Local
> _______________________________________________
> OSPF mailing list
> [email-masked]

---

From: Dave Katz <[email-masked]>
Date: Tue, 7 Jul 2009 17:09:14 -0500

Any implementation that uses unbounded memory in OSPF with a bounded- 
size LSA database is, by definition, amateurish.

Production-grade software protects itself against such things (even  
when bogosity is caused by somebody else's implementation.)

IMHO.

--Dave