Subject: Re: [OSPF] Query for OSPFv3 MIB range value

From: Acee Lindem <[email-masked]>
Date: Wed, 5 Jan 2011 16:05:01 -0500

Hi Abhishek,

See inline. I've also copied the editors of the document. 

On Dec 27, 2010, at 1:23 AM, Abhishek Bhalotia wrote:

> Hi,
>  
> I have one query related to OSPFv3 MIB (rfc5643)
>  
> For the below field the range is defined from 1 to 1800
> Ospfv3UpToRefreshIntervalTC 
>              SYNTAX      Unsigned32 (1..1800) 
>  
> And below is one of the many entries that are using this Syntax
>  
>    ospfv3NbrRestartHelperAge OBJECT-TYPE  
>            SYNTAX       Ospfv3UpToRefreshIntervalTC 
>            UNITS        "seconds"  
>            MAX-ACCESS   read-only  
>            STATUS       current  
>            DESCRIPTION  
>               "Remaining time in current OSPF Graceful restart  
>               interval, if the router is acting as a restart  
>               helper for the neighbor."  
>            ::= { ospfv3NbrEntry 14 }  
>  
> So now If Process is not HELPER enabled, and Current state of Helper is NONE.
> So what value must be displayed for  “ospfv3NbrRestartHelperAge” ?
> Value 0 can not be displayed as it is not in range.

Since the ospfv3NbrRestartHelperStatus clearly indicates whether or not this value is applicable, I don't see a real harm in returning 1. 

>  
> This problem does not exist in OSPFv2, as no such range is specified
>  
>  
> Similar issues are present in other table entires too where the minimum value is 1 instead of 0.
>  
> For eg:
> ospfv3NbrIfId OBJECT-TYPE 
>             SYNTAX          InterfaceIndex 
>             MAX-ACCESS      read-only 
>             STATUS          current 
>             DESCRIPTION 
>                 "The interface ID that the neighbor advertises 
>                 in its Hello Packets on this link, that is, the 
>                 neighbor's local interface index." 
>             ::= { ospfv3NbrEntry 12 } 
>  
> Here InterfaceIndex range start from 1
> But in case of NBMA nbr which is created due to configuration, this field will be 0. So how to display this field ?

There is no problem here. Configured neighbors should be returned in ospfv3CfgNbrTable as opposed to  ospfv3NbrTable. 

Hope this helps,
Acee 

>  
> Other similar fields are ROUTER-Id, [Interface DR/BDR values refer to Router id, and for P2P interface how to display value 0 ]
>  
>  
> Thanks and regards
> Abhishek
>  
>              ***************************************************************************************
>             This e-mail and attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient's) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!
>  
> <ATT00001..txt>

---

From: Abhishek Bhalotia <[email-masked]>
Date: Tue, 11 Jan 2011 21:16:46 +0530

Hi Acee,

Thanks for the clarification.

How about the below entry in Ospfv3 IF Table for DR and BDR for P2P
interface, where it will be 0, but the range is from 1 for Router-id.

ospfv3IfDesignatedRouter OBJECT-TYPE
            SYNTAX          Ospfv3RouterIdTC
            MAX-ACCESS      read-only
            STATUS          current
            DESCRIPTION
                "The Router ID of the Designated Router."
            ::= { ospfv3IfEntry 13 }
Ospfv3RouterIdTC ::= TEXTUAL-CONVENTION
             DISPLAY-HINT "d"
             STATUS      current
             DESCRIPTION
                  "A 32-bit, unsigned integer uniquely identifying the
                  router in the Autonomous System.  To ensure
                  uniqueness, this may default to the value of one of
                  the router's IPv4 host addresses if IPv4 is
                  configured on the router."
             REFERENCE
                  "OSPF for IPv6, Appendix C.1, Global Parameters"
             SYNTAX      Unsigned32 (1..'FFFFFFFF'h)

Thanks and Regards

Abhishek

****************************************************************************
***********

            This e-mail and attachments contain confidential information
from HUAWEI, which is intended only for the person or entity whose address
is listed above. Any use of the information contained herein in any way
(including, but not limited to, total or partial disclosure, reproduction,
or dissemination) by persons other than the intended recipient's) is
prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it!

  _____  

From: Acee Lindem [mailto:[email-masked]] 
Sent: Thursday, January 06, 2011 2:35 AM
To: Abhishek Bhalotia
Cc: [email-masked]; Vishwas Manral; Dan Joyal
Subject: Re: [OSPF] Query for OSPFv3 MIB range value

Hi Abhishek,

Hi,

So now If Process is not HELPER enabled, and Current state of Helper is
NONE.

So what value must be displayed for  "ospfv3NbrRestartHelperAge" ?

Since the ospfv3NbrRestartHelperStatus clearly indicates whether or not this
value is applicable, I don't see a real harm in returning 1. 

 

 

Similar issues are present in other table entires too where the minimum
value is 1 instead of 0.

For eg:

But in case of NBMA nbr which is created due to configuration, this field
will be 0. So how to display this field ?

There is no problem here. Configured neighbors should be returned in
ospfv3CfgNbrTable as opposed to  ospfv3NbrTable. 

Hope this helps,

Acee 

 

Other similar fields are ROUTER-Id, [Interface DR/BDR values refer to Router
id, and for P2P interface how to display value 0 ]

Thanks and regards

Abhishek

****************************************************************************
***********

            This e-mail and attachments contain confidential information
from HUAWEI, which is intended only for the person or entity whose address
is listed above. Any use of the information contained herein in any way
(including, but not limited to, total or partial disclosure, reproduction,
or dissemination) by persons other than the intended recipient's) is
prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it!

<ATT00001..txt>

---

From: Acee Lindem <[email-masked]>
Date: Mon, 17 Jan 2011 20:40:31 -0500

Hi Abhishek,
I checked with some SNMP experts and there really isn't an easy way to change the TC. The only alternative is to: 

  1. Define a new Router ID TC, e.g., Ospfv3RouterIdNotApplicable0TC,  which allows 0 to indicate not applicable. 
  2. Deprecate OSPF Router ID MIB variables that are sometimes not applicable.
  3. Define new variables using the new TC for the new variables which are sometimes not applicable.  

Others are encouraged to indicate what they are returning in situations where the variables are not applicable. 
Thanks,
Acee 

On Jan 11, 2011, at 10:46 AM, Abhishek Bhalotia wrote:

> How about the below entry in Ospfv3 IF Table for DR and BDR for P2P interface, where it will be 0, but the range is from 1 for Router-id.
>