Subject: [OSPF] Regarding Flushing Translated Type-7 LSAs

From: keshavaak 70257 <[email-masked]>
Date: Wed, 16 Feb 2011 13:29:08 +0800

Hi,

while flushing the T7 LSA, 

When the Translator elsection status has beedn deposed by another, 
   Type-5 LSAs that are  generated by aggregating Type-7 LSAs into their 
   best matched Type-7 address ranges  are flushed immideately.
Where as 
   Type-5 LSAs generated by translating Type-7 LSAs are not immediately
   flushed, but are allowed to remain in the OSPF routing domain as if
   the originator is still an elected translator.

why flushing time can be diffrent for 'normal Type-7 Translated' and 'aggregeted Type-7 Translated LSA' ?

Please help us to understand the scenario.

3.3 Flushing Translated Type-7 LSAs

   "If an NSSA border router is translating Type-7 LSA's into Type-5
   LSA's with NSSATranslatorState set to elected and the NSSA border
   router has determined that its translator election status has been
   deposed by another NSSA border router (see Section 3.1), then, as
   soon as the TranslatorStabilityInterval has expired without the
   router reelecting itself as a translator, Type-5 LSAs that are
   generated by aggregating Type-7 LSAs into their best matched Type-7
   address ranges (see Section 3.2, Step (3)) are flushed.  Conversely
   Type-5 LSAs generated by translating Type-7 LSAs are not immediately
   flushed, but are allowed to remain in the OSPF routing domain as if
   the originator is still an elected translator.  This minimizes the
   flushing and flooding impact on the transit topology of an NSSA that
   changes its translators frequently."

******************************************************************************************
 This email and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained here in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this email in error, please notify the sender by phone or email immediately and delete it!
 *****************************************************************************************

---

From: Acee Lindem <[email-masked]>
Date: Wed, 16 Feb 2011 06:17:10 -0500

Hi Keshavaak, 
This was added back in about 1997 or 1998 but IIRC, the reason was to allow the deposed translating router to purge the translated type 5 LSAs at its own pace rather than scanning the OSPF local RIB for type 7 routes. The aggregates were deemed easier to purge since they would be readily available with their own data structures. 
Hope this helps,
Acee 
P.S. Routers (especially the smaller enterprise variety) were much less powerful in 1997 :^). 

On Feb 16, 2011, at 12:29 AM, keshavaak 70257 wrote:

> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf