Subject: [OSPF] Single Hop MANET versus Broadcast/P2MP Hybrid Interface

From: Acee Lindem <[email-masked]>
Date: Wed, 11 May 2011 18:22:29 -0400

Speaking as WG Co-Chair,

As many of you remember, we spent a lot of WG time 2004-2007 discussing various OSPF MANET solutions. We were unable to converge on a single solution and ended up with 3 experimental RFCs. It was thought that possibly one day a clear winner would emerge and become a standard. While this may still happen in the future, I don't believe we are there yet and do not feel it would be beneficial to renew the debate.

In Beijing, the hybrid broadcast/P2MP interface was proposed with a radio networks being one of the target environment. This collision with the former work on OSPF MANET elicited much discussion. In Prague, the chairs, authors, and some other interested parties met to specifically address this collision. What we agreed was that the existing OSPF MANET RFCs were the agreed upon solution(s) for MANET environments. The OSPF hybrid interface could still be valuable as a simple adjacency reduction technique on links where broadcast capability was available but not all the links had the same costs. We also agreed that the OSPF MANET mechanisms (with some simplifications) could also handle the single hop case.

Hence, the questions for the WG are:

  1. Do we want to accept draft-nsheth-ospf-hybrid-bcast-and-p2mp-01.txt as a WG document?

https://datatracker.ietf.org/doc/draft-nsheth-ospf-hybrid-bcast-and-p2mp

  2. Do we wish to allow revisions of the OSPF MANET experimental RFCs to cover the single-hop case (and possibly minor corrections)?

https://datatracker.ietf.org/doc/rfc5449/
https://datatracker.ietf.org/doc/rfc5614/
https://datatracker.ietf.org/doc/rfc5820/

Note that IPR statements are filed for some of the above.

Thanks,
Acee

---

From: John E Drake <[email-masked]>
Date: Wed, 11 May 2011 15:30:58 -0700

Yes and No

Sent from my iPhone

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Acee Lindem
> Sent: Wednesday, May 11, 2011 3:22 PM
> To: OSPF List
> Subject: [OSPF] Single Hop MANET versus Broadcast/P2MP Hybrid Interface
> 
> Speaking as WG Co-Chair,
> 
> As many of you remember, we spent a lot of WG time 2004-2007 discussing
> various OSPF MANET solutions. We were unable to converge on a single
> solution and ended up with 3 experimental RFCs. It was thought that
> possibly one day a clear winner would emerge and become a standard.
> While this may still happen in the future, I don't believe we are there
> yet and do not feel it would be beneficial to renew the debate.
> 
> In Beijing, the hybrid broadcast/P2MP interface was proposed with a
> radio networks being one of the target environment. This collision with
> the former work on OSPF MANET elicited much discussion. In Prague, the
> chairs, authors, and some other interested parties met to specifically
> address this collision. What we agreed was that the existing OSPF MANET
> RFCs were the agreed upon solution(s) for MANET environments. The OSPF
> hybrid interface could still be valuable as a simple adjacency
> reduction technique on links where broadcast capability was available
> but not all the links had the same costs. We also agreed that the OSPF
> MANET mechanisms (with some simplifications) could also handle the
> single hop case.
> 
>   2. Do we wish to allow revisions of the OSPF MANET experimental RFCs
> to cover the single-hop case (and possibly minor corrections)?
> 
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf

---

From: Richard Ogier <[email-masked]>
Date: Wed, 11 May 2011 16:03:56 -0700

In response to the above question, I will repeat what I said in my earlier post: One nice thing about having two (short) drafts showing how both OSPF-OR and OSPF-MDR can be applied to single-hop broadcast networks, is that it will help people to understand and compare these different solutions . An alternative is for these OSPF-MANET drafts to be Informational, since they don't require modification of the original protocols, but describe how they can be applied to the single-hop case.

Thanks,
Richard

Acee Lindem wrote:

Speaking as WG Co-Chair,

Thanks,
Acee

---

From: "Retana, Alvaro" <[email-masked]>
Date: Thu, 12 May 2011 17:09:21 +0000

1. Yes.

2. Yes, but...IMHO we don't need a full refresh of the RFCs.  An ID updating the RFC should be enough.  The ID should be Experimental (just like the RFC).

Alvaro.

> Sent: Wednesday, May 11, 2011 6:22 PM
> To: OSPF List

---

From: Alia Atlas <[email-masked]>
Date: Thu, 12 May 2011 13:14:20 -0400

Yes to (1)
and no opinion on (2)

Alia

---

From: "Henderson, Thomas R" <[email-masked]>
Date: Thu, 12 May 2011 13:06:36 -0700

> https://datatracker.ietf.org/doc/draft-nsheth-ospf-hybrid-bcast-and-

I have no objection.

> https://datatracker.ietf.org/doc/rfc5820/

I would be interested to work on this.

- Tom

---

From: Emmanuel Baccelli <[email-masked]>
Date: Thu, 12 May 2011 22:14:48 +0200

> > https://datatracker.ietf.org/doc/draft-nsheth-ospf-hybrid-bcast-and-

+1

> I would be interested to work on this.

Count me in too!

Emmanuel

---

From: Stan Ratliff <[email-masked]>
Date: Thu, 12 May 2011 16:20:21 -0400

Yes on both questions.

Regards,
Stan

On May 12, 2011, at 4:14 PM, Emmanuel Baccelli wrote:

>
>
> On Thu, May 12, 2011 at 10:06 PM, Henderson, Thomas R <[email-masked] 
> > wrote: