Subject: Re: [OSPF] OSPF Digest, Vol 68, Issue 8

From: thiruma valavan <[email-masked]>
Date: Sat, 29 Oct 2011 22:34:49 +0530

Hi OSPF group members,

Is this the objective of using Instance Id in OSPFv2.

Instance id will be used If interface having more than one addresses, so we
need to configure different subnets in router interface (Using secondary
address cli command).

So we can connect multiple areas on single link, No need different physical
connection for each area.

Thanks,
Thiru

On Fri, Oct 28, 2011 at 12:30 AM, <[email-masked]> wrote:

> If you have received this digest without all the individual message
> attachments you will need to update your digest options in your list
> subscription.  To do so, go to
>
> https://www.ietf.org/mailman/listinfo/ospf
>
> Click the 'Unsubscribe or edit options' button, log in, and set "Get
> MIME or Plain Text Digests?" to MIME.  You can set this option
> globally for all the list digests you receive at this point.
>
>
>
> Send OSPF mailing list submissions to
>        [email-masked]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>        https://www.ietf.org/mailman/listinfo/ospf
> or, via email, send a message with subject or body 'help' to
>        [email-masked]
>
> You can reach the person managing the list at
>        [email-masked]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of OSPF digest..."
>
>
> Today's Topics:
>
>   1.  New Version Notification -
>      draft-ietf-ospf-auth-trailer-ospfv3-08.txt (Acee Lindem)
>   2. Re:  New Version Notification -
>      draft-ietf-ospf-auth-trailer-ospfv3-08.txt (Acee Lindem)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Wed, 26 Oct 2011 19:48:42 -0400
> From: Acee Lindem <[email-masked]>
> To: OSPF List <[email-masked]>
> Subject: [OSPF] New Version Notification -
>        draft-ietf-ospf-auth-trailer-ospfv3-08.txt
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset="us-ascii"
>
> This version includes changes in response to the external reviews that have
> taken place since we completed WG last call. A few things have been
> clarified and the following two items have been added:
>
>    1. Mitigation of Cross Protocol Attacks by appending a protocol specific
> byte to the key. This will prevent replay attacks when the same key is used
> by multiple protocols (and the sets of valid input packets intercept). See
> sections 4.4 and 4.5.
>
>    2. Recommendations for authentication key selection have been added to
> the "Security Considerations".  See section 6.
>
> Links to be the new version and a nicely annotated diff with the previous
> version are included in the forwarded E-mail below.
>
> Thanks,
> Acee
>
>
>
>
> Begin forwarded message:
>
> From: "[email-masked]<mailto:[email-masked]>" <
> [email-masked]<mailto:[email-masked]>>
> Date: October 26, 2011 6:19:35 PM EDT
> To: "[email-masked]<mailto:[email-masked]>" <
> [email-masked]<mailto:[email-masked]>>, "
> [email-masked]<mailto:
> [email-masked]>" <
> [email-masked]<mailto:
> [email-masked]>>, "[email-masked]
> <mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]
> >>
> Subject: New Version Notification -
> draft-ietf-ospf-auth-trailer-ospfv3-08.txt
>
> New version (-08) has been submitted for
> draft-ietf-ospf-auth-trailer-ospfv3-08.txt.
>
> http://www.ietf.org/internet-drafts/draft-ietf-ospf-auth-trailer-ospfv3-08.txt
>
>
> Diff from previous version:
> http://tools.ietf.org/rfcdiff?url2=draft-ietf-ospf-auth-trailer-ospfv3-08
>
> IETF Secretariat.
>
>
>
> ------------------------------
>
> Message: 2
> Date: Wed, 26 Oct 2011 19:53:33 -0400
> From: Acee Lindem <[email-masked]>
> Cc: OSPF List <[email-masked]>
> Subject: Re: [OSPF] New Version Notification -
>        draft-ietf-ospf-auth-trailer-ospfv3-08.txt
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset="us-ascii"
>
>
> Of course, I meant "intersect" rather than "intercept" below. In other
> words, a packet from one protocol could potentially also represent a valid
> packet in another protocol and be replayed.
> Thanks,
> Acee
>
> On Oct 26, 2011, at 7:48 PM, Acee Lindem wrote:
>
> > This version includes changes in response to the external reviews that
> have taken place since we completed WG last call. A few things have been
> clarified and the following two items have been added:
> >
> >    1. Mitigation of Cross Protocol Attacks by appending a protocol
> specific byte to the key. This will prevent replay attacks when the same key
> is used by multiple protocols (and the sets of valid input packets
> intercept). See sections 4.4 and 4.5.
> >
> >    2. Recommendations for authentication key selection have been added to
> the "Security Considerations".  See section 6.
> >
> > Links to be the new version and a nicely annotated diff with the previous
> version are included in the forwarded E-mail below.
> >
> > Thanks,
> > Acee
> >
> >
> >
> >
> > Begin forwarded message:
> >
> > From: "[email-masked]<mailto:[email-masked]>" <
> [email-masked]<mailto:[email-masked]>>
> > Date: October 26, 2011 6:19:35 PM EDT
> > To: "[email-masked]<mailto:[email-masked]>" <
> [email-masked]<mailto:[email-masked]>>, "
> [email-masked]<mailto:
> [email-masked]>" <
> [email-masked]<mailto:
> [email-masked]>>, "[email-masked]
> <mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]
> >>
> > Subject: New Version Notification -
> draft-ietf-ospf-auth-trailer-ospfv3-08.txt
> >
> > New version (-08) has been submitted for
> draft-ietf-ospf-auth-trailer-ospfv3-08.txt.
> >
> http://www.ietf.org/internet-drafts/draft-ietf-ospf-auth-trailer-ospfv3-08.txt
> >
> >
> > Diff from previous version:
> >
> http://tools.ietf.org/rfcdiff?url2=draft-ietf-ospf-auth-trailer-ospfv3-08
> >
> > IETF Secretariat.
> >
> > _______________________________________________
> > OSPF mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/ospf
>
>
>
> ------------------------------
>
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf
>
>
> End of OSPF Digest, Vol 68, Issue 8
> ***********************************
>

---

From: Acee Lindem <[email-masked]>
Date: Sat, 29 Oct 2011 13:35:47 -0400

Hi Thiru,
You are not precluded from using the OSPFv2 Instance ID for this purpose. However, we already have RFC 5185 to allow a single interface to be in multiple areas (note that no secondary IP address is necessary):

  http://www.rfc-editor.org/rfc/rfc5185.txt

The primary application is supporting multiple OSPF instances using the same link. One application is OSPF Transport Instance:

  http://www.ietf.org/id/draft-ietf-ospf-transport-instance-07.txt

Thanks,
Acee

On Oct 29, 2011, at 1:04 PM, thiruma valavan wrote:

Hi OSPF group members,

Instance id will be used If interface having more than one addresses, so we need to configure different subnets in router interface (Using secondary address cli command).

So we can connect multiple areas on single link, No need different physical connection for each area.

Thanks,
Thiru

On Fri, Oct 28, 2011 at 12:30 AM, <[email-masked]<mailto:[email-masked]>> wrote:
If you have received this digest without all the individual message
attachments you will need to update your digest options in your list
subscription.  To do so, go to

Send OSPF mailing list submissions to
       [email-masked]<mailto:[email-masked]>

To subscribe or unsubscribe via the World Wide Web, visit
       https://www.ietf.org/mailman/listinfo/ospf
or, via email, send a message with subject or body 'help' to
       [email-masked]<mailto:[email-masked]>

You can reach the person managing the list at
       [email-masked]<mailto:[email-masked]>

Today's Topics:

Message: 1
Date: Wed, 26 Oct 2011 19:48:42 -0400
From: Acee Lindem <[email-masked]<mailto:[email-masked]>>
To: OSPF List <[email-masked]<mailto:[email-masked]>>
Subject: [OSPF] New Version Notification -
       draft-ietf-ospf-auth-trailer-ospfv3-08.txt
Message-ID: <[email-masked]<mailto:[email-masked]>>
Content-Type: text/plain; charset="us-ascii"

This version includes changes in response to the external reviews that have taken place since we completed WG last call. A few things have been clarified and the following two items have been added:

   1. Mitigation of Cross Protocol Attacks by appending a protocol specific byte to the key. This will prevent replay attacks when the same key is used by multiple protocols (and the sets of valid input packets intercept). See sections 4.4 and 4.5.

   2. Recommendations for authentication key selection have been added to the "Security Considerations".  See section 6.

Links to be the new version and a nicely annotated diff with the previous version are included in the forwarded E-mail below.

Thanks,
Acee

Begin forwarded message:

From: "[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>" <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>
Date: October 26, 2011 6:19:35 PM EDT
To: "[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>" <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>, "[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>" <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>, "[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>" <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>
Subject: New Version Notification - draft-ietf-ospf-auth-trailer-ospfv3-08.txt

New version (-08) has been submitted for draft-ietf-ospf-auth-trailer-ospfv3-08.txt.
http://www.ietf.org/internet-drafts/draft-ietf-ospf-auth-trailer-ospfv3-08.txt

IETF Secretariat.

Message: 2
Date: Wed, 26 Oct 2011 19:53:33 -0400
From: Acee Lindem <[email-masked]<mailto:[email-masked]>>
Cc: OSPF List <[email-masked]<mailto:[email-masked]>>
Subject: Re: [OSPF] New Version Notification -
       draft-ietf-ospf-auth-trailer-ospfv3-08.txt
Message-ID: <[email-masked]<mailto:[email-masked]>>
Content-Type: text/plain; charset="us-ascii"

Of course, I meant "intersect" rather than "intercept" below. In other words, a packet from one protocol could potentially also represent a valid packet in another protocol and be replayed.
Thanks,
Acee

On Oct 26, 2011, at 7:48 PM, Acee Lindem wrote:

> This version includes changes in response to the external reviews that have taken place since we completed WG last call. A few things have been clarified and the following two items have been added:
>
>    1. Mitigation of Cross Protocol Attacks by appending a protocol specific byte to the key. This will prevent replay attacks when the same key is used by multiple protocols (and the sets of valid input packets intercept). See sections 4.4 and 4.5.
>
>    2. Recommendations for authentication key selection have been added to the "Security Considerations".  See section 6.
>
> Links to be the new version and a nicely annotated diff with the previous version are included in the forwarded E-mail below.
>
> Thanks,
> Acee
>
>
>
>
> Begin forwarded message:
>
> From: "[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>" <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>
> To: "[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>" <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>, "[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>" <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>, "[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>" <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>
> Subject: New Version Notification - draft-ietf-ospf-auth-trailer-ospfv3-08.txt
>
> New version (-08) has been submitted for draft-ietf-ospf-auth-trailer-ospfv3-08.txt.
> [email-masked]<mailto:[email-masked]>

_______________________________________________
OSPF mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ospf

_______________________________________________
OSPF mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ospf