Subject: [OSPF] [Editorial Errata Reported] RFC5709 (2989)

From: RFC Errata System <[email-masked]>
Date: Mon, 10 Oct 2011 17:51:19 -0700 (PDT)

The following errata report has been submitted for RFC5709,
"OSPFv2 HMAC-SHA Cryptographic Authentication".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5709&eid=2989

--------------------------------------
Type: Editorial
Reported by: Dai Wenjie (David Jet) <[email-masked]>

Section: 3.

Original Text
-------------
   With the additions in this document, the currently valid algorithms
   (including mode) for OSPFv2 Cryptographic Authentication include:

           Keyed-MD5               (defined in RFC 2328, Appendix D)

Corrected Text
--------------
   With the additions in this document, the currently valid algorithms
   (including mode) for OSPFv2 Cryptographic Authentication include:

           Keyed-MD5               (defined in RFC 2328, Appendix D)

Notes
-----
The link 'Appendix D' referenced is incorrect. It is now 'http://tools.ietf.org/html/rfc5709#appendix-D', and it should be 'http://tools.ietf.org/html/rfc2328#appendix-D'.
Pay attention to the difference of the numbers in links,please.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5709 (draft-ietf-ospf-hmac-sha-07)
--------------------------------------
Title               : OSPFv2 HMAC-SHA Cryptographic Authentication
Publication Date    : October 2009
Author(s)           : M. Bhatia, V. Manral, M. Fanto, R. White, M. Barnes, T. Li, R. Atkinson
Category            : PROPOSED STANDARD
Source              : Open Shortest Path First IGP
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Tue, 11 Oct 2011 06:29:02 +0530

Yes, the link is incorrect in the HTML version of the RFC. I don't remember giving the URL and don't know how it was inserted in the HTML version. Cant we just fix the HTML page to point to RFC 2328 Appendix D instead of pointing to RFC 5709 Appendix D (which does not even exist!)?

There is no problem with the TXT version of the RFC. 

Cheers, Manav

> -----Original Message-----
> From: RFC Errata System [mailto:[email-masked]] 
> Sent: Tuesday, October 11, 2011 6:21 AM
> To: Bhatia, Manav (Manav); [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: [Editorial Errata Reported] RFC5709 (2989)
> 
> 
>    With the additions in this document, the currently valid 
> algorithms    (including mode) for OSPFv2 Cryptographic 
> Authentication include:             Keyed-MD5               
> (defined in RFC 2328, Appendix D)
> 
> Corrected Text
> --------------
>    With the additions in this document, the currently valid 
> algorithms    (including mode) for OSPFv2 Cryptographic 
> Authentication include:             Keyed-MD5               
> (defined in RFC 2328, Appendix D)
> 
> Notes
> -----
> The link 'Appendix D' referenced is incorrect. It is now 
> 'http://tools.ietf.org/html/rfc5709#appendix-D', and it 
> should be 'http://tools.ietf.org/html/rfc2328#appendix-D'. 
> This errata is currently posted as "Reported". If necessary, 
> please use "Reply All" to discuss whether it should be 
> verified or rejected. When a decision is reached, the 
> verifying party (IESG) can log in to change the status and 
> edit the report, if necessary. 
>

---

From: Acee Lindem <[email-masked]>
Date: Mon, 10 Oct 2011 21:21:00 -0400

RFC-Editor(s),
Can you simply update the html link as Manav suggests?
Thanks,
Acee
On Oct 10, 2011, at 8:59 PM, Bhatia, Manav (Manav) wrote:

> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf

---

From: Acee Lindem <[email-masked]>
Date: Tue, 11 Oct 2011 18:19:32 -0400

Hi Alice,

Thanks for the information. In the hopes of dispensing of this matter quickly, I have opened a tools ticket on this issue:

http://trac.tools.ietf.org/group/tools/trac/ticket/6

Can you close this errata as "Rejected"? If not, I'll advise Steward to do it (WG chairs don't have the authority). 

Thanks,
Acee 

On Oct 11, 2011, at 5:51 PM, Alice Hagens wrote:

> Acee, Manav,
> 
> The HTML versions of RFCs available from tools.ietf.org (e.g., http://tools.ietf.org/html/rfc5709) are created and maintained by the Tools Team, not the RFC Editor. They are automatically created by running rfcmarkup (http://tools.ietf.org/tools/rfcmarkup/) on the text of the RFC. In short, the link on http://tools.ietf.org/html/rfc5709 was automatically created based on parsing the string "RFC 2328, Appendix D".
> 
> As noted on http://www.rfc-editor.org/errata.php, errata are for the RFCs as available from rfc-editor.org, e.g., http://www.rfc-editor.org/rfc/rfc5709.txt.
> 
> The verifiers (Area Directors) have the ability to edit the contents of the errata report.  Perhaps the Corrected Text could convey the intended correction, maybe "Keyed-MD5  (defined in RFC 2328, Appendix D, as updated by this document)", and the content of the Notes could be removed.
> 
> Thank you.
> RFC Editor/ah
> 
> On Oct 10, 2011, at 9:21 PM, Acee Lindem wrote:
> 
>> RFC-Editor(s),