Subject: [OSPF] In OSPFv3 are a router's own host routes or loopback routes propagated across area boundary?

From: "Kecskemeti, Delia" <[email-masked]>
Date: Fri, 8 Nov 2013 22:25:06 +0000

Hi

In OSPFv3 are a router's own host routes or loopback routes propagated across area boundary?
What happens to a router's prefixes listed in its intra-area LSAs at area boundary, are they visible / accessible from the rest of areas?
Does the ABR describe them into the adjacent area in inter-area prefix LSA (maybe with LA options bit set and prefix length 128) or not?
That is after the SPF computation, for a routing table entry that describes a router and its set of prefixes, are those prefixes copied into an interarea LSA for distribution into adjacent areas?
Or are they considered the same as link local addresses and never distributed beyond the area via inter-area prefix LSAs?

Thank you  

Delia Kecskemeti, MTS
direct 613.270.2281  fax 613.592.2283

---

From: Acee Lindem <[email-masked]>
Date: Sat, 9 Nov 2013 21:44:16 +0000

Hi Delia, 
See inline. 

On 11/8/13 2:25 PM, "Kecskemeti, Delia" <[email-masked]>
wrote:

>What happens to a router's prefixes listed in its intra-area LSAs at area
>boundary, are they visible / accessible from the rest of areas?
>Does the ABR describe them into the adjacent area in inter-area prefix
>LSA (maybe with LA options bit set and prefix length 128) or not?
>That is after the SPF computation, for a routing table entry that
>describes a router and its set of prefixes, are those prefixes copied
>into an interarea LSA for distribution into adjacent areas?

They are advertised in an inter-area-prefix-LSAs like any other intra-area
OSPFv3 route. The prefix options for the intra-area-prefix-LSA are not
propagated to the inter-area-LSAs. Hence, the LA-bit will not be set.

Thanks,
Acee 

>Or are they considered the same as link local addresses and never
>distributed beyond the area via inter-area prefix LSAs?
>
>Thank you  
>
>Delia Kecskemeti, MTS
>_______________________________________________
>OSPF mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/ospf

---

From: "Kecskemeti, Delia" <[email-masked]>
Date: Sat, 9 Nov 2013 23:39:06 +0000

Great, thank you very much Acee, 
Very much appreciated

All the best

Delia Kecskemeti, MTS

-----Original Message-----
From: Acee Lindem [mailto:[email-masked]] 
Sent: Saturday, November 09, 2013 4:44 PM
To: Kecskemeti, Delia; [email-masked]
Subject: Re: [OSPF] In OSPFv3 are a router's own host routes or loopback routes propagated across area boundary?

Hi Delia,
See inline. 

On 11/8/13 2:25 PM, "Kecskemeti, Delia" <[email-masked]>
wrote:

>What happens to a router's prefixes listed in its intra-area LSAs at 
>area boundary, are they visible / accessible from the rest of areas?

They are advertised in an inter-area-prefix-LSAs like any other intra-area
OSPFv3 route. The prefix options for the intra-area-prefix-LSA are not propagated to the inter-area-LSAs. Hence, the LA-bit will not be set.

Thanks,
Acee