Subject: [OSPF] FW: New Version Notification for draft-chen-ospf-transition-to-ospfv3-00.txt

From: Ing-Wher Chen <[email-masked]>
Date: Fri, 7 Feb 2014 14:50:46 +0000

Hello,

The information draft below documents how to encapsulate OSPFv3 packets in IPv4
in an effort to transition to OSPFv3 and IPv6.

Thanks,
Helen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, January 27, 2014 2:25 AM
To: Ing-Wher Chen; Ing-Wher Chen; Acee Lindem; Acee Lindem
Subject: New Version Notification for draft-chen-ospf-transition-to-ospfv3-00.txt

A new version of I-D, draft-chen-ospf-transition-to-ospfv3-00.txt
has been successfully submitted by I. Chen and posted to the IETF repository.

Name:		draft-chen-ospf-transition-to-ospfv3
Revision:	00
Title:		OSPFv3 over IPv4 for IPv6 Transition
Document date:	2014-01-26
Group:		Individual Submission
Pages:		8
URL:            http://www.ietf.org/internet-drafts/draft-chen-ospf-transition-to-ospfv3-00.txt
Status:         https://datatracker.ietf.org/doc/draft-chen-ospf-transition-to-ospfv3/
Htmlized:       http://tools.ietf.org/html/draft-chen-ospf-transition-to-ospfv3-00

Abstract:
   This draft defines a mechanism to use IPv4 to transport OSPFv3
   packets, in order to facilitate transition from IPv4-only to IPv6 and
   dual-stack within a routing domain.  Using OSPFv3 over IPv4 with the
   existing OSPFv3 Address Family extension simplifies transition from
   an OSFPv2 IPv4-only routing domain to an OSPFv3 dual-stack routing
   domain, and later possibly to an IPv6-only routing domain.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Karsten Thomann <[email-masked]>
Date: Sat, 08 Feb 2014 20:51:52 +0100

Hello,

I don't know if i have missed that part, but what would happen if OSPFv3 is running over IPv4 and 
there are two (or more) IPv6 Islands already deployed within the network, should there be any 
LSA flooding checks, like do not flood LSA with IPv6 networks over IPv4 only links, or should the 
route calculation/installation of the information simply fail as there is no valid path?

Regarding:
In situations where the IPv4 deployment is a proper
   superset of the IPv6 deployment, it is expected that OSPFv3 packets
   would be carried over IPv4, until the rest of the network deployment
   is upgraded to support IPv6 in addition to IPv4.
Is there any explicit preference over which version the adjacency is build if v4 and v6 is available 
in that specific part of the network?
What should happen when an IPv4 Link gets v6 added, graceful reestablish the adjacency over 
IPv6, or wait until forced protocol switch?
Regards
Karsten

Am Freitag, 7. Februar 2014, 14:50:46 schrieb Ing-Wher Chen:
> Hello,
> 
> The information draft below documents how to encapsulate OSPFv3 packets in
> IPv4 in an effort to transition to OSPFv3 and IPv6.
> 
> Thanks,
> Helen
> 
> Subject: New Version Notification for
> draft-chen-ospf-transition-to-ospfv3-00.txt
> 
> 
> URL:           
> http://www.ietf.org/internet-drafts/draft-chen-ospf-transition-to-ospfv3-00
> .txt Status:        
> https://datatracker.ietf.org/doc/draft-chen-ospf-transition-to-ospfv3/
> Htmlized:      
> http://tools.ietf.org/html/draft-chen-ospf-transition-to-ospfv3-00
> 
> 
> Abstract:
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf