Subject: Re: [OSPF] draft-chen-ospf-transition-to-ospfv3-00.txt

From: RJ Atkinson <[email-masked]>
Date: Mon, 10 Feb 2014 14:33:05 -0500

Earlier, Karsten Thomann wrote, in part:
> I don't know if i have missed that part, but what would happen if OSPFv3 
> is running over IPv4 and there are two (or more) IPv6 Islands already deployed 
> within the network, should there be any LSA flooding checks, like do not flood 
> LSA with IPv6 networks over IPv4 only links, or should the route 
> calculation/installation of the information simply fail 
> as there is no valid path?

The OSPF deployments I am familiar with did not "auto deploy"
or "self deploy".  Instead, all of the OSPF deployments that I am
familiar with had engineers making deliberate decisions about how
to configure the OSPF deployment, and also how to configure the
OSPF routers in that deployment.

One deployment option, already deployed in some places, is to run
"ships in the night".  In this model, the IPv4 topology exclusively
uses OSPFv2 over IPv4 and the IPv6 topology exclusively uses OSPFv3
over IPv6.  For some sites, that is a good option.  A number of my
clients are very interested in this new I-D because it optimises
their IPv6 transition strategy.

For some sites, IPv6 transition is simplified, optimised, and also
cost-reduced by using OSPFv3 over IPv4 initially, and carrying both 
IPv4 prefixes and IPv6 prefixes inside that one OSPFv3 deployment 
(i.e. using the Address Family extension to keep the prefixes clearly 
differentiated within a single OSPFv3 deployment).  This can lower
operational costs because one can get by with managing only OSPFv3,
rather than having to manage both OSPFv2 and OSPFv3.

If one's "IPv6 islands" (to use your term) are really dual-stack
(aside: having dual-stack rather than IPv6-only would be expected
and normal if another part of one's OSPF deployment is using 
OSPF over IPv4), then EITHER the whole deployment should be configured 
to run over IPv4  XOR  the whole deployment should be configured 
to run over IPv6.  

Having different "IPv4 islands" and "IPv6 islands" is an explicit choice 
of a configuration engineer or design engineer.  That probably is not 
the optimal deployment choice for an engineer to make.  It definitely 
is NOT a choice that I would make or that I would recommend to my clients.

From the descriptions and definitions in the draft, it would not be 
"normal" or "expected" to mix IPv6 transport with IPv4 transport
within a single OSPFv3 deployment.

> Is there any explicit preference over which version the adjacency 
> is build if v4 and v6 is available in that specific part of the network?

The choice of preferred OSPF transport really is something that the 
configuration engineer ought to configure.  As the details of configuring 
any IP router are outside the scope of the IETF, I am not sure that 
this I-D properly can or should say very more than it already says.

Perhaps the I-D could add clarifying text along these lines
somewhere in Section 2:

 "Implementers of OSPFv3 over IPv4 SHOULD add a configuration
  knob to let the router administrator select whether a given
  OSPFv3-enabled interface should use OSPFv3 over IPv4 or 
  OSPFv3 over IPv6.  Except when an OSPFv3 deployment is being 
  transitioned from using IPv4 transmission to using IPv6 
  transmission, it is RECOMMENDED that all routers within an 
  OSPFv3 deployment use the same IP version for OSPFv3 packet 
  transmission."

> What should happen when an IPv4 Link gets v6 added, graceful reestablish 
> the adjacency over IPv6, or wait until forced protocol switch?

See my answer just above.  

I would expect that any router that implements this I-D also would implement 
a configuration knob to indicate whether IPv4 transmission or IPv6 transmission 
is preferred.  Over time, a configuration engineer might change this 
(e.g. manually change from IPv4 transmission to IPv6 transmission AFTER 
an entire IPv4 network has been deployed-with/converted-to dual-stack
IPv4 and IPv6).

Yours,

Ran Atkinson

---

From: Karsten Thomann <[email-masked]>
Date: Sat, 15 Feb 2014 13:22:11 +0100

Am Montag, 10. Februar 2014, 14:33:05 schrieb RJ Atkinson:
> > is running over IPv4 and there are two (or more) IPv6 Islands already
> > deployed within the network, should there be any LSA flooding checks,
> > like do not flood LSA with IPv6 networks over IPv4 only links, or should
> > the route
I know that such deployments are normally well planned, but as there is already a draft about 
ospfv3 autoconfig, even if it is not designed to be used in company networks.

> is NOT a choice that I would make or that I would recommend to my clients.
I would not do it either, but I have already seen some strange ospf designs..., and as mentioned it 
is a case which can happen with ospf autoconfiguration, but we don't need to discuss it further as 
it is for homenetworks

> a configuration knob to indicate whether IPv4 transmission or IPv6
> transmission is preferred.  Over time, a configuration engineer might
> change this (e.g. manually change from IPv4 transmission to IPv6
> transmission AFTER an entire IPv4 network has been
> deployed-with/converted-to dual-stack IPv4 and IPv6).
> 
> Yours,
> 
> Ran Atkinson

Thanks for the detailed anwsers, I'm satisfied with the addition.

Kind regards,
Karsten
> 
> 
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf

---

From: Acee Lindem <[email-masked]>
Date: Mon, 17 Feb 2014 17:20:33 +0000

Hi Karsten,
We wil add Ran's suggested text to the next revision.
Thanks,
Acee

From: Karsten Thomann <[email-masked]<mailto:[email-masked]>>
Date: Saturday, February 15, 2014 4:22 AM
To: OSPF - OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: Re: [OSPF] draft-chen-ospf-transition-to-ospfv3-00.txt

> OSPF routers in that deployment.

I know that such deployments are normally well planned, but as there is already a draft about ospfv3 autoconfig, even if it is not designed to be used in company networks.

> is NOT a choice that I would make or that I would recommend to my clients.

I would not do it either, but I have already seen some strange ospf designs..., and as mentioned it is a case which can happen with ospf autoconfiguration, but we don't need to discuss it further as it is for homenetworks

Kind regards,

Karsten

> [email-masked]<mailto:[email-masked]>

---

From: Karsten Thomann <[email-masked]>
Date: Mon, 17 Feb 2014 21:13:01 +0100

Hi Acee,

found some nits to resolve in the next draft.
1. Introduction
s/to to/to

2. Encapsulation in IPv4
First sentence of the second passage
s/by a OSPF/by an OSPF

3. Security Considerations
In the second passage is a little typo it should be RFC6506 instead of 6505

5.2 Informative References

Headline is right for RFC 6506 and is correct after the headline but listed wrong as RFC6505.

Kind regards,
Karsten

Am Montag, 17. Februar 2014, 17:20:33 schrieben Sie:

Hi Karsten, 

*From: *Karsten Thomann <[email-masked][1]>

*Date: *Saturday, February 15, 2014 4:22 AM

*To: *OSPF - OSPF WG List <[email-masked][2]>

*Subject: *Re: [OSPF] draft-chen-ospf-transition-to-ospfv3-00.txt

Kind regards,
Karsten
> [email-masked][3]
> https://www.ietf.org/mailman/listinfo/ospf[4]

--------
[1] mailto:[email-masked]
[2] mailto:[email-masked]
[3] mailto:[email-masked]
[4] https://www.ietf.org/mailman/listinfo/ospf

---

From: Acee Lindem <[email-masked]>
Date: Wed, 26 Feb 2014 23:32:38 +0000

Thanks Karsten – we will include all these editorial changes in the next revision.
Acee

From: Karsten Thomann <[email-masked]<mailto:[email-masked]>>
Date: Monday, February 17, 2014 12:13 PM
To: Ericsson <[email-masked]<mailto:[email-masked]>>, OSPF - OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: Re: [OSPF] draft-chen-ospf-transition-to-ospfv3-00.txt

Hi Acee,

1. Introduction

s/to to/to

2. Encapsulation in IPv4

s/by a OSPF/by an OSPF

Kind regards,

Karsten

Hi Karsten,

Thanks,

Acee

Kind regards,

Karsten