Subject: [OSPF] OSPF over IPv4: use case example

From: RJ Atkinson <[email-masked]>
Date: Mon, 3 Mar 2014 05:41:06 -0500

Hi,

During the OSPF meeting (taking place now), Abhay recently
asked why IPv6 link-local addressing is not a sufficient
solution for OSPFv3 deployments (with AF extension)
in IPv4-only networks.

As we discussed during the meeting, there are some 
deployed link types that do not yet support IPv6 packets 
*at all*.  However, one imagines that over time, such 
links will have equipment upgrades to have full dual-stack
(IPv4 + IPv6) support.  Using OSPFv3/IPv4 now with the
AF extension -- and later migrating to OSPFv3 -- can
reduce operations costs significantly in at least some
deployments that I'm familiar with.

For example, some deployed IP/VSAT terminals either 
(A) have Ethernet interfaces that only support ARP 
and IPv4 [e.g., using EtherType to filter in hardware]
OR 
(B) have serial interfaces that again only support
IPv4/PPP packets. 

ASIDE with more context:
  For those who don't use SATCOM much, The term VSAT is
  precisely defined as "Very Small Aperture Terminal".
  "Very Small Aperture" typically means that the SATCOM
  dish on the ground is roughly 1m in diameter, rather
  than the rather larger SATCOM dishes used in some other
  deployments.  VSATs are quite commonly used around the 
  whole globe, in both developed and less developed regions.  
  
  Within North America they commonly are used to connect 
  retail sites (e.g. banks, petrol stations, consumer 
  electronics stores) back to the central site for that 
  business.

  Separately, it would not be odd for a VSAT deployment 
  to have an uplink speed that is ~10% of the downlink speed.

Yours,

Ran Atkinson

---

From: Acee Lindem <[email-masked]>
Date: Sun, 9 Mar 2014 16:31:24 +0000

Hi Ran, 
We will add this use case to the draft.
Thanks,
Acee 

On 3/3/14 2:41 AM, "RJ Atkinson" <[email-masked]> wrote:

>_______________________________________________
>OSPF mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/ospf