Subject: [OSPF] New Version Notification for draft-smirnov-ospf-xaf-te-01.txt

From: Anton Smirnov <[email-masked]>
Date: Wed, 16 Apr 2014 12:56:48 +0200

Hello,
    authors of this draft would like to solicit feedback. This draft was 
presented to WG in London and draft was updated couple of days ago to 
rectify notes received after the presentation.
    The draft proposes technique how IPv6 routes should be calculated 
over MPLS TE signaled by OSPFv2.

    The draft discusses why simple solution to the problem not requiring 
standardization works most of the time but if it fails it may fail with 
very big impact to the network and thus unacceptable. But presentation 
delivered during the meeting discussed this in pictures and in greater 
length, so if after reading the draft you would still not be convinced 
simple solution is not good enough I encourage you to review slide deck 
presented during the meeting.

Anton Smirnov

-------- Original Message --------
Subject: New Version Notification for draft-smirnov-ospf-xaf-te-01.txt
Date: Mon, 14 Apr 2014 13:48:01 -0700
From: <[email-masked]>

A new version of I-D, draft-smirnov-ospf-xaf-te-01.txt
has been successfully submitted by Anton Smirnov and posted to the
IETF repository.

Name:		draft-smirnov-ospf-xaf-te
Revision:	01
Title:		OSPF Routing with Cross-Address Family MPLS Traffic Engineering 
Tunnels
Document date:	2014-04-14
Group:		Individual Submission
Pages:		7
URL: 
http://www.ietf.org/internet-drafts/draft-smirnov-ospf-xaf-te-01.txt
Status:         https://datatracker.ietf.org/doc/draft-smirnov-ospf-xaf-te/
Htmlized:       http://tools.ietf.org/html/draft-smirnov-ospf-xaf-te-01
Diff: 
http://www.ietf.org/rfcdiff?url2=draft-smirnov-ospf-xaf-te-01

Abstract:
    When using Traffic Engineering (TE) in a dual-stack IPv4/IPv6 network
    the Multiprotocol Label Switching (MPLS) TE Label Switched Paths
    (LSP) infrastructure may be duplicated, even if the destination IPv4
    and IPv6 addresses belong to the same remote router.  In order to
    achieve an integrated MPLS TE LSP infrastructure, OSPF routes must be
    computed over MPLS TE tunnels created using information propagated in
    another OSPF instance.  This is solved by advertising cross-address
    family (X-AF) OSPF TE information.

    This document describes an update to RFC5786 that allows for the easy
    identification of a router's local X-AF IP addresses.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Acee Lindem <[email-masked]>
Date: Thu, 17 Apr 2014 21:08:32 +0000

Hi Anton, 

I think I’m finally understanding the application of this draft. You state that the OSPF and OSPFv3 domains need not coincide. That is true but they must at least include the head-end of the LSPs for which you want to compute LSP paths. Do you mean this to also apply to multiple instances of the same AF? It would be a very ugly network design where they are part of the same routing domain. 

Thanks,
Acee

On Apr 16, 2014, at 6:56 AM, Anton Smirnov <[email-masked]> wrote:

>   Hello,
>   authors of this draft would like to solicit feedback. This draft was presented to WG in London and draft was updated couple of days ago to rectify notes received after the presentation.
>   The draft proposes technique how IPv6 routes should be calculated over MPLS TE signaled by OSPFv2.
> 
>   The draft discusses why simple solution to the problem not requiring standardization works most of the time but if it fails it may fail with very big impact to the network and thus unacceptable. But presentation delivered during the meeting discussed this in pictures and in greater length, so if after reading the draft you would still not be convinced simple solution is not good enough I encourage you to review slide deck presented during the meeting.
> 
> Anton Smir
> Title:		OSPF Routing with Cross-Address Family MPLS Traffic Engineering Tunnels
> URL: http://www.ietf.org/internet-drafts/draft-smirnov-ospf-xaf-te-01.txt
> Diff: http://www.ietf.org/rfcdiff?url2=draft-smirnov-ospf-xaf-te-01
> 
> Abstract:
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf

---

From: Acee Lindem <[email-masked]>
Date: Thu, 17 Apr 2014 21:12:09 +0000

All,

The gist of the draft is to allow a single OSPF(v3) instance to signal LSP endpoints for both IPv4 and IPv6 and, thus, consolidate the TE routing domain. Is there interest in considering this work?

I would support it since it seems fairly straightforward (unless my reading has missed something).

Thanks,
Acee

Begin forwarded message:

From: Anton Smirnov <[email-masked]<mailto:[email-masked]>>
Subject: [OSPF] New Version Notification for draft-smirnov-ospf-xaf-te-01.txt
Date: April 16, 2014 at 6:56:48 AM EDT
To: OSPF List <[email-masked]<mailto:[email-masked]>>

  Hello,

Anton Smirnov

-------- Original Message --------
Subject: New Version Notification for draft-smirnov-ospf-xaf-te-01.txt
Date: Mon, 14 Apr 2014 13:48:01 -0700
From: <[email-masked]<mailto:[email-masked]>>

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

_______________________________________________
OSPF mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ospf

---

From: Anton Smirnov <[email-masked]>
Date: Fri, 18 Apr 2014 11:05:31 +0200

Hi Acee,

 > Do you mean this to also apply
 > to multiple instances of the same AF? It would be a very ugly network
 > design where they are part of the same routing domain.

    This technique allows one protocol instance to use TEs signaled by 
another protocol instance.
    Choice of instances may indeed be quite bizarre - for example, the 
same technique may be used to signal TEs via ISIS/IPv4 AF and be used 
for routing by OSPFv3/IPv6 AF. Possibility of making such design does 
not mean that this design makes practical sense or that we should care 
about it.

    As authors see it, the main application now would be to signal TEs 
via OSPFv2/IPv4 AF and use them for routing in OSPFv3/IPv6 AF.

    And, in more distant future, vice verse - signal TEs via OSPFv3/IPv6 
AF and use them for routing in OSPFv2/IPv4 AF. That may be needed when 
OSPFv2 is being phased out of the network - but of course we are very 
far from this point yet.

    While other combinations are theoretically possible we do not see 
practical value in them.

Anton

On 04/17/2014 11:08 PM, Acee Lindem wrote:
> Hi Anton,
>
> I think I’m finally understanding the application of this draft. You
> state that the OSPF and OSPFv3 domains need not coincide. That is
> true but they must at least include the head-end of the LSPs for
> which you want to compute LSP paths. Do you mean this to also apply
> to multiple instances of the same AF? It would be a very ugly network
> design where they are part of the same routing domain.
>
> Thanks, Acee
>
>> Hello, authors of this draft would like to solicit feedback. This
>> draft was presented to WG in London and draft was updated couple of
>> days ago to rectify notes received after the presentation. The
>> draft proposes technique how IPv6 routes should be calculated over
>> MPLS TE signaled by OSPFv2.
>>
>> The draft discusses why simple solution to the problem not
>> requiring standardization works most of the time but if it fails it
>> may fail with very big impact to the network and thus unacceptable.
>> But presentation delivered during the meeting discussed this in
>> pictures and in greater length, so if after reading the draft you
>> would still not be convinced simple solution is not good enough I
>> encourage you to review slide deck presented during the meeting.
>>
>> Anton Smir -------- Original Message -------- Subject: New Version
>> Notification for draft-smirnov-ospf-xaf-te-01.txt Date: Mon, 14 Apr
>> 2014 13:48:01 -0700 From: <[email-masked]>
>>
>>
>> A new version of I-D, draft-smirnov-ospf-xaf-te-01.txt has been
>> successfully submitted by Anton Smirnov and posted to the IETF
>> repository.
>>
>> Name:		draft-smirnov-ospf-xaf-te Revision:	01 Title:		OSPF Routing
>> with Cross-Address Family MPLS Traffic Engineering Tunnels Document
>> date:	2014-04-14 Group:		Individual Submission Pages:		7 URL:
>> Htmlized:
>> http://tools.ietf.org/html/draft-smirnov-ospf-xaf-te-01 Diff:
>> Abstract: When using Traffic Engineering (TE) in a dual-stack
>> IPv4/IPv6 network the Multiprotocol Label Switching (MPLS) TE Label
>> Switched Paths (LSP) infrastructure may be duplicated, even if the
>> destination IPv4 and IPv6 addresses belong to the same remote
>> router.  In order to achieve an integrated MPLS TE LSP
>> infrastructure, OSPF routes must be computed over MPLS TE tunnels
>> created using information propagated in another OSPF instance.
>> This is solved by advertising cross-address family (X-AF) OSPF TE
>> information.
>>
>> This document describes an update to RFC5786 that allows for the
>> easy identification of a router's local X-AF IP addresses.
>>
>>
>>
>>
>> Please note that it may take a couple of minutes from the time of
>> submission until the htmlized version and diff are available at
>> tools.ietf.org.
>>
>> The IETF Secretariat
>>
>>
>>
>> _______________________________________________ OSPF mailing list
>> [email-masked] https://www.ietf.org/mailman/listinfo/ospf
>