Subject: [OSPF] Comments on draft-xu-ospf-routable-ip-address

From: Abhay Roy <[email-masked]>
Date: Mon, 25 Aug 2014 11:57:28 -0700

[speaking as WG member]

Two comments..

1. Section 3 has this text - "This TLV is only applicable to OSPFv2.".
     I believe, this should also be applicable to RFC5838, i.e. for IPv4 
AF's

2. Section 3 and 4 describes the scope as SHOULD be domain-wide. I 
personally don't see any real use cause of any lessor scope (Area or 
Link) since we have mechanisms to generate routable IP address for those 
scopes already. So I would suggest we limit the scope of this document 
to be "MUST be domain-wide". Any concerns with that?

Regards,
-Abhay

---

From: Abhay Roy <[email-masked]>
Date: Mon, 25 Aug 2014 12:08:32 -0700

This is a simple document with a few strong drivers (ELC and S-BFD) 
requiring it..

Please share your support or objections in making it a WG document.

Regards,
-Abhay

On 8/25/14, 11:57 AM, Abhay Roy wrote:
>     I believe, this should also be applicable to RFC5838, i.e. for 
> IPv4 AF's
>
> Link) since we have mechanisms to generate routable IP address for 
> those scopes already. So I would suggest we limit the scope of this 
> document to be "MUST be domain-wide". Any concerns with that?
>
> Regards,
> -Abhay
>
>
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf

---

From: Karsten Thomann <[email-masked]>
Date: Mon, 25 Aug 2014 23:21:08 +0200

About your comments:
1. I've raised that question already june 8th onlist, but the discussion ended off list waiting for an 
answer from a co-author

2. Will check it tomorrow with some more time

I support making it a WG document, but would also like to get 1. clarified before WG adoption, but 
thats up to the WG consensus

Regards
Karsten

Am Montag, 25. August 2014, 12:08:32 schrieb Abhay Roy:

This is a simple document with a few strong drivers (ELC and S-BFD) requiring it.. 

Regards,-Abhay

[speaking as WG member]

Two comments..

1. Section 3 has this text - "This TLV is only applicable to OSPFv2.".     I believe, this should also be 
applicable to RFC5838, i.e. for IPv4 AF's 

2. Section 3 and 4 describes the scope as SHOULD be domain-wide. I personally don't see any real 
use cause of any lessor scope (Area or Link) since we have mechanisms to generate routable IP 
address for those scopes already. So I would suggest we limit the scope of this document to be 
"MUST be domain-wide". Any concerns with that? 

Regards,-Abhay

_______________________________________________
OSPF mailing list
[email-masked][1]
https://www.ietf.org/mailman/listinfo/ospf[2] 

--------
[1] mailto:[email-masked]
[2] https://www.ietf.org/mailman/listinfo/ospf

---

From: Manav Bhatia <[email-masked]>
Date: Tue, 26 Aug 2014 09:31:06 +0530

Hi Abhay,

Thanks for the review. We'll update the draft with these comments in
the next revision.

Can we request the chairs to poll the WG for accepting this as a WG doc?

Cheers, Manav

On Tue, Aug 26, 2014 at 12:27 AM, Abhay Roy <[email-masked]> wrote:
>     I believe, this should also be applicable to RFC5838, i.e. for IPv4 AF's
>
> personally don't see any real use cause of any lessor scope (Area or Link)
> since we have mechanisms to generate routable IP address for those scopes
> already. So I would suggest we limit the scope of this document to be "MUST
> be domain-wide". Any concerns with that?
>
> Regards,
> -Abhay
>

---

From: Manav Bhatia <[email-masked]>
Date: Tue, 26 Aug 2014 09:32:48 +0530

I see that a poll has already been issued.

Yes, i support this to be taken up as a WG document ! :-)

---

From: Uma Chunduri <[email-masked]>
Date: Tue, 26 Aug 2014 07:03:30 +0000

Dear  Abhay, Karsten,

Thanks for the comments.

My quick answers:
For -

1.       As Karsten said we discussed this offline and agreed that it's applicable to IPv4 AFs possible through RFC 5838. Thx.

2.       Agree. We will correct this.

--
Uma C.

From: OSPF [mailto:[email-masked]] On Behalf Of Karsten Thomann
Sent: Monday, August 25, 2014 2:21 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [OSPF] Poll for WG adoption of draft-xu-ospf-routable-ip-address

About your comments:

1. I've raised that question already june 8th onlist, but the discussion ended off list waiting for an answer from a co-author

I support making it a WG document, but would also like to get 1. clarified before WG adoption, but thats up to the WG consensus

Regards

Karsten

Regards,
-Abhay

[speaking as WG member]

Two comments..

2. Section 3 and 4 describes the scope as SHOULD be domain-wide. I personally don't see any real use cause of any lessor scope (Area or Link) since we have mechanisms to generate routable IP address for those scopes already. So I would suggest we limit the scope of this document to be "MUST be domain-wide". Any concerns with that?

Regards,
-Abhay

OSPF mailing list

[email-masked]<mailto:[email-masked]>

---

From: Uma Chunduri <[email-masked]>
Date: Tue, 26 Aug 2014 07:11:35 +0000

Dear Chairs,

Support  (also co-author).

--
Uma C.

---

From: Mach Chen <[email-masked]>
Date: Tue, 26 Aug 2014 09:49:33 +0000

Support.

Best regards,
Mach

From: OSPF [mailto:[email-masked]] On Behalf Of Abhay Roy
Sent: Tuesday, August 26, 2014 3:09 AM
To: [email-masked]
Subject: [OSPF] Poll for WG adoption of draft-xu-ospf-routable-ip-address

Regards,
-Abhay

Two comments..

Regards,
-Abhay

OSPF mailing list

---

From: Xuxiaohu <[email-masked]>
Date: Wed, 27 Aug 2014 02:10:31 +0000

Support as a co-author.

Xiaohu

Regards,
-Abhay

Two comments..

Regards,
-Abhay

OSPF mailing list

---

From: Lizhenbin <[email-masked]>
Date: Wed, 27 Aug 2014 05:08:06 +0000

Support.

Best Regards,

Robin

________________________________
发件人: OSPF [[email-masked]] 代表 Abhay Roy [[email-masked]]
发送时间: 2014年8月26日 3:08
收件人: [email-masked]
主题: [OSPF] Poll for WG adoption of draft-xu-ospf-routable-ip-address

Regards,
-Abhay

Two comments..

Regards,
-Abhay

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Wed, 27 Aug 2014 21:35:27 +0000

Support.

    Les

From: OSPF [mailto:[email-masked]] On Behalf Of Abhay Roy (akr)
Sent: Monday, August 25, 2014 12:09 PM
To: [email-masked]
Subject: [OSPF] Poll for WG adoption of draft-xu-ospf-routable-ip-address

Regards,
-Abhay

Two comments..

Regards,
-Abhay

OSPF mailing list

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Wed, 27 Aug 2014 23:39:01 +0000

I have read draft-xu-ospf-routable-ip-address and support its progress as an OSPF WG document.

Thanks!

-Nobo

From: OSPF [mailto:[email-masked]] On Behalf Of Abhay Roy (akr)
Sent: Monday, August 25, 2014 3:09 PM
To: [email-masked]
Subject: [OSPF] Poll for WG adoption of draft-xu-ospf-routable-ip-address

Regards,
-Abhay

Two comments..

Regards,
-Abhay

OSPF mailing list

---

From: Dhruv Dhody <[email-masked]>
Date: Sat, 30 Aug 2014 18:30:44 +0530

Hi,

I have read this I.D., and support its adoption.

Dhruv