Subject: Re: [OSPF] [spring] FW: New Version Notification for draft-lw-spring-sid-allocation-00.txt

From: Hannes Gredler <[email-masked]>
Date: Thu, 23 Oct 2014 17:46:34 +0200

liao,

my read of your draft is that you're utilizing IGP extensions to flood
configuration informatioun through the network. have you considered
using netconf/YANG for doing so ? and if so what is wrong (what
are the shortcomings) of netconf/YANG to configure RAN routers ?
IOW why are exisiting configuration mencahnism not good enough ?

/hannes

On Wed, Oct 22, 2014 at 05:35:48PM +0800, [email-masked] wrote:
|    In some situation where users expect to simply plug in a SR node and have
|    it automatically use Segment Routing.
|    This draft attempts to solve this need.
|    Expecting your review and comments. Thank you.
| 
|    Best Regards.
|    Ting, Bo, Fangwei, and Bhumip
| 
|    ----- ת���� ����038768/user/zte_ltd ʱ�� 2014-10-22 16:11 -----
| 
|    [email-masked] �ռ��� Bhumip Khasnabish
|                                    <[email-masked]>, "Bhumip
|    2014-10-22 16:02                Khasnabish" <[email-masked]>,
|                                    "fangwei hu" <[email-masked]>,
|                                    Fangwei Hu <[email-masked]>, "Wu
|                                    Bo" <[email-masked]>, "Ting Liao"
|                                    <[email-masked]>, Ting Liao
|                                    <[email-masked]>, Bo Wu
|                                    <[email-masked]>
|                               ����
|                               ���� New Version Notification for
|                                    draft-lw-spring-sid-allocation-00.txt
| 
| 
|    A new version of I-D, draft-lw-spring-sid-allocation-00.txt
|    has been successfully submitted by Fangwei Hu and posted to the
|    IETF repository.
| 
|    Name:                                  draft-lw-spring-sid-allocation
|    Revision:                 00
|    Title:                                  SPRING SID Allocation
|    Document date:                 2014-10-22
|    Group:                                  Individual Submission
|    Pages:                                  12
|    URL:
|     http://www.ietf.org/internet-drafts/draft-lw-spring-sid-allocation-00.txt
|    Status:
|    https://datatracker.ietf.org/doc/draft-lw-spring-sid-allocation/
|    Htmlized:
|    http://tools.ietf.org/html/draft-lw-spring-sid-allocation-00
| 
|    Abstract:
|      Segment Routing (SR) allows for a flexible definition of end-to-end
|      paths within IGP topologies by encoding paths as sequences of
|      topological sub-paths, called "segments".  These segments are
|      advertised by the link-state routing protocols (IS-IS and OSPF).  And
|      a segment is identified by a Segment Routing ID(SID).  This document
|      proposes a method that the only selected SR nodes responsible for
|      allocating SIDs for a SR domain to reduce SID configuration required
|      on all SR nodes.
| 
| 
| 
| 
|    Please note that it may take a couple of minutes from the time of
|    submission
|    until the htmlized version and diff are available at tools.ietf.org.
| 
|    The IETF Secretariat

| _______________________________________________
| spring mailing list
| [email-masked]
| https://www.ietf.org/mailman/listinfo/spring

---

From: "Osborne, Eric" <[email-masked]>
Date: Fri, 24 Oct 2014 11:29:38 +0000

I don’t understand the practical use of this draft.  If a node is going to pull SID information from the IGP as advertised by the SRMN, that node needs to understand whatever extensions you add to the IGP, and needs to be able to parse things to figure out what its own local label range is.  That’s pretty much exactly the work that the node would need to do with the current IGP extensions, where it advertises its own range+offset.

I’m having trouble coming up with a scenario where your approach is easier, more scalable, or otherwise beneficial in some way not covered by existing technology.  Can you clarify this for me?  I don’t mean “tell me how it’s *different* from what’s already defined”, I mean “tell me why it’s *better* than what’s already defined”

eric

From: Isis-wg [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, October 24, 2014 1:57 AM
To: Hannes Gredler
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Isis-wg] 答复: Re: [spring] FW: New Version Notification for draft-lw-spring-sid-allocation-00.txt

Hi, Hannes

Thanks for your review and the good comments.

 In this draft, SID can be automatically generated by a control node (the Segment Routing Management Nodes (SRMNs)）,
and the SRMNs generate the SID mapping to each node in the SR domain，
then the IGP extension flooding out to every node, each node will know the sid allocated to each other.

While if we use  Netconf/YANG, all the nodes in the SR domain should be supported  the open interface to Netconf/YANG,
which is not easy, for many ASGs, CSGs only support SNMP protocol in the IP RAN scenarios.
So this solution could simpify the conguration of ASG,CSG(actually it is zero-configuratin for them), which is very important for the operation.

Best Regards.
Ting

Hannes Gredler <[email-masked]<mailto:[email-masked]>>

2014-10-23 23:46

收件人

<[email-masked]<mailto:[email-masked]>>

抄送

"[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

主题

Re: [spring] FW: New Version Notification for draft-lw-spring-sid-allocation-00.txt

liao,

/hannes

On Wed, Oct 22, 2014 at 05:35:48PM +0800, [email-masked]<mailto:[email-masked]> wrote:
|    In some situation where users expect to simply plug in a SR node and have
|    it automatically use Segment Routing.
|    This draft attempts to solve this need.
|    Expecting your review and comments. Thank you.
|
|    Best Regards.
|    Ting, Bo, Fangwei, and Bhumip
|
|    ----- ת???Ë ?Î?Ã038768/user/zte_ltd ʱ?? 2014-10-22 16:11 -----
|
|    [email-masked]<mailto:[email-masked]> ?Õ???Ë Bhumip Khasnabish
|                                    <[email-masked]<mailto:[email-masked]>>, "Bhumip
|    2014-10-22 16:02                Khasnabish" <[email-masked]<mailto:[email-masked]>>,
|                                    "fangwei hu" <[email-masked]<mailto:[email-masked]>>,
|                                    Fangwei Hu <[email-masked]<mailto:[email-masked]>>, "Wu
|                                    Bo" <[email-masked]<mailto:[email-masked]>>, "Ting Liao"
|                                    <[email-masked]<mailto:[email-masked]>>, Ting Liao
|                                    <[email-masked]<mailto:[email-masked]>>, Bo Wu
|                                    <[email-masked]<mailto:[email-masked]>>
|                               ???Í
|                               ?÷?â New Version Notification for
|                                    draft-lw-spring-sid-allocation-00.txt
|
|
|    A new version of I-D, draft-lw-spring-sid-allocation-00.txt
|    has been successfully submitted by Fangwei Hu and posted to the
|    IETF repository.
|
|    Name:                                  draft-lw-spring-sid-allocation
|    Revision:                 00
|    Title:                                  SPRING SID Allocation
|    Document date:                 2014-10-22
|    Group:                                  Individual Submission
|    Pages:                                  12
|    URL:
|     http://www.ietf.org/internet-drafts/draft-lw-spring-sid-allocation-00.txt
|    Status:
|    https://datatracker.ietf.org/doc/draft-lw-spring-sid-allocation/
|    Htmlized:
|    http://tools.ietf.org/html/draft-lw-spring-sid-allocation-00
|
|    Abstract:
|      Segment Routing (SR) allows for a flexible definition of end-to-end
|      paths within IGP topologies by encoding paths as sequences of
|      topological sub-paths, called "segments".  These segments are
|      advertised by the link-state routing protocols (IS-IS and OSPF).  And
|      a segment is identified by a Segment Routing ID(SID).  This document
|      proposes a method that the only selected SR nodes responsible for
|      allocating SIDs for a SR domain to reduce SID configuration required
|      on all SR nodes.
|
|
|
|
|    Please note that it may take a couple of minutes from the time of
|    submission
|    until the htmlized version and diff are available at tools.ietf.org.
|
|    The IETF Secretariat

| _______________________________________________
| spring mailing list
| [email-masked]<mailto:[email-masked]>
| https://www.ietf.org/mailman/listinfo/spring