Subject: [OSPF] Update to OSPF YANG model

From: "Derek Man-Kit Yeung (myeung)" <[email-masked]>
Date: Tue, 14 Oct 2014 22:16:16 +0000

FYI. Please note that a new version of OSPF YANG model has been submitted.

A new version of I-D, draft-yeung-netmod-ospf-02.txt
has been successfully submitted by Derek Yeung and posted to the
IETF repository.

Name: draft-yeung-netmod-ospf
Revision: 02
Title: Yang Data Model for OSPF Protocol
Document date: 2014-10-14
Group: Individual Submission
Pages: 72
URL:            http://www.ietf.org/internet-drafts/draft-yeung-netmod-ospf-02.txt
Status:         https://datatracker.ietf.org/doc/draft-yeung-netmod-ospf/
Htmlized:       http://tools.ietf.org/html/draft-yeung-netmod-ospf-02
Diff:           http://www.ietf.org/rfcdiff?url2=draft-yeung-netmod-ospf-02

Abstract:
   This document defines a YANG data model that can be used to configure
   and manage OSPF.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

Thanks,
- Derek

---

From: Uma Chunduri <[email-masked]>
Date: Wed, 15 Oct 2014 05:46:52 +0000

Thank you for the draft and it's very useful (have few comments and shall discuss).

--
Uma C.

From: OSPF [mailto:[email-masked]] On Behalf Of Derek Man-Kit Yeung (myeung)
Sent: Tuesday, October 14, 2014 3:16 PM
To: [email-masked]
Subject: [OSPF] Update to OSPF YANG model

Name:
draft-yeung-netmod-ospf
Revision:
02
Title:
Yang Data Model for OSPF Protocol
Document date:
2014-10-14
Group:
Individual Submission
Pages:
72

Abstract:

The IETF Secretariat

Thanks,
- Derek

---

From: "Derek Man-Kit Yeung (myeung)" <[email-masked]>
Date: Fri, 24 Oct 2014 21:29:35 +0000

Uma,

Sure. Please send us the comments.

To jump start the discussion, I list a few areas that the co-authors are looking for feedback from the WG.

Notifications

- The current model define notifications for all the traps common between OSPFv2 and OSPFv3 MIB.

- In order words, there is no matching notification defined for ospfIfAuthFailure , ospfMaxAgeLsa, ospfOriginateLsa, ospfTxRetransmit,

- Should the above be defined too?

- Are there any new notification beyond the exiting MIB that we should include?

RPC

- There is no RPC defined in the data model.

- Is there any use case for them?

Operation data

- There are known missing config and operation data from the model.

- We plan to add back authentication and counters in the upcoming iterations.

- Are there other config/operation states to be added?

Protocol centric vs VRF centric data model

- The current data model support both, Should we:

1) Keep it this way and let vendors pick which style best suit them.

2) Keep it this way and require vendors to support both styles (Just through the model, not CLI). Or

3) Pick one for the data model and so vendor only support one style.

Thanks,
- Derek

From: Uma Chunduri <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, October 14, 2014 10:46 PM
To: myeung <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: Update to OSPF YANG model

Thank you for the draft and it’s very useful (have few comments and shall discuss).

--
Uma C.

From: OSPF [mailto:[email-masked]] On Behalf Of Derek Man-Kit Yeung (myeung)
Sent: Tuesday, October 14, 2014 3:16 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [OSPF] Update to OSPF YANG model

Name:
draft-yeung-netmod-ospf
Revision:
02
Title:

Abstract:

The IETF Secretariat

Thanks,
- Derek