Subject: [OSPF] FW: New Version Notification for draft-chunduri-ospf-self-defined-sub-tlvs-00.txt

From: Uma Chunduri <[email-masked]>
Date: Wed, 15 Oct 2014 23:30:52 +0000

Dear OSPF WG,

 Please see the link for the document below.

Abstract:
   This document proposes a TLV within the body of the OSPF Router
   Information (RI) Opaque LSA, called Self-defined Sub-TLV Container
   TLV.  Here the term OSPF means both OSPFv2 and OSPFv3.	

Comments/Concerns/Suggestions welcome!

--
Uma C.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, October 15, 2014 3:32 PM
To: Uma Chunduri; Luis M. Contreras; Xiaohu Xu; Luis M.Contreras; Xiaohu Xu; Uma Chunduri
Subject: New Version Notification for draft-chunduri-ospf-self-defined-sub-tlvs-00.txt

A new version of I-D, draft-chunduri-ospf-self-defined-sub-tlvs-00.txt
has been successfully submitted by Uma Chunduri and posted to the IETF repository.

Name:		draft-chunduri-ospf-self-defined-sub-tlvs
Revision:	00
Title:		Using Self-defined Sub-TLVs for Agile Service Deployment
Document date:	2014-10-15
Group:		Individual Submission
Pages:		7
URL:            http://www.ietf.org/internet-drafts/draft-chunduri-ospf-self-defined-sub-tlvs-00.txt
Status:         https://datatracker.ietf.org/doc/draft-chunduri-ospf-self-defined-sub-tlvs/
Htmlized:       http://tools.ietf.org/html/draft-chunduri-ospf-self-defined-sub-tlvs-00

---

From: Anton Smirnov <[email-masked]>
Date: Thu, 16 Oct 2014 11:36:11 +0200

Hi Uma,
    there is very important difference with admin tags.
    Admin tags have known formatting. Because of this it is possible to 
advertise a tag from implementation even if it doesn't support 
functionality which local network policy designates to the tag.
    Self-defined TLV does not have fixed formatting known beforehand. So 
only the implementation which is aware of its internals can originate 
and interpret it. For this reason it is more like Experimental or 
Vendor-Specific Sub-TLV.

Anton

On 10/16/2014 01:30 AM, Uma Chunduri wrote:
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf
>

---

From: Uma Chunduri <[email-masked]>
Date: Thu, 16 Oct 2014 18:05:34 +0000

Hi Anton,
Thanks for reading the document and bringing the subtle difference with node Admin tags. 
In-line ..[Uma]:

--
Uma C.

-----Original Message-----
From: Anton Smirnov [mailto:[email-masked]] 
Sent: Thursday, October 16, 2014 2:36 AM
To: Uma Chunduri; [email-masked]
Subject: Re: [OSPF] FW: New Version Notification for draft-chunduri-ospf-self-defined-sub-tlvs-00.txt

    Hi Uma,
    there is very important difference with admin tags.
    Admin tags have known formatting. Because of this it is possible to advertise a tag from implementation even if it doesn't support functionality which local network policy designates to the tag.
[Uma]: The part which is common here is advertising  information from the local Policy into the OSPF area/Domain. But in case of Self-defined TLV you are also associating and advertising certain  attributes and this can also be used by an external entity
             to make certain decisions/derive some conclusions. This is the key.
    Self-defined TLV does not have fixed formatting known beforehand. So only the implementation which is aware of its internals can originate and interpret it. For this reason it is more like Experimental or Vendor-Specific Sub-TLV.
[Uma]:  Yes, if node which receives  Self-defined TLV, and doesn't support the functionality it can't interpret it . The part what is similar is, even if Admin tag with fixed format is understood by the receiving node,
              which can't support the functionality can't  still interpret the meaning of it.
For this reason it is more like Experimental or Vendor-Specific Sub-TLV.
[Uma]: I would not say "vendor" specific , rather deployment specific as interpreted and provisioned by the operator.

Anton

On 10/16/2014 01:30 AM, Uma Chunduri wrote:
> Subject: New Version Notification for 
> draft-chunduri-ospf-self-defined-sub-tlvs-00.txt
>
>