Subject: [OSPF] WG Draft QA review of draft-ietf-ospf-routable-ip-address-00

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Tue, 14 Oct 2014 03:44:26 +0000

Hello,

I have been selected as the Routing Directorate QA reviewer for draft-ietf-ospf-routable-ip-address-00.

The Routing Directorate QA reviews are intended to be a support to improve the quality of RTG Area documents as they pass through the IETF process. This is the QA review just after WG adoption.

Summary

This draft defines a useful extension to OSPF to allow routers in other areas to be able to associate reachable addresses with a router which supports a

particular capability. I do not foresee any major hurdles in this document progressing to become an RFC.

Comments

It would be beneficial to explain why the routable address information only needs to be flooded with domain-scope

(i.e. explain how routers in the area already have this information).

I suspect the security folks will likely point to the dangers of advertising local node addresses domain wide -

which may make it easier for a node in one area to be targeted from another area. The security section should

anticipate this by referencing the various OSPF authentication RFCs as the means to protect this information.

Major Issues

No major issues found.

Minor Issues

The IANA Comsiderations section should refer to the OSPF Router Information (RI) TLVs Registry defined by [RFC4970].

Nits

Abstract: Last sentence

   s/the OSPF/the term OSPF

Introduction: First paragraph

   " propagated to another area, those routers in the latter area need..."

The sentence should end after "area" and a new sentence begin with "Those".

Introduction: Last sentence

   s/the OSPF/the term OSPF

Section 3: penultimate sentence

The phrase

  "within the body of the corresponding RI Opaque LSA"

can be removed. It repeats the first sentence of the paragraph and does not match the equivalent text in Section 4.

---

From: Uma Chunduri <[email-masked]>
Date: Wed, 15 Oct 2014 05:44:26 +0000

Hi Les,

Thanks for your review and comments.
Please see my replies in-line [Uma]:

--
Uma C.

From: OSPF [mailto:[email-masked]] On Behalf Of Les Ginsberg (ginsberg)
Sent: Monday, October 13, 2014 8:44 PM
To: [email-masked]
Cc: OSPF List ([email-masked]); Ospf Chairs ([email-masked])
Subject: [OSPF] WG Draft QA review of draft-ietf-ospf-routable-ip-address-00

Hello,

Summary

Comments

[Uma]:  Sure, we shall add a statement to indicate why this is relevant for domain scope.

[Uma]: Though multiple areas,  as all under same administrative domain, knowing this information  through RI LSA should not be a concern as such.

             But we shall refer security RFC's relevant as you indicated.

Major Issues

No major issues found.

Minor Issues

Nits

Abstract: Last sentence

   s/the OSPF/the term OSPF

[Uma]: Sure.

[Uma]: Sure.

   s/the OSPF/the term OSPF

[Uma]: Sure.

The phrase

[Uma]: Sure. Thanks!