Subject: [OSPF] draft-ietf-ospf-segment-routing-extensions-03

From: Shraddha Hegde <[email-masked]>
Date: Tue, 2 Dec 2014 16:50:11 +0000

Authors,

Some  comments on the draft.

1.      The draft refers to the various use cases in the use case document in I-D.filsfils-rtgwg-segment-routing. It's useful to mention the section of the use case draft which is applicable for each reference instead of giving generic reference.
2.      Section 7.2 LAN Adj-sid sub TLV:
    Based on the description of the text it appears that the LAN AdjSID Sub TLV can contain multiple neighbor-ID /SID pairs based on the nodes attached to a broadcast network. The TLV diagram should depict carrying multiple such pairs.

       "It is used to advertise a SID/Label for an
   adjacency to a non-DR node on a broadcast or NBMA network."

   Does the above statement mean only DR originates the LAN-Adj SID and advertises label to non-DR nodes?
      Shouldn't each node in broadcast link  originate LAN adj-SID and advertise label to all other nodes on the link?

3.      Adj-Sid sub TLV section 7.1:
    Description of V-flag mentions Prefix-SID,  it should be changed to Adj-SID.
4.      Section 4: Extended prefix range TLV is very similar to Extended prefix TLV just that it has additional range associated with it.
    I would think that we should have "route type" as in Extended prefix TLV instead of just having a bit indicating "inter area"

    Rgds
    Shraddha

---

From: Peter Psenak <[email-masked]>
Date: Tue, 02 Dec 2014 18:08:41 +0100

Shraddha,

please see inline:

On 12/2/14 17:50 , Shraddha Hegde wrote:
>  1. The draft refers to the various use cases in the use case document
>     in I-D.filsfils-rtgwg-segment-routing. It’s useful to mention the
>     section of the use case draft which is applicable for each reference
>     instead of giving generic reference.

sure, we can add that.

> Based on the description of the text it appears that the LAN AdjSID Sub
> TLV can contain multiple neighbor-ID /SID pairs based on the nodes
> attached to a broadcast network. The TLV diagram should depict carrying
> multiple such pairs.

no. LAN AdjSID Sub TLV only advertises a adj-SID for a single neighbor. 
If you have more non-DR neighbors, you need to advertise multiple LAN 
Adj-SID Sub-TLVs.

>         “It is used to advertise a SID/Label for an
>     adjacency to a non-DR node on a broadcast or NBMA network.”
> Does the above statement mean only DR originates the LAN-Adj SIDand
> advertises label to non-DR nodes?

no.

>        Shouldn’t each node in broadcast link originate LAN adj-SID and
> advertise label to all other nodes on the link?

For the adjacency to DR, Adj-SID Sub-TLV is used. For the adjacency to 
non-DR LAN Adj-SID Sub-TLV is used. It's done all all nodes on the LAN.

> Description of V-flag mentions Prefix-SID,  it should be changed to Adj-SID.

good catch, will correct.

>
>  4. Section 4: Extended prefix range TLV is very similar to Extended
>     prefix TLV just that it has additional range associated with it.

yes, that is correct.

>
> I would think that we should have "route type" as in Extended prefix TLV
> instead of just having a bit indicating "inter area"

route-type would be misleading for range, as single range can include 
prefixes of various types (intra, inter, external). We have discussed 
this between authors and we agreed route-type is not the right way.

thanks,
Peter

---

From: Shraddha Hegde <[email-masked]>
Date: Wed, 3 Dec 2014 05:10:58 +0000

Peter,

<Snipped to open points>

>        Shouldn't each node in broadcast link originate LAN adj-SID and

<Shraddha> Is there a specific reason to advertise adj-sid for the DR and LAN adj-sid for non-DR?
                      Is it because the Neighbor-ID is already part of Extended link TLV and we are saving 4 bytes?

<Shraddha> The prefix range TLV is carried in Extended prefix LSA which is based on scope of flooding.
                       If we combine intra/inter/external in the prefix range TLV, what scope is used for flooding the extended prefix LSA?

Rgds
Shraddha

-----Original Message-----
From: Peter Psenak [mailto:[email-masked]] 
Sent: Tuesday, December 02, 2014 10:39 PM
To: Shraddha Hegde; [email-masked]
Cc: OSPF WG List
Subject: Re: draft-ietf-ospf-segment-routing-extensions-03

Shraddha,

please see inline:

On 12/2/14 17:50 , Shraddha Hegde wrote:
>     in I-D.filsfils-rtgwg-segment-routing. It's useful to mention the

sure, we can add that.

> Based on the description of the text it appears that the LAN AdjSID 
> Sub TLV can contain multiple neighbor-ID /SID pairs based on the nodes 
> attached to a broadcast network. The TLV diagram should depict 
> carrying multiple such pairs.

no. LAN AdjSID Sub TLV only advertises a adj-SID for a single neighbor. 
If you have more non-DR neighbors, you need to advertise multiple LAN Adj-SID Sub-TLVs.

no.

>        Shouldn't each node in broadcast link originate LAN adj-SID and

yes, that is correct.

thanks,
Peter

---

From: Peter Psenak <[email-masked]>
Date: Wed, 03 Dec 2014 09:30:38 +0100

Shraddha,

please see inline:

>                        Is it because the Neighbor-ID is already part of Extended link TLV and we are saving 4 bytes?

for adjacency on 2p2 link and adjacency to DR, link-type and link-id in 
Extended link TLV is used. For non-DR case, we need to describe the 
neighbor by neighbor-id, so we needed a new sub-TLV to do that.

>                         If we combine intra/inter/external in the prefix range TLV, what scope is used for flooding the extended prefix LSA?

prefix range is used for SR mapping server to optimize the SID 
advertisement. Prefix range as such does not need to have a route type, 
because it is not advertising a reachability. One can use domain wide 
flooding for certain external prefix, but use regular inter-area 
distribution for prefix range that is covering the external prefix.

thanks,
Peter

> .

---

From: Shraddha Hegde <[email-masked]>
Date: Thu, 4 Dec 2014 16:45:24 +0000

Peter,

<Shraddha>  Combining the different route types in the prefix range TLV looks very complex.
                        How practical it is in a real deployment to get a prefix range that covers through intra/inter/external route types?                       
          
                       In my opinion, it is adding unnecessary complexity into the protocol.
                      If a prefix range covers intra and inter area routes would the IA flag be set?
                      Would this prefix range be propagated from backbone area to non-backbone area?
                      If some prefix range contains a mix of inter and external how's the inter area prefix SIDs 
                      Propagated into NSSA area and external ones blocked?
                   
                     Keeping the prefix ranges confined within route types would make it much more simple.

Rgds
Shraddha

-----Original Message-----
From: Peter Psenak [mailto:[email-masked]] 
Sent: Wednesday, December 03, 2014 2:01 PM
To: Shraddha Hegde; [email-masked]
Cc: OSPF WG List
Subject: Re: draft-ietf-ospf-segment-routing-extensions-03

Shraddha,

please see inline:

On 12/3/14 06:10 , Shraddha Hegde wrote:
> Peter,
>
> <Snipped to open points>
>
>>         Shouldn't each node in broadcast link originate LAN adj-SID 
>> and advertise label to all other nodes on the link?
>

for adjacency on 2p2 link and adjacency to DR, link-type and link-id in Extended link TLV is used. For non-DR case, we need to describe the neighbor by neighbor-id, so we needed a new sub-TLV to do that.

thanks,
Peter

---

From: Peter Psenak <[email-masked]>
Date: Thu, 04 Dec 2014 18:45:24 +0100

Shraddha,

>                          How practical it is in a real deployment to get a prefix range that covers through intra/inter/external route types?

Imagine you want to advertise a SIDs for a range 192.0.2.1, Prefix 
Length 32, Range Size 255. Out of that range individual /32 prefixes can 
be of different route-types. Prefix range does not have a route-type.

>                        If a prefix range covers intra and inter area routes would the IA flag be set?

IA flag has nothing to do with the route-type. IA flag means that the 
range advertisement has bean 'leaked' between areas and is used to 
prevent redundant leaking.

>                        Would this prefix range be propagated from backbone area to non-backbone area?

yes, SRMS range advertisements will be propagated between areas if LSA 
type 10 is used for the advertisement.

>                        Propagated into NSSA area and external ones blocked?

that is not a problem. You may not have external prefix in NSSA area, 
but the range can still cover such external prefix. In such case the SID 
for the external prefix will never be used in NSSA area.

>                       Keeping the prefix ranges confined within route types would make it much more simple.

true, but it will make the deployment harder.

thanks,
Peter

---

From: Shraddha Hegde <[email-masked]>
Date: Fri, 5 Dec 2014 04:52:11 +0000

Peter,

<snipped>

>                        Would this prefix range be propagated from backbone area to non-backbone area?

yes, SRMS range advertisements will be propagated between areas if LSA type 10 is used for the advertisement.

<Shraddha> You mean area scope (type 10) LSAs will be flooded across area boundary? Or you mean they will be
                       Re-originated at the boundary and if AS scope LSA (type 11) they will be flooded across the boundary?

<Shraddha> OK. I see your point.

I think the document needs to capture the information that the prefix range can have different route-types covered.
It wasn't clear from reading the document. Probably an "elements of  procedure" section is required for the prefix range TLV
To cover the flooding scope and other aspects.

One more point to be mentioned is that if there is a prefix range TLV that covers a certain prefix and there is also a prefix SID
For the same prefix , then the prefix SID should be considered and the SID in the prefix range should be ignored.

Rgds
Shraddha

-----Original Message-----
From: Peter Psenak [mailto:[email-masked]] 
Sent: Thursday, December 04, 2014 11:15 PM
To: Shraddha Hegde; [email-masked]
Cc: OSPF WG List
Subject: Re: draft-ietf-ospf-segment-routing-extensions-03

Shraddha,

On 12/4/14 17:45 , Shraddha Hegde wrote:
>
> Peter,
>
>>
>>> I would think that we should have "route type" as in Extended prefix 
>>> TLV instead of just having a bit indicating "inter area"
>>
> advertisement. Prefix range as such does not need to have a route 
> type, because it is not advertising a reachability. One can use domain 
> wide flooding for certain external prefix, but use regular inter-area 

Imagine you want to advertise a SIDs for a range 192.0.2.1, Prefix Length 32, Range Size 255. Out of that range individual /32 prefixes can be of different route-types. Prefix range does not have a route-type.

>                        If a prefix range covers intra and inter area routes would the IA flag be set?

IA flag has nothing to do with the route-type. IA flag means that the range advertisement has bean 'leaked' between areas and is used to prevent redundant leaking.

>                        Would this prefix range be propagated from backbone area to non-backbone area?

yes, SRMS range advertisements will be propagated between areas if LSA type 10 is used for the advertisement.

>                        Propagated into NSSA area and external ones blocked?

that is not a problem. You may not have external prefix in NSSA area, but the range can still cover such external prefix. In such case the SID for the external prefix will never be used in NSSA area.

thanks,
Peter
> To: Shraddha Hegde; 
> [email-masked]
> Cc: OSPF WG List
>> For the adjacency to DR, Adj-SID Sub-TLV is used. For the adjacency 
>> to non-DR LAN Adj-SID Sub-TLV is used. It's done all all nodes on the LAN.
>>
>>> I would think that we should have "route type" as in Extended prefix 
>>> TLV instead of just having a bit indicating "inter area"
>>
> advertisement. Prefix range as such does not need to have a route 
> type, because it is not advertising a reachability. One can use domain 
> wide flooding for certain external prefix, but use regular inter-area 
>> To: Shraddha Hegde; 
>> [email-masked]
>> Cc: OSPF WG List
>>> Sub TLV can contain multiple neighbor-ID /SID pairs based on the 
>>> nodes attached to a broadcast network. The TLV diagram should depict 
>> For the adjacency to DR, Adj-SID Sub-TLV is used. For the adjacency 
>> to non-DR LAN Adj-SID Sub-TLV is used. It's done all all nodes on the LAN.
>>
>>>
>>> I would think that we should have "route type" as in Extended prefix 
>>> TLV instead of just having a bit indicating "inter area"
>>

---

From: Peter Psenak <[email-masked]>
Date: Fri, 05 Dec 2014 09:08:05 +0100

Shraddha,

>                         Re-originated at the boundary and if AS scope LSA (type 11) they will be flooded across the boundary?

type 10 will be reoriginated, type 11 will be flooded across.
> To cover the flooding scope and other aspects.

sure.

> For the same prefix , then the prefix SID should be considered and the SID in the prefix range should be ignored.

agreed. Will add that to the doc.

thanks,
Peter