Subject: [OSPF] Feedback regarding draft-ietf-ospf-ospfv3-autoconfig

From: Rama Darbha <[email-masked]>
Date: Fri, 23 Jan 2015 22:51:29 -0500

A. Lindem and J. Arkko,

Some feedback on this draft. In section 5:

"5.  OSPFv3 Router ID Selection
A pseudo-random number SHOULD be used for the OSPFv3 Router ID."

I think it would be valuable to describe why a pseudo-random number should
be chosen. The [OSPFv3] document doesn't make any reference to selecting a
pseudo-random number, so it would be good to justify the reasoning.
Something along the lines of:
"The router id in OSPFv3 is a 32-bit value [OSPFv3]. As outlined in
[OSPFv3], a router running OSPFv3 may not have an IPv4 address to
automatically select as the router id. Since auto-configuration cannot
guarantee a unique router id as outlined in [OSPFv3], a pseudo-random
router id is the solution for OSPFv3 autoconfiguration to prevent router id
collision."

Also, there's a small formatting error. Section 7.2 and 7.4 are not marked
correctly as headers.

Regards,
Rama

-- 
-----
Rama Darbha
[email-masked]
919 410 7262

---

From: Acee Lindem <[email-masked]>
Date: Sat, 24 Jan 2015 19:23:46 -0500

Hi Rama,

> On Jan 23, 2015, at 10:51 PM, Rama Darbha <[email-masked] <mailto:[email-masked]>> wrote:
> 
> A. Lindem and J. Arkko,
> 
> I think it would be valuable to describe why a pseudo-random number should be chosen. The [OSPFv3] document doesn't make any reference to selecting a pseudo-random number, so it would be good to justify the reasoning. Something along the lines of:
> "The router id in OSPFv3 is a 32-bit value [OSPFv3]. As outlined in [OSPFv3], a router running OSPFv3 may not have an IPv4 address to automatically select as the router id. Since auto-configuration cannot guarantee a unique router id as outlined in [OSPFv3], a pseudo-random router id is the solution for OSPFv3 autoconfiguration to prevent router id collision.”

Since the whole draft is about autoconfiguration, I would think this is obvious that the router would not have an IPv4 address. We also state:

   An OSPFv3 router requires a unique Router ID within the OSPFv3
   routing domain for correct protocol operation.  An OSPFv3 router
   implementing this specification will select a router-id that has a
   high probability of uniqueness.

If I did add something, it would be:

   Existing Router ID selection algorithms (section C.1 in [OSPFV2] and 
   [OSPFV3]) are not viable since they are dependent on a unique IPv4  
   interface address which is not likely to be available in auto configured 
   deployments.

> 
> 
> 
> Also, there's a small formatting error. Section 7.2 and 7.4 are not marked correctly as headers.

This really isn’t a formatting error. The problem is that heading is too long to fit on one line. I think I will shorten the headings to fit on a single line to avoid confusion. 

> 
> 
> Regards,
> Rama
> 
> -- 
> -----
> Rama Darbha
> [email-masked] <mailto:[email-masked]>
> 919 410 7262
> _______________________________________________
> OSPF mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ospf

---

From: Mitchell Erblich <[email-masked]>
Date: Sat, 24 Jan 2015 17:34:18 -0800

Group,

		First, I have not read this document, so please don’t shoot the messenger.

		May I add, …

			If due to configuration or other reasons that the router is late in announcing its Router ID compared to receiving Router IDs, independent of any means that a Router ID is chosen, it MUST compare its to be announced Router ID with ALL received Router IDs, as to identify if a Router ID collision would occur and take the appropriate steps.

			Additionally, after a router has begun announcing its Router ID, it SHOULD ?randomly/periodicly?, if the check is not already done with each received Router ID, compare its announced Router ID with all received Router IDs, as to identify if a collision has occurred.

			Secondly, wouldn’t any auto configuration method using any random type generation mitigate and not prevent router id collisions?

		Mitchell Erblich

On Jan 23, 2015, at 7:51 PM, Rama Darbha <[email-masked]> wrote:

> "The router id in OSPFv3 is a 32-bit value [OSPFv3]. As outlined in [OSPFv3], a router running OSPFv3 may not have an IPv4 address to automatically select as the router id. Since auto-configuration cannot guarantee a unique router id as outlined in [OSPFv3], a pseudo-random router id is the solution for OSPFv3 autoconfiguration to prevent router id collision."
> 
> 
> 
> [email-masked]