Subject: [OSPF] OSPF Topology Transparent Zone (TTZ) WG Poll for Adoption as Experimental

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sat, 10 Jan 2015 21:09:18 +0000

We have discussed OSPF TTZ at several IETFs and the authors and their
colleagues have even developed a working prototype. We believe there is
consensus that the protocol mechanisms are viable. However, there is
disagreement as to whether or not these mechanisms will provide
significant benefit. The answer is definitely topology and deployment
dependent. After some discussion, we have decided to poll for adoption as
an experimental draft. Please indicate your support or opposition WG
adoption as experimental prior to January 24th, 2015.

For your convenience, here is a URL for the draft:

http://www.ietf.org/id/draft-chen-ospf-ttz-09.txt

Thanks,
Acee and Abhay

---

From: Huaimo Chen <[email-masked]>
Date: Sun, 11 Jan 2015 03:07:57 +0000

I was a member of a team on vendor side for dividing a network with only area 0 into a few of areas. The team spent a long time (1+ years) in splitting the network into multiple areas in order to have minimum service interruptions.

OSPF Topology Transparent Zone (TTZ) provides an easy way to transfer a part of network in an area into a zone smoothly without service interruptions. In a few simple steps, a part of network is transferred into a zone smoothly. The zone also makes the LSDB become smaller. These have been demonstrated live. 

So I support it for WG adoption.

Best Regards,
Huaimo as an author
-----Original Message-----
From: OSPF [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: Saturday, January 10, 2015 4:09 PM
To: OSPF WG List
Subject: [OSPF] OSPF Topology Transparent Zone (TTZ) WG Poll for Adoption as Experimental

We have discussed OSPF TTZ at several IETFs and the authors and their colleagues have even developed a working prototype. We believe there is consensus that the protocol mechanisms are viable. However, there is disagreement as to whether or not these mechanisms will provide significant benefit. The answer is definitely topology and deployment dependent. After some discussion, we have decided to poll for adoption as an experimental draft. Please indicate your support or opposition WG adoption as experimental prior to January 24th, 2015.

Thanks,
Acee and Abhay 

_______________________________________________
OSPF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ospf

---

From: Dhruv Dhody <[email-masked]>
Date: Sun, 11 Jan 2015 09:11:36 +0530

Support!

Regards,
Dhruv

---

From: "Wunan (Eric)" <[email-masked]>
Date: Mon, 12 Jan 2015 01:58:18 +0000

Support!

Regards
Eric

-----邮件原件-----
发件人: Acee Lindem (acee) [mailto:[email-masked]] 
发送时间: 2015年1月11日 5:09
收件人: OSPF WG List
主题: [OSPF] OSPF Topology Transparent Zone (TTZ) WG Poll for Adoption as Experimental

Thanks,
Acee and Abhay

---

From: "Anil Kumar S N (VRP Network BL)" <[email-masked]>
Date: Mon, 12 Jan 2015 04:55:49 +0000

Support!

Reagrds
Anil S N

-----Original Message-----
From: OSPF [mailto:[email-masked]] On Behalf Of Wunan (Eric)
Sent: 12 January 2015 07:28
To: Acee Lindem (acee); OSPF WG List
Subject: Re: [OSPF] OSPF Topology Transparent Zone (TTZ) WG Poll for Adoption as Experimental

Support!

Regards
Eric

-----邮件原件-----
发件人: Acee Lindem (acee) [mailto:[email-masked]] 
发送时间: 2015年1月11日 5:09
收件人: OSPF WG List
主题: [OSPF] OSPF Topology Transparent Zone (TTZ) WG Poll for Adoption as Experimental

Thanks,
Acee and Abhay

---

From: Veerendranatha Reddy Vallem <[email-masked]>
Date: Mon, 12 Jan 2015 05:32:04 +0000

Support.

Regards,
Veerendranath

-----Original Message-----
From: OSPF [mailto:[email-masked]] On Behalf Of Wunan (Eric)
Sent: 12 January 2015 09:58
To: Acee Lindem (acee); OSPF WG List
Subject: Re: [OSPF] OSPF Topology Transparent Zone (TTZ) WG Poll for Adoption as Experimental

Support!

Regards
Eric

-----邮件原件-----
发件人: Acee Lindem (acee) [mailto:[email-masked]] 
发送时间: 2015年1月11日 5:09
收件人: OSPF WG List
主题: [OSPF] OSPF Topology Transparent Zone (TTZ) WG Poll for Adoption as Experimental

Thanks,
Acee and Abhay

---

From: Richard Li <[email-masked]>
Date: Tue, 13 Jan 2015 22:30:56 +0000

I support it for adoption as "Experimental" as a co-author.

This draft specifies a method for topology abstraction, virtualization and reduction. An implementation has been completed and shown as running codes in IETF'91 at Hololulu. 

Among others I see a few testable advantages and up-sides:

- It can reduce message amount and topology complexity, and thus reduces the OSPF computation overhead for routers out of the zones. 

- It allows for network re-areaing without service disruption. Sometimes a network needs to be split into multiple smaller areas. Without TTZ, we would see that some interfaces will go down after the old area is removed and then go up after the new area is configured. With TTZ, the routers would not "feel" those changes inside a zone.

- It provides for operational ease for network re-areaing. Splitting a part of network into few smaller areas is very challenging. TTZ will make the job a lot easier.

- It improves network scalability a lot by virtualizing a zone as its edges connected, and can make Create and Maintain E2E Service much easier.

Thanks and regards,

Renwei

-----Original Message-----
From: OSPF [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: Saturday, January 10, 2015 1:09 PM
To: OSPF WG List
Subject: [OSPF] OSPF Topology Transparent Zone (TTZ) WG Poll for Adoption as Experimental

Thanks,
Acee and Abhay

---

From: Aravind Kumar Paramasivam <[email-masked]>
Date: Tue, 13 Jan 2015 16:05:46 -0800

Support !!!

Regards,
Aravind

On Sat, Jan 10, 2015 at 7:07 PM, Huaimo Chen <[email-masked]> wrote:

> I was a member of a team on vendor side for dividing a network with only
> area 0 into a few of areas. The team spent a long time (1+ years) in
> splitting the network into multiple areas in order to have minimum service
> interruptions.
>
> OSPF Topology Transparent Zone (TTZ) provides an easy way to transfer a
> part of network in an area into a zone smoothly without service
> interruptions. In a few simple steps, a part of network is transferred into
> a zone smoothly. The zone also makes the LSDB become smaller. These have
> been demonstrated live.
>
> disagreement as to whether or not these mechanisms will provide significant
> benefit. The answer is definitely topology and deployment dependent. After
> some discussion, we have decided to poll for adoption as an experimental
> draft. Please indicate your support or opposition WG adoption as
> experimental prior to January 24th, 2015.
>

---

From: Dean cheng <[email-masked]>
Date: Wed, 14 Jan 2015 02:00:29 +0000

Support.

Dean

> dependent. After some discussion, we have decided to poll for adoption
> as an experimental draft. Please indicate your support or opposition WG

---

From: William McCall <[email-masked]>
Date: Mon, 19 Jan 2015 22:58:01 -0600

Haven't been there for all of the conversation, but experimental makes
sense. Previous comments were addressed in the new draft. Support.

-- 
William McCall