Subject: Re: [OSPF] ospf passive interface and redistribute ospf

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 21 Apr 2015 16:23:20 +0000

Hi Fredrik,
Note that passive interfaces are a non-standard protocol extension and are not subject to IETF specification. Having said that, you have misunderstood how the passive feature has been implemented by many vendors. The passive interface subnet will be advertised as a local stub network in the Router-LSA corresponding to the area in which they are configured. If you want to advertise these subnets as external routes you should not configure them as passive and should simply redistribute your connected routes.
Hope this helps,
Acee

From: Fredrik Liljegren <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, April 21, 2015 at 9:03 AM
To: OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: [OSPF] ospf passive interface and redistribute ospf

Hi!

I have a scenario where I run two OSPF instances (AS) on the same router, and intend to share some routing information between them. One instance attaches locally connected networks, and one instance facing the external world.

The locally connected networks are included into OSPF as passive networks, and are supposed to be redistributed into the “external” OSPF instance with redistribute OSPF. This does not work, and I can’t find any documentation regarding this use case. Other OSPF networks are redistributed as expected, but the passive networks seems to be considered as connected even though they are included into with the passive feature. Are passive networks to be considered as any other locally connected OSPF network when it comes to redistribute OSPF, or is there some difference in this regards? I thought they would be treated the same, and am trying to convince some designers that it is, but I better make sure first that it actually is the case or did I misunderstand the passive feature?

Thanks and regards
Fredrik

---

From: Fredrik Liljegren <[email-masked]>
Date: Tue, 21 Apr 2015 16:32:10 +0000

Hi!

Thanks for your answer. We thought about redistribute connected as well, but since we currently don’t have access to route maps to filter out the wanted networks (and absolutely not want to expose all internal networks) we thought the way to go would be to include the wanted ones as passive and it would work fine, but apparently not.

Then we will escalate the need for the filter mechanism and go for that solution instead.

Thanks again, much appreciated!

Regards
Fredrik

From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: den 21 april 2015 18:23
To: Fredrik Liljegren; [email-masked]
Subject: Re: [OSPF] ospf passive interface and redistribute ospf

Hi Fredrik,

Hi!

Thanks and regards
Fredrik

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 21 Apr 2015 16:35:07 +0000

Fredrik,

Please work with me, OSPF WG is not necessarily the best place to discuss vendor specific configurations.
Thanks Acee :)

Cheers,
Jeff

From: Fredrik Liljegren <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, April 21, 2015 at 9:32 AM
To: "Acee Lindem (acee)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [OSPF] ospf passive interface and redistribute ospf

Hi!

Regards
Fredrik

From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: den 21 april 2015 18:23
To: Fredrik Liljegren; [email-masked]<mailto:[email-masked]>
Subject: Re: [OSPF] ospf passive interface and redistribute ospf

Hi Fredrik,

Hi!

Thanks and regards
Fredrik