Subject: [OSPF] regarding draft-ppsenak-ospf-te-link-attr-reuse-00

From: "xuling (F)" <[email-masked]>
Date: Wed, 6 Jan 2016 07:28:10 +0000

Hi, all

To make the node that is not TE enabled advertises link attributes for other applications, it is worth considering another choice which has least change to the protocol and implementation. The method is: advertising RI capability TLV in RI LSA when advertising TE LSA. TE capability bit in RI capability TLV can indicate whether link attributes should become part of TE topology.

In draft-ietf-ospf-rfc4970bis,

 ”an OSPF router advertising an OSPF RI LSA MAY include the Router Informational Capability TLV’’ can be enhanced with: an OSPF router advertising an OSPF RI LSA should include Router Informational Capability TLV which can inform TE capability bit.

 In this case, some improvement needs to be done in draft-ietf-ospf-rfc4970bis. These are my personal view.

Best regards,

Ling XU

Hi All,

draft-ppsenak-ospf-te-link-attr-reuse-00 proposes moving and/or copying TLVs from the TE Opaque LSA to the Extended Link Opaque LSA. The draft lists the problems that the draft is trying to solve.  I have reproduced that list of problems below, with each problem followed by what I believe to be a better and simpler solution.

   1.  Whenever the link is advertised in a TE Opaque LSA, the link
       becomes a part of the TE topology, which may not match IP routed
       topology.  By making the link part of the TE topology, remote
       nodes may mistakenly believe that the link is available for MPLS
       TE or GMPLS, when, in fact, MPLS is not enabled on the link.

To address this issue, we simply need to define a new sub-TLV in the TE Link LSA  to say whether MPLS/GMPLS/RSVP is enabled on the link instead of moving the TLVs around into different LSAs.

   2.  The TE Opaque LSA carries link attributes that are not used or
       required by MPLS TE or GMPLS.  There is no mechanism in TE Opaque
       LSA to indicate which of the link attributes should be passed to
       MPLS TE application and which should be used by OSPFv2 and other
       applications.

OSPF database is a container and OSPF can use any of the LSAS for its own use including the TE LSAs.  As far as the TE database goes, it contains data from TE LSAs as well as non-TE LSAs (Network LSA) today so the reasoning described here doesn't make sense.

   3.  Link attributes used for non-TE purposes is partitioned across
       multiple LSAs - the TE Opaque LSA and the Extended Link Opaque
       LSA.  This partitioning will require implementations to lookup
       multiple LSAs to extract link attributes for a single link,
       bringing needless complexity to the OSPFv2 implementations.

There will be nodes in the network which will run older software which send these attributes via TE LSAs so the problem of looking into the TE LSAs for TE related information doesn't get solved with this draft.  Rather it makes it more complicated. With this draft, the multiple LSA lookup will only increase.  An implementation will first have to find if Extended link LSA contains the required info,  if not it will need to look up the info in TE.LSA.

Looking up multiple LSAs for information is an implementation issue and I am sure there will be implementations that will handle this  gracefully so that it doesn't cause
delays in critical paths. It doesn't seem reasonable to come up with protocol extensions to solve implementation issues.

Rgds
Shraddha

________________________________
xuling
华为技术有限公司 Huawei Technologies Co., Ltd.
[Company_logo]

Phone:
Fax:
Mobile:
Email:
地址：深圳市龙岗区坂田华为基地 邮编：518129
Huawei Technologies Co., Ltd.
Bantian, Longgang District,Shenzhen 518129, P.R.China
http://www.huawei.com
________________________________
本邮件及其附件含有华为公司的保密信息，仅限于发送给上面地址中列出的个人或群组。禁
止任何其他人以任何形式使用（包括但不限于全部或部分地泄露、复制、或散发）本邮件中
的信息。如果您错收了本邮件，请您立即电话或邮件通知发件人并删除本邮件！
This e-mail and its attachments contain confidential information from HUAWEI, which
is intended only for the person or entity whose address is listed above. Any use of the
information contained herein in any way (including, but not limited to, total or partial
disclosure, reproduction, or dissemination) by persons other than the intended
recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it!

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 6 Jan 2016 12:51:08 +0000

Hi Ling,

From: OSPF <[email-masked]<mailto:[email-masked]>> on behalf of "xuling (F)" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, January 6, 2016 at 2:28 AM
To: OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: [OSPF] regarding draft-ppsenak-ospf-te-link-attr-reuse-00

Hi, all

The intent of RFC 4970 and the BIS version is that the drafts requiring new capabilities will define them and request IANA allocation as opposed to updating RFC 4970BIS for every new capability.

As for the mechanism, I think this would be rather unwieldy to attempt to get SRLG information from different LSAs. Rather, within the OSPF Routing Domain, I’d choose to advertise SRLGs either in the TE LSAs or the Prefix/Link Attribute LSAs.

Thanks,
Acee

Best regards,

Ling XU

Hi All,

Rgds
Shraddha

Phone:
Fax:
Mobile:
Email:

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 7 Jan 2016 12:16:25 +0000

Hi Ling,

From: OSPF <[email-masked]<mailto:[email-masked]>> on behalf of "xuling (F)" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, January 6, 2016 at 9:52 PM
To: OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: [OSPF] regarding draft-ppsenak-ospf-te-link-attr-reuse-00

Hi Acee,

I suggest to advertise SRLG only in the TE opaque LSA, and advertise TE capability to help understand whether node is TE enabled. If node isn’t TE enabled , SRLG shouldn’t be used for TE application; otherwise, SRLG can be used for TE application or for other application purposes.

I don’t think this is a good idea since it doesn’t solve of the problem of consolidating non-TE information in the OSPF prefix/link attribute LSA and avoiding having to advertise and process three independent LSAs. Also, if you are going to require a protocol change anyway, you might as well use the OSPF prefix/link LSAs.

Thanks,
Acee

the mechanism to advertise TE capability has been well defined in draft-ietf-ospf-rfc4970bis.

Best regards,
Ling

Hi Ling,

From: OSPF <[email-masked]<mailto:[email-masked]<mailto:[email-masked]%3cmailto:[email-masked]>>> on behalf of "xuling (F)" <[email-masked]<mailto:[email-masked]<mailto:[email-masked]%3cmailto:[email-masked]>>>

To: OSPF WG List <[email-masked]<mailto:[email-masked]<mailto:[email-masked]%3cmailto:[email-masked]>>>

Hi, all

?an OSPF router advertising an OSPF RI LSA MAY include the Router Informational Capability TLV?? can be enhanced with: an OSPF router advertising an OSPF RI LSA should include Router Informational Capability TLV which can inform TE capability bit.

As for the mechanism, I think this would be rather unwieldy to attempt to get SRLG information from different LSAs. Rather, within the OSPF Routing Domain, I?d choose to advertise SRLGs either in the TE LSAs or the Prefix/Link Attribute LSAs.

Thanks,

Acee

Best regards,

Ling XU

Phone:
Fax:
Mobile:
Email: