Subject: [OSPF] Increasing the maximum number of links advertisable in a single Router LSA

From: Vlad Olariu <[email-masked]>
Date: Mon, 4 Apr 2016 14:27:21 +0200

Hello All,

Considering what the OSPFv2 RFC states:

A.4.2 All of the router's links to the area must be described in a single
> router-LSA.

The maximum number of links advertisable in a single Router-LSA for a
single LSA is around 5K.

Following this, I have two questions:
> How come the* # links* has 2 bytes, allowing for up to 65536 links?
> Is there any way to bypass the 5K limit?

Thank you.

P.S This is of course just an exercise. I don't expect any sane network
design to require that many links in the same area.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 4 Apr 2016 13:55:52 +0000

Hi Vlad,

From: OSPF <[email-masked]<mailto:[email-masked]>> on behalf of Vlad Olariu <[email-masked]<mailto:[email-masked]>>
Date: Monday, April 4, 2016 at 8:27 AM
To: OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: [OSPF] Increasing the maximum number of links advertisable in a single Router LSA

Hello All,

A.4.2 All of the router's links to the area must be described in a single router-LSA.

The maximum number of links advertisable in a single Router-LSA for a single LSA is around 5K.

Following this, I have two questions:
> How come the # links has 2 bytes, allowing for up to 65536 links?

No - this was fixed in OSPFv3 by supporting a variable number of Router-LSAs which are concatenated. This is yet another advantage of OSPFv3 over OSPFv2.

This has not been a problem heretofore and I know of several implementations that have lower Router-LSA link limits due to not supporting IP frag/reassembly up to 64K.

Thanks,
Acee

Thank you.

P.S This is of course just an exercise. I don't expect any sane network design to require that many links in the same area.