Subject: [OSPF] [Technical Errata Reported] RFC6987 (4685)

From: RFC Errata System <[email-masked]>
Date: Thu, 5 May 2016 17:17:11 -0700 (PDT)

The following errata report has been submitted for RFC6987,
"OSPF Stub Router Advertisement".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6987&eid=4685

--------------------------------------
Type: Technical
Reported by: Alexander Okonnikov <[email-masked]>

Section: 4

Original Text
-------------

Corrected Text
--------------
(At the end of the section)

If the stub router is located in transit area, crossed by virtual
link(s), latter will become inoperational in case the stub router is
on path between two virtual link endpoints - either due to only path
in transit area or due to topology changes which move stub router onto
this path. 

Notes
-----
Virtual links become inoperational in case path metric between two endpoints is > 0xffff. Path metric of two or more links, one of which has MaxLinkMetric, will inevitably exceed value 0xffff.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6987 (draft-ietf-ospf-rfc3137bis-04)
--------------------------------------
Title               : OSPF Stub Router Advertisement
Publication Date    : September 2013
Author(s)           : A. Retana, L. Nguyen, A. Zinin, R. White, D. McPherson
Category            : INFORMATIONAL
Source              : Open Shortest Path First IGP
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 6 May 2016 01:40:19 +0000

The text below is technically correct (other than the grammar). However,
I’d view it more as additional information than an actual errata.

Thanks,
Acee

On 5/5/16, 8:17 PM, "RFC Errata System" <[email-masked]> wrote:

>Virtual links become inoperational in case path metric between two
>endpoints is > 0xffff. Path metric of two or more links, one of which has
>MaxLinkMetric, will inevitably exceed value 0xffff.
>
>Instructions:
>-------------

---

From: Alexander Okonnikov <[email-masked]>
Date: Fri, 6 May 2016 04:48:10 +0300

Hello Acee,

Yes, it is addition, but I have no idea about another way how to add this clarification rather than via errata tool.

Thank you.

6 мая 2016 г., 4:40 +0300, Acee Lindem (acee)<[email-masked]>, писал:
> On 5/5/16, 8:17 PM, "RFC Errata System"<[email-masked]>wrote:
>  
> > Reported by: Alexander Okonnikov<[email-masked]
> >  
> > Section: 4
> >  
> > Original Text
> > -------------
> >  
> >  
> > Corrected Text
> > --------------
> > endpoints is>0xffff. Path metric of two or more links, one of which has

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sat, 7 May 2016 11:44:19 +0000

Hi Alex,

I don’t really agree with the precedent of going back and improving existing documents through errata. My view of errata is that it is meant to correct things that  are wrong rather than add improvements and clarifications. However, I’ll leave the decision to the ADs.

Note that we currently have several documents in the WG last call or “Publication Requested” state and it would be great if you’d focus your efforts there.

https://datatracker.ietf.org/doc/draft-ietf-ospf-two-part-metric/
https://datatracker.ietf.org/doc/draft-ietf-ospf-transition-to-ospfv3/
https://datatracker.ietf.org/doc/draft-ietf-ospf-segment-routing-extensions/
https://datatracker.ietf.org/doc/draft-ietf-ospf-ttz/

Thanks,
Acee

From: Alexander Okonnikov <[email-masked]<mailto:[email-masked]>>
Date: Thursday, May 5, 2016 at 9:48 PM
To: RFC Errata System <[email-masked]<mailto:[email-masked]>>, "Alvaro Retana (aretana)" <[email-masked]<mailto:[email-masked]>>, "Liem Nguyen (lhnguyen)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Alia Atlas <[email-masked]<mailto:[email-masked]>>, Deborah Brungard <[email-masked]<mailto:[email-masked]>>, "Abhay Roy (akr)" <[email-masked]<mailto:[email-masked]>>, Acee Lindem <[email-masked]<mailto:[email-masked]>>
Cc: OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Technical Errata Reported] RFC6987 (4685)

Hello Acee,

Thank you.

6 мая 2016 г., 4:40 +0300, Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>>, писал:
The text below is technically correct (other than the grammar). However,
I’d view it more as additional information than an actual errata.

Thanks,
Acee

On 5/5/16, 8:17 PM, "RFC Errata System" <[email-masked]<mailto:[email-masked]>> wrote:

--------------------------------------
Type: Technical
Reported by: Alexander Okonnikov <[email-masked]<mailto:[email-masked]>

Section: 4

Original Text
-------------

Corrected Text
--------------

Notes
-----

Instructions:
-------------

Author(s) : A. Retana, L. Nguyen, A. Zinin, R. White, D.
McPherson