Subject: [OSPF] AD review of draft-ietf-ospf-transition-to-ospfv3-07

From: Alia Atlas <[email-masked]>
Date: Thu, 9 Jun 2016 15:57:57 -0400

As is customary, I have done my AD review
of draft-ietf-ospf-transition-to-ospfv3-07.
First, I would like to thank the authors for their work on this document.
It looks like
very useful technology.

I have a few minor questions below.  I will put this into IETF Last Call as
well while
waiting for the authors to update the draft ASAP.   That gives a chance of
making it
on to the June 30 telechat if the authors are responsive.

Minor:

1) Sec 3.1:  "If this is supported, the IPv4 data plane MUST resolve
     the layer-2 address using Address Resolution Protocol (ARP) on
     multi-access networks and point-to-point over LAN [RFC5309] for
     direct next-hops on different IPv4 subnets."

     I believe it is the IPv4 (i.e. layer-3) address to be resolved with
ARP - not the
     layer-2 address.

2) Sec 3.3: "If IPv4 transport, as specified herein, is used for IPv6
address
     families, virtual links cannot be
     supported. Hence, it is RECOMMENDED to use the IP transport
     matching the address family in OSPF routing domains requiring
     virtual links."

     From this section, I was expecting that "cannot" would be a "can".  Did
     I miss something?  Can you clarify further?

3) Sec 1: 2nd to last paragraph: "In situations where the IPv6 deployment
is a
   proper superset of the IPv4 deployment, it is expected that OSPFv3
   would be transported over IPv6."

   I believe the "proper" should be removed.   If the IPv6 deployment is
exactly the same
   as the IPv4 deployment, then it is expected that OSPFv3 would be
transported over
   IPv6.     As it is,how the case of equal deployment is handled is
unspecified.

Thanks,
Alia

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 9 Jun 2016 22:42:30 +0000

Hi Alia,

Thanks for the review - you caught some rather subtle points.

From: OSPF <[email-masked]<mailto:[email-masked]>> on behalf of Alia Atlas <[email-masked]<mailto:[email-masked]>>
Date: Thursday, June 9, 2016 at 3:57 PM
To: OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: [OSPF] AD review of draft-ietf-ospf-transition-to-ospfv3-07

As is customary, I have done my AD review of draft-ietf-ospf-transition-to-ospfv3-07.
First, I would like to thank the authors for their work on this document.  It looks like
very useful technology.

I have a few minor questions below.  I will put this into IETF Last Call as well while
waiting for the authors to update the draft ASAP.   That gives a chance of making it
on to the June 30 telechat if the authors are responsive.

Minor:

     I believe it is the IPv4 (i.e. layer-3) address to be resolved with ARP - not the
     layer-2 address.

Ok - this text comes from me and I was viewing resolution from the standpoint of the “to” address family rather than the “from” address family. I agree the “from” address family is probably a more common characterization.

2) Sec 3.3: "If IPv4 transport, as specified herein, is used for IPv6 address
     families, virtual links cannot be
     supported. Hence, it is RECOMMENDED to use the IP transport
     matching the address family in OSPF routing domains requiring
     virtual links."

The draft doesn’t address virtual link support in deployments where the address-family doesn’t match the transport. Hence, the text is correct as written.

3) Sec 1: 2nd to last paragraph: "In situations where the IPv6 deployment is a
   proper superset of the IPv4 deployment, it is expected that OSPFv3
   would be transported over IPv6."

   I believe the "proper" should be removed.   If the IPv6 deployment is exactly the same
   as the IPv4 deployment, then it is expected that OSPFv3 would be transported over
   IPv6.     As it is,how the case of equal deployment is handled is unspecified.

I agree. We will remove “proper".

Thanks,
Acee

Thanks,
Alia

---

From: Alia Atlas <[email-masked]>
Date: Thu, 9 Jun 2016 18:59:22 -0400

Hi Acee,

> Thanks for the review - you caught some rather subtle points.

thanks - this was a nice tractable draft to read in a short time.

> From: OSPF <[email-masked]> on behalf of Alia Atlas <
> [email-masked]>
> To: OSPF WG List <[email-masked]>
> Ok - this text comes from me and I was viewing resolution from the
> standpoint of the “to” address family rather than the “from” address
> family. I agree the “from” address family is probably a more common
> characterization.
>

Feel free to say "MUST resolve from the IPv4 address to the layer-2 address
using ARP...." if you
want extreme clearness.

> The draft doesn’t address virtual link support in deployments where the
> address-family doesn’t match the transport. Hence, the text is correct as
> written.
>

Ok - but the draft  just says
"Hence, it is RECOMMENDED to use the IP transport
     matching the address family in OSPF routing domains requiring
     virtual links."

Can you clean this up to be extremely clear?
With an IPv4 transport, IPv6 virtual links are not supported.
With an IPv4 transport, IPv4 virtual links are supported.

and vice versa.

I read the relaxation as applying to both IPv4 and IPv6; maybe I was
reading too fast, but a few clarifying
words would probably help.

> I agree. We will remove “proper".

thanks,
Alia

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 9 Jun 2016 23:01:47 +0000

Hi Alia,
I agree with your suggestions - we will make update the draft before the tele chat.
Thanks,
Acee

From: Alia Atlas <[email-masked]<mailto:[email-masked]>>
Date: Thursday, June 9, 2016 at 6:59 PM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>
Cc: OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: Re: [OSPF] AD review of draft-ietf-ospf-transition-to-ospfv3-07

Hi Acee,

On Thu, Jun 9, 2016 at 6:42 PM, Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Alia,

Minor:

Feel free to say "MUST resolve from the IPv4 address to the layer-2 address using ARP...." if you
want extreme clearness.

and vice versa.

I read the relaxation as applying to both IPv4 and IPv6; maybe I was reading too fast, but a few clarifying
words would probably help.

thanks,
Alia

Thanks,
Acee

Thanks,
Alia