Subject: Re: [OSPF] [IANA #1047782] Protocol Action: 'OSPFv3 LSA Extendibility' to Proposed Standard (draft-ietf-ospf-ospfv3-lsa-extend-23.txt)

From: Peter Psenak <[email-masked]>
Date: Thu, 01 Feb 2018 10:02:56 +0100

Hi Acee,

as a next step, can you please ask for a early IANA allocation from the 
new registries as specified in section 8 of 
draft-ietf-ospf-ospfv3-segment-routing-extensions-11.txt

thanks,
Peter

On 01/02/18 00:04 , Acee Lindem (acee) wrote:
> Hi Amanda,
>
> This is correct.
>
> Thanks
> Acee
>
> On 1/31/18, 5:12 PM, "Amanda Baber via RT" <[email-masked]> wrote:
>
>      Hi Acee,
>
>      I apologize for my oversight. There's no problem with placing the registrations in Section 2.
>
>      Can you confirm that this action has been completed correctly?
>
>      ACTION 4
>
>      We've registered the following OSPFv3 LSA Function Codes:
>
>      33	E-Router-LSA	[RFC-ietf-ospf-ospfv3-lsa-extend-23]
>      34	E-Network-LSA	[RFC-ietf-ospf-ospfv3-lsa-extend-23]
>      35	E-Inter-Area-Prefix-LSA	[RFC-ietf-ospf-ospfv3-lsa-extend-23]
>      36	E-Inter-Area-Router-LSA	[RFC-ietf-ospf-ospfv3-lsa-extend-23]
>      37	E-AS-External-LSA	[RFC-ietf-ospf-ospfv3-lsa-extend-23]
>      38	Unused (Not to be allocated)	[RFC-ietf-ospf-ospfv3-lsa-extend-23]
>      39	E-Type-7-LSA	[RFC-ietf-ospf-ospfv3-lsa-extend-23]
>      40	E-Link-LSA	[RFC-ietf-ospf-ospfv3-lsa-extend-23]
>      41	E-Intra-Area-Prefix-LSA	[RFC-ietf-ospf-ospfv3-lsa-extend-23]
>
>      Please see
>      https://www.iana.org/assignments/ospfv3-parameters
>
>      thanks,
>      Amanda
>
>
>      On Wed Jan 31 19:29:16 2018, [email-masked] wrote:
>      > Hi Amanda,
>      >
>      > The actions below are correct. However, the one (the first) IANA
>      > action from the draft is missing:
>      >
>      > This specification defines nine OSPFv3 Extended LSA types as
>      > described in Section 2.  These are added the existing OSPFv3 LSA
>      > Function Codes registry.
>      >
>      > I guess I should have repeated these in the IANA Considerations
>      > section.
>      >
>      >
>      > LSA function code   LS Type   Description
>      > ----------------------------------------------------
>      > 33                  0xA021    E-Router-LSA
>      > 34                  0xA022    E-Network-LSA
>      > 35                  0xA023    E-Inter-Area-Prefix-LSA
>      > 36                  0xA024    E-Inter-Area-Router-LSA
>      > 37                  0xC025    E-AS-External-LSA
>      > 38                  N/A       Unused (Not to be allocated)
>      > 39                  0xA027    E-Type-7-LSA
>      > 40                  0x8028    E-Link-LSA
>      > 41                  0xA029    E-Intra-Area-Prefix-LSA
>      >
>      >
>      > OSPFv3 Extended LSA Types
>      >
>      > Thanks,
>      >  Acee
>      >
>      >
>      >
>      >
>      > On 1/31/18, 2:17 PM, "Amanda Baber via RT" <[email-masked]>
>      > wrote:
>      >
>      > Dear Authors:
>      >
>      > ATTENTION: A RESPONSE TO THIS MESSAGE IS NEEDED
>      >
>      > We've completed the registry actions for the following RFC-to-be:
>      >
>      > draft-ietf-ospf-ospfv3-lsa-extend-23
>      >
>      > ACTION 1:
>      >
>      > We've added the following entry to the OSPFv3 Prefix Options (8 bits)
>      > registry:
>      >
>      > 0x20        N-bit   [RFC-ietf-ospf-ospfv3-lsa-extend-23]
>      >
>      > Please see
>      > https://www.iana.org/assignments/ospfv3-parameters
>      >
>      >
>      > ACTION 2:
>      >
>      > We've created the following registry:
>      >
>      > OSPFv3 Extended-LSA TLVs
>      > Reference: [RFC-ietf-ospf-ospfv3-lsa-extend-23]
>      >
>      > Range       Registration Procedures
>      > 9-32767     IETF Review or IESG Approval
>      > 33024-45055 First Come First Served
>      >
>      > Value       Description     Reference
>      > 0   Reserved        [RFC-ietf-ospf-ospfv3-lsa-extend-23]
>      > 1   Router-Link TLV [RFC-ietf-ospf-ospfv3-lsa-extend-23]
>      > 2   Attached-Routers TLV    [RFC-ietf-ospf-ospfv3-lsa-extend-23]
>      > 3   Inter-Area Prefix TLV   [RFC-ietf-ospf-ospfv3-lsa-extend-23]
>      > 4   Inter-Area Router TLV   [RFC-ietf-ospf-ospfv3-lsa-extend-23]
>      > 5   External Prefix TLV     [RFC-ietf-ospf-ospfv3-lsa-extend-23]
>      > 6   Intra-Area Prefix TLV   [RFC-ietf-ospf-ospfv3-lsa-extend-23]
>      > 7   IPv6 Link-Local Address TLV     [RFC-ietf-ospf-ospfv3-lsa-extend-
>      > 23]
>      > 8   IPv4 Link-Local Address TLV     [RFC-ietf-ospf-ospfv3-lsa-extend-
>      > 23]
>      >      9-32767     Unassigned
>      > 32768-33023 Reserved for Experimental Use   [RFC-ietf-ospf-ospfv3-lsa-
>      > extend-23]
>      >      33024-45055 Unassigned
>      > 45056-65535 Reserved        [RFC-ietf-ospf-ospfv3-lsa-extend-23]
>      >
>      > Please see
>      > https://www.iana.org/assignments/ospfv3-parameters
>      >
>      >
>      > ACTION 3:
>      >
>      > We've created the following registry:
>      >
>      > OSPFv3 Extended-LSA sub-TLVs
>      > Reference: [RFC-ietf-ospf-ospfv3-lsa-extend-23]
>      >
>      > Range       Registration Procedures
>      > 4-32767     IETF Review or IESG Approval
>      > 33024-45055 First Come First Served
>      >
>      > Value       Description     Reference
>      > 0   Reserved        [RFC-ietf-ospf-ospfv3-lsa-extend-23]
>      > 1   IPv6 Forwarding Address sub-TLV  [RFC-ietf-ospf-ospfv3-lsa-extend-
>      > 23]
>      > 2   IPv4 Forwarding Address sub-TLV  [RFC-ietf-ospf-ospfv3-lsa-extend-
>      > 23]
>      > 3   Route Tag sub-TLV       [RFC-ietf-ospf-ospfv3-lsa-extend-23]
>      >      4-32767     Unassigned
>      > 32768-33023 Reserved for Experimental Use   [RFC-ietf-ospf-ospfv3-lsa-
>      > extend-23]
>      >      33024-45055 Unassigned
>      > 45056-65535 Reserved        [RFC-ietf-ospf-ospfv3-lsa-extend-23]
>      >
>      > Please see
>      > https://www.iana.org/assignments/ospfv3-parameters
>      >
>      >
>      > Please let us know whether this document's registry actions have been
>      > completed correctly. Once we receive your confirmation, we'll notify
>      > the RFC Editor that the actions are complete. If a team of authors is
>      > responsible for the document, and the actions have been performed
>      > correctly, please send a single confirmation message.
>      >
>      > We'll update any references to this document in the registries when
>      > the RFC Editor notifies us that they've assigned an RFC number.
>      >
>      > Best regards,
>      >
>      > Amanda Baber
>      > Lead IANA Services Specialist
>      >
>      >
>      >
>
>
>
>
>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 1 Feb 2018 10:48:40 +0000

Hi Peter, 

Good point, we have OSPFv3 SR implementations and don't want the code points used. 

Thanks
Acee

On 2/1/18, 4:02 AM, "Peter Psenak (ppsenak)" <[email-masked]> wrote:

    Hi Acee,

    thanks,
    Peter

---

From: Dirk Goethals <[email-masked]>
Date: Thu, 1 Feb 2018 13:07:33 +0100

indeed.

Thx,

Dirk

Op 1/02/2018 om 11:48 schreef Acee
Lindem (acee):

Hi Peter,

Thanks
Acee

Hi Acee,

thanks,
Peter