Subject: [OSPF] Experimental support of OSPFv2 Segment Routing in Free Range Routing

From: Olivier Dugeon <[email-masked]>
Date: Tue, 6 Feb 2018 21:12:57 +0100

Hi all,

We are please to announce that we have added Experimental support of OSPF SR
(draft-ietf-ospf-segment-routing-extensions-24) in Free Range Routing
protocol suite https://frrouting.org

This feature is available on the master branch: 
https://github.com/FRRouting/frr
and will be part of the future 4.0 release.

Supported Features:

* Automatic computation of Primary and Backup Adjacency SID with
Cisco experimental remote IP address
* SRGB configuration
* Prefix configuration for Node SID with optional NO-PHP flag (Linux
kernel support both mode)
* Node MSD configuration (with Linux Kernel >= 4.10 a maximum of 32 labels
could be stack)
* Automatic provisioning of MPLS table
* Static route configuration with label stack up to 32 labels

Interoperability:
* tested on various topology including point-to-point and LAN interfaces
in a mix of Free Range Routing instance and Cisco IOS-XR 6.0.x
* check OSPF LSA conformity with latest wireshark release 2.5.0-rc

Known limitations

* Runs only within default VRF
* Only single Area is supported. ABR is not yet supported
* Only SPF algorithm is supported
* Extended Prefix Range is not supported
* MPLS table are not flush at startup. Thus, restarting zebra process is
   mandatory to remove old MPLS entries in the data plane after a crash of
   ospfd daemon
* With NO Penultimate Hop Popping, it is not possible to express a Segment
   Path with an Adjacency SID due to the impossibility for the Linux 
Kernel to
   perform double POP instruction.

For details implementation & instructions on how to use this new feature,
please consult doc/OSPF-SR.rst.

Regards

FRR team

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 7 Feb 2018 14:43:19 +0000

Hi Olivier,

Great news Olivier! I’m hoping you are looking at OSPFv3 Extended LSAs and OSPFv3 SR as well.

Thanks,
Acee

From: OSPF <[email-masked]> on behalf of Olivier Dugeon <[email-masked]>
Date: Tuesday, February 6, 2018 at 3:13 PM
To: SPRING WG List <[email-masked]>, OSPF WG List <[email-masked]>
Subject: [OSPF] Experimental support of OSPFv2 Segment Routing in Free Range Routing

Hi all,

This feature is available on the master branch: https://github.com/FRRouting/frr
and will be part of the future 4.0 release.

Supported Features:

Interoperability:

Known limitations

  Path with an Adjacency SID due to the impossibility for the Linux Kernel to

Regards

FRR team

---

From: Olivier Dugeon <[email-masked]>
Date: Wed, 7 Feb 2018 18:03:18 +0100

Hi Acee,

Unfortunately not. The next step from our side will be SR for IS-IS and 
PCC supporting SR.

Concerning OSPFv3, I have no particular knowledge of the current 
implementation in FRRouting. I think it is far from OSPFv2, so, there is 
certainly a huge base work to be coded before adding Extended LSAs and 
Router Information.

Regards

Olivier

Le 07/02/2018 à 15:43, Acee Lindem (acee) a écrit :
> *From: *OSPF <[email-masked]> on behalf of Olivier Dugeon 
> <[email-masked]>
> *Date: *Tuesday, February 6, 2018 at 3:13 PM
> *To: *SPRING WG List <[email-masked]>, OSPF WG List <[email-masked]>
> *Subject: *[OSPF] Experimental support of OSPFv2 Segment Routing in 
> Free Range Routing
>
> Hi all,
>

-- 
logo Orange <http://www.orange.com>

Olivier Dugeon
Senior research engineer in QoS and network control
Open Source Referent
Orange/IMT/OLN/WTC/IEE/OPEN

fixe : +33 2 96 07 28 80
mobile : +33 6 82 90 37 85
[email-masked] <mailto:[email-masked]>