Subject: Re: [P2PSIP] Update of reload base draft

From: "Michael Chen" <[email-masked]>
Date: Mon, 23 Jan 2012 22:04:47 -0700

Cullen,

Back in September and October of last year, I posted 6 questions and
suggested corrections to base-19, but all of them went on unanswered. I
also don't see them being addressed by base-20. These are their subject
lines:

[P2PSIP] Base draft section 6.4.3.2 Stat Response Definition
clarification, Michael Chen
[P2PSIP] Question about base draft section 9.7.4.2, Michael Chen
[P2PSIP] Base section 10.4 clarification, Michael Chen

[P2PSIP] Base draft 9.5 bullet 2 needs to be revised, Michael Chen
[P2PSIP] Question about base draft 9.7.4.4 Detecting partitioning,
Michael Chen
[P2PSIP] Base draft 9.7.4.1 title does not match its content, Michael
Chen

Would any of the key members revisit and reply them?

Thanks

--Michael

> -------- Original Message --------
> Subject: [P2PSIP] Update of reload base draft
> From: Cullen Jennings <[email-masked]>
> Date: Tue, January 17, 2012 6:43 pm
> To: P2PSIP Mailing List <[email-masked]>
> 
> 
> We believe this revision addresses the following DISCUSS comments:
> 
> Jari Arkko
> Adrian Farrel
> Robert Sparks
> Peter Saint-Andre
> Dan Romascanu
> Russ Housley
> 
> Note: we did not address non-DISCUSS comments. We are planning to
> do that on a subsequent pass.
> 
> Most of the changes are editorial/clarifying, however, a number
> were substantive (though generally not breaking). Here's a summary
> of what we believe the major ones are:
> 
> * Changed the certificate enrollment protocol to remove the
>  password from the URL. Note that this is a breaking change.
> 
> * Globally renamed "private id" and "compressed id" to "opaque id"
> 
> * Specified the details of the overlay name (S 5.3.2)
> 
> * Nailed down the fragment semantics, harmonizing between the fragment
>  field defn. and the rules for generating fragments.  The high bit must
>  always be set and unfragmented packets are represented as the last
>  fragment with an offset of 0.
> 
> * Specified new requirements for malicious loop prevention:
> 
>  - Configuration servers are supposed to set TTL based on
>    overlay size.
>  - Peers must check that TTL never exceeds the configured
>    maximum.
>  - Peers should check for duplicates in the destination
>    list.
> 
> * Added a new Error_Invalid_Message generic error code.
> 
> In terms of schedule, we plan to spin a new draft before the draft
> deadline that addresses all the DISCUSS comments and as many
> of the comments as possible.
> 
> Ekr, Bruce, & Cullen
> 
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 24 Jan 2012 06:00:31 -0800

20 only addressed some discusses from some of the IESG and not even all of theses. It did not deal with comments from IESG or other comments from the list so we did not get those in but I imagine they are still on the queue to go look at but thank you for grabbing the subjects.