Subject: [P2PSIP] Themes in Communication Architectures

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 1 Jun 2012 10:45:33 +0300

Hi all, 

this week I spoke at an academic conference and provided the researchers with my guidelines on how they can make their research work less successful. 
People liked it and they are already following some of my guidelines. Great so far. 

At the end I got a question that I couldn't provide an answer for and I am sure you guys have thought about this already quite a bit. 

The computer science industry seems to be following trends (or themes) regarding communication architectures. A few years ago (maybe 5 - 7) everyone wanted to design protocols that follow a peer-to-peer paradigm. This working group and others in the IETF are a result of the excitement at that time. 

For some reason, however, the theme changed and we are now more in a client-to-server thinking (which is what I would call most of the cloud computing concepts). It may change again.

So, the question for you who had worked such a long time on this p2p paradigm: What are the reasons for the shift? 

My guess is that it is a combination of technical difficulties to get the p2p communication systems to work and the attractiveness of the business model for collecting everything on the server-side, i.e. the service provider is much more in control of what is going on (call this a customer binding) and can track the user's service usage. 

Ciao
Hannes

---

From: Jaime Jimenez <[email-masked]>
Date: Fri, 1 Jun 2012 13:39:28 +0300

Hi Hannes,

If you mean why some parts of the industry are moving from to CS than P2P. Leaving technical difficulties aside, which I agree are one of the reasons, IMO everything boils down to cheap bandwidth and cheap storage. Those two things greatly favor client-server type of systems.

It is also true that companies like to collect as much info as possible, but they could do that while still leaving processing/storage on the client side. At this rate my OS is going to exist just to support the browser, we will be back to mainframe computing :D

Ciao!
-- Jaime

On Jun 1, 2012, at 10:45 AM, Hannes Tschofenig wrote:

> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 15 Jun 2012 17:18:09 -0600

It's more about the business models that will fly at a given time. 

But on the technology front, note that as lots of traffic moved from really fast notebook computers to sort of slow mobile phones, the relative ratio of client to server power has shifted from where it was 5 years ago. No doubt it will shift again. That said, there is still far more going on with P2P today than there was 5 years ago - it's just less interesting to talk about than say SDN.