Subject: Re: [P2PSIP] [reload-implementers] Is there any protype or simple implementation about the RELOAD?

From: Marc Petit-Huguenin <[email-masked]>
Date: Sat, 16 Jun 2012 08:37:44 -0700

On 06/13/2012 01:12 AM, fangh01 wrote:
> Hello, I'm interested in the RELOAD protocol, and I plan to implement a
> live streaming system based on p2psip which use the RELOAD protocol.
> However, after search the internet, I couldn't find any RELOAD related
> implementation to reference, is there any protype or simple implementation
> on RELOAD protocol offered on the internet?

Look in the archives for the "Implementation listing" thread:

http://implementers.org/archives/reload/2011-October/date.html

> Another question is that can anyone show the standard RELOAD packets with
> the ".pcap" format?

I uploaded a pcap file and its associated RSA key here:

http://ietf.implementers.org/reload/storage.pcap.gz
http://ietf.implementers.org/reload/bootstrap.p12

You need to install the p12 in Wireshark first (password: password).
Note that for some reason Wireshark 1.6.8 does not decrypt the packets.  It
works fine with Wireshark 1.7 (I always use the HEAD of the git tree, so YMMV).

Note that this is not an endorsement of the practice of implementing protocols
based on examples.

- -- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org
Profile: http://www.linkedin.com/in/petithug

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Thu, 28 Jun 2012 09:15:00 -0700

On 06/16/2012 08:37 AM, Marc Petit-Huguenin wrote:
>> implementation to reference, is there any protype or simple
>> implementation on RELOAD protocol offered on the internet?
> 
>> Another question is that can anyone show the standard RELOAD packets
>> with the ".pcap" format?
> 
> You need to install the p12 in Wireshark first (password: password). Note
> that for some reason Wireshark 1.6.8 does not decrypt the packets.  It 

I just verified that the new stable release of Wireshark (1.8.0) decrypts
correctly the RELOAD packets.

- -- 
Marc Petit-Huguenin