Subject: [paws] Suggested language change for the charter

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 14 Apr 2011 12:11:45 -0400

In the review by IESG/IAB some issues came up that are basically interactions between security, privacy and regulatory imperatives.   The suggested change to the security text is:
  "The protocol must protect both the channel enablement process and
   the privacy of users, and prevent unauthorized disclosure of a
   user's location. In some circumstances robust security
   mechanisms may be required to be used to prevent device identity
   spoofing, modification of device requests, modification of channel
   enablement information and impersonation of registered database
   services. Such requirements are expected to be the subject of
   various regulations in various countries so the WG must balance
   the need to adhere to regulation with the desire for Internet
   services to be the same regardless of location."

Would everyone be okay with this change?

Brian

---

From: Rex Buddenberg <[email-masked]>
Date: Thu, 14 Apr 2011 10:35:25 -0700

Brian,

I think you have the priorities reversed.

Authenticity of the data is always and universal.  There will be no
cases where authenticity is not a requirement in PAWS.  

Confidentiality is a requirement but it's not universal.

On Thu, 2011-04-14 at 12:11 -0400, Rosen, Brian wrote:
> _______________________________________________
> paws mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/paws

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 14 Apr 2011 13:46:02 -0400

So you are worried that by lumping all of the mechanisms under "may be required" we short shrift some mechanisms that we believe will always be required?

Could you suggest a wording change that achieves that?

The text suggestion arises because lots of privacy sensitive data is required to be provided by some (i.e. U.S.) regulators, but may not be required by all.  So some mechanisms may be optional to deploy.

Brian

---

From: <[email-masked]>
Date: Thu, 14 Apr 2011 17:51:31 +0000

Just one suggested change:

S/Such requirements are expected to be the subject of
   various regulations in various countries so the WG must balance
   the need to adhere to regulation with the desire for Internet
   services to be the same regardless of location./Such security
requirements
   may be in the scope of regulations which could vary between countries.
The WG
   MUST consider these security aspects in the design of the protocol with
sufficient
   flexibility to meet the needs of differing regulations/deployments.

Otherwise looks fine.

-Raj

On 4/14/11 11:11 AM, "ext Rosen, Brian" <[email-masked]> wrote:

>In the review by IESG/IAB some issues came up that are basically
>interactions between security, privacy and regulatory imperatives.   The
>suggested change to the security text is:

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 14 Apr 2011 19:54:58 +0200

Hi, 

In the IESG telechat today we decided to leave the text as it is for the
time being and send the current charter text to external IETF review.
The discussion can continue as part of the external review. 

Regards,

Dan 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Rosen, Brian
> Sent: Thursday, April 14, 2011 8:46 PM
> To: Rex Buddenberg
> Cc: [email-masked]
> Subject: Re: [paws] Suggested language change for the charter
> 
> So you are worried that by lumping all of the mechanisms 
> under "may be required" we short shrift some mechanisms that 
> we believe will always be required?
> 
> The text suggestion arises because lots of privacy sensitive 
> data is required to be provided by some (i.e. U.S.) 
> regulators, but may not be required by all.  So some 
> mechanisms may be optional to deploy.
> 
> Brian
> 
> 
> >> In the review by IESG/IAB some issues came up that are 
> basically interactions between security, privacy and 
> regulatory imperatives.   The suggested change to the 
> security text is:

---

From: Rex Buddenberg <[email-masked]>
Date: Thu, 14 Apr 2011 11:04:34 -0700

On Thu, 2011-04-14 at 13:46 -0400, Rosen, Brian wrote:
> So you are worried that by lumping all of the mechanisms under "may be
> required" we short shrift some mechanisms that we believe will always
> be required?

Brian, may be an allergic reaction on my part -- too many times I've
seen attention to confidentiality but not authenticity.  I hope this
audience all knows that the way public key works, confidentiality does
not confer authenticity.  But the PKI necessary to hold up digital
signature also holds up confidentiality.  

> Could you suggest a wording change that achieves that?

I'll try a couple notes below
> 
> The text suggestion arises because lots of privacy sensitive data is
> required to be provided by some (i.e. U.S.) regulators, but may not be
> required by all.   
	For the confidentiality subject, I agree with you.

>  So some mechanisms may be optional to deploy.
	Again, for confidentiality, agree.  But show me a situation where
authenticity is not a valid requirement?
> >>   user's location.

s/ The protocol must authenticate data between users and the channel
enablement process to preclude bogus or spoofed data.

>  In some circumstances 

the protocol must protect privacy of uses (one aspect of which would be
unauthorized disclosure of that user's location).  

> robust security
> >>   services. 

This is all authenticity so can be used to modify that part.

> Such requirements are expected to be the subject of

---

From: Paul Lambert <[email-masked]>
Date: Thu, 14 Apr 2011 16:44:53 -0700

Minor comments:

1) "... In some circumstances robust security mechanisms may be.."  
    Is redundantly wishy-washy. I'd suggest "will" instead of  "may"
2) "... various regulations in various countries ..."
          Reads poorly  - suggest:
   " The security requirements are the subject of regulations that vary
     between countries so the WG must balance
     the need to adhere to regulation with the desire for Internet
     services to be the same regardless of location."
   
Paul

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Rosen, Brian
> Sent: Thursday, April 14, 2011 9:12 AM
> To: [email-masked]
> Subject: [paws] Suggested language change for the charter
> 
> interactions between security, privacy and regulatory imperatives.
> The suggested change to the security text is: