Subject: [paws] comments on draft-wei-paws-framework

From: <[email-masked]>
Date: Sat, 21 Jul 2012 23:52:52 +0000

This is also a quite well written draft, which addresses the same solution space as draft-das-paws-protocol-02, with quite significant similarities to that draft.

The main differences I could observe is that it has slightly more detailed description on white spaces purpose, it does not define the INT-REQ and INT-RESP messages which draft-das-paws does (and which purpose I did not understand), and it uses xml for the data model description, while draft-das-paws uses json.
But all the comments I had on the data model described in draft-das-paws apply for this draft as well.

During the last F2F both drafts (or a previous reincarnation of them) were presented, and there was a request that the authors come up with a merged draft, rather than having two separate drafts with quite big overlap.
That did not happen for some reason, so we'll possibly need to decide which one of the two very similar drafts will the wg proceed forward. So I'd encourage people to read the drafts before the F2F.

- Gabor

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Peter McCann
Sent: Tuesday, July 10, 2012 7:31 AM
To: [email-masked]
Subject: [paws] New draft on a protocol framework for PAWS

Hi, all,

Yesterday we submitted a draft protocol framework for PAWS that defines an XML schema for messages and data elements between a master device and a database.  You can find it here:

http://tools.ietf.org/html/draft-wei-paws-framework-00

For now the draft is kind of hand-wavy about database discovery and the security model, especially the security model for validating slave devices.
These issues probably need to be addressed in separate documents.

--
Peter J. McCann
Huawei Technologies (USA)
[email-masked]
+1 908 541 3563
Rm. C-0105, 400 Crossings Blvd. (2nd floor), Bridgewater, NJ  08807-2863  USA

_______________________________________________
paws mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/paws

---

From: Zhulei <[email-masked]>
Date: Mon, 23 Jul 2012 10:41:40 +0000

Hi Gabor and all,

I think that you are correct that this proposal is one of two presentations in last IETF f2f meeting. The differences has been narrowed during this ietf meeting duration. For the reasons that I am open to merge proposals based on the consensus of work group, it is to see the differences between two.

There are a number of differences between draft-wei-paws-framework [paws framework] and draft-das-paws-protocol-02 [paws protocol]. 

1) First of all, [paws framework] describes the principles of DB discovery and security considerations which are required by charter and requirement document. But, seems [paws framework] outline the concepts of them, and separate more detail documents are expected. It would be helpful in case that the regulatory has different understanding if would have discovery or full security mechanisms to paws application. Then, core part of paws protocol supporting interoperability is quite clean to be reused, and satisfy the other needs at the same time.

2) The messages of INT-REQ and INT-RESP in [paws protocol] are invisible to [paws framework]. The reason to establish tcp connection is not sure to me. The information put in INT-REQ and INT-RESP is duplicated if compare to registration process, it is also not sure to me. So, these two messages can be moved if we are going merging wg doc, or one of them.

3) I think that regulatory shown the need and e-mail list wants this procedure in framework and would like to keep update messages part in [paws framework]. Not sure the reasons not to satisfy the need to update white space channel information in [paws protocol].

4) The security is not discussed in detail in [paws framework], the security-related information is not included in paws layer, we consider the security should be totally dealt in HTTPS, TLS layer is in charge of the confidentiality, integrity protection and authentication. So, [paws framework] does not include shared key and digest authentication information in xml scheme. Please refer the first point for this security consideration.

5) About the validation procedure, in [paws framework] just one slave device will be included in each validation procedure, not as a list of slave devices described in [paws protocol]. 

6) As you figure out that [paws framework] uses xml format data model and [paws protocol] uses JSON data mode. I think that these two proposals all work paws. No comments on this.

7) I think that discovery procedure might be discussed in a separate document whatever the need doing discovery, so there is only a short discussion for discovery in [paws framework] and [paws protocol].

Best regards,
Zhu Lei

Zhu Lei
Huawei
Wireless network research department 
E-mail address: [email-masked]
Phone: +86-10-60611961
Mobile: +86-13910157020

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2012年7月22日 7:53
收件人: Peter McCann; [email-masked]
主题: [paws] comments on draft-wei-paws-framework

- Gabor

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Peter McCann
Sent: Tuesday, July 10, 2012 7:31 AM
To: [email-masked]
Subject: [paws] New draft on a protocol framework for PAWS

Hi, all,