Subject: [paws] draft document for Discovery

From: <[email-masked]>
Date: Mon, 9 Jul 2012 21:04:47 +0000

Hello All,

Please find a link below to a draft submission for the Discovery process as described in the Use Cases & Requirements document. We are looking forward to your review and comments as well as discussion at IETF#84.

Abstract:
   A white space master device needs to query a white space database and
   obtain information about available spectrum/channels prior to
   operation.  White space databases which contain information about
   available spectrum/channels are associated with a regulatory domain.
   A white space master device needs to discover the relevant white
   space database(s) given its current location and in which regulatory
   domain that it is operating.  The white space database discovery is
   the preliminary step that a white space master device has to perform.

URL:             http://www.ietf.org/internet-drafts/draft-probasco-paws-discovery-00.txt
Htmlized:        http://tools.ietf.org/html/draft-probasco-paws-discovery-00

Kind Regards,
Scott & Raj

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 9 Jul 2012 17:27:31 -0400

This re-invents LoST without the extensive mechanisms for self organizing databases.
LoST has a query that sends location in, with a Service URN (which for this use would be "I want a WSDB for this location" and you get back (a list of) URIs.

That's what you propose, without the service URN because you want a special location based discovery mechanism just for WSDBs.

What you don't deal with is how a WSDB DS finds out about all other WSDB DSs.  That's the LoST "Forest Guide".  The FG works without a root, and allows cooperating LoST servers to  refer queries to the right server.

It's not really a great idea to bake a URI into a device.  Who knows what will happen over the life of a device?

The existing LoST discovery mechanism is built for widespread deployment in ISPs.   We may need something that works well without that.  There aren't a lot of good mechanisms that really work well - you either have a root of some sort, or, as you propose, a starting seed.  The root problem is who runs the root, and the starting seed problem is the lifetime of the seed.  You note that the seed gets nothing out of the exchange - it doesn't get to serve the query, it only gets to refer to someone who does.

I actually think this is not an important problem to solve really well.  The most common deployment model is going to be a tower and clients.  The tower can be configured, and either the clients learn from the tower, or the tower handles the database query itself.  Client discovery in that case could be the LoST discovery mechanism.

We have to handle the self organizing case (say a MANET) where one or more devices have some other path to the Internet to get to the WSDB.  They will need real discovery and may not have a cooperating ISP.  While I really don't like configuration, it may be the only viable way to do it.

Brian

On Jul 9, 2012, at 5:04 PM, <[email-masked]<mailto:[email-masked]>> wrote:

Hello All,

Abstract:

Kind Regards,
Scott & Raj

_______________________________________________
paws mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/paws

---

From: <[email-masked]>
Date: Mon, 16 Jul 2012 20:39:58 +0000

Hello All,

We have made a minor update to the draft based on received comments. We have clarified that the discovery server has global scope, ie. that a unique discovery server is not required for each regulatory domain. Also we have cited the appropriate requirements which this draft fulfills and provided some high level view of the messaging.

URL:             http://www.ietf.org/internet-drafts/draft-probasco-paws-discovery-01.txt
Diff:            http://tools.ietf.org/rfcdiff?url2=draft-probasco-paws-discovery-01

Kind Regards,
Scott & Raj

From: Scott Probasco <[email-masked]<mailto:[email-masked]>>
Date: Mon, 9 Jul 2012 21:04:47 +0000
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [paws] draft document for Discovery

Hello All,

Abstract:

Kind Regards,
Scott & Raj

_______________________________________________ paws mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/paws