Subject: [paws] XML schema versus JSON, vCard & iCal

From: Teco Boot <[email-masked]>
Date: Fri, 10 Aug 2012 15:02:31 +0200

We had a discussion on XML vs. JSON. I prefer the one with most compact messages.

On vCard and JSON: what is the status of "A JavaScript Object Notation (JSON) Representation for vCard"?
http://tools.ietf.org/html/draft-bhat-vcarddav-json-00

On valid times: can we use same format as certificates? They have similar simple requirements: valid notBefore & notAfter.
http://tools.ietf.org/html/rfc3280#section-4.1.2.5

Teco

---

From: <[email-masked]>
Date: Fri, 10 Aug 2012 15:43:30 +0000

Yes, there was a discussion on what representation/encoding we should use, JSON or XML. We took hums in the room to see preferences, and there was strong preference towards using JSON.
One technical issue which came up: not all data structures we may want to reuse have a JSON representation, some only have XML. Can JSON include XML data structures, if yes, can someone point to a doc describing it?  Otherwise we'll have to redefine them in JSON (this is what draft-das is actually doing).

Let me ask this: are there any objections to using JSON representation for the data format? Does anyone think that XML would be a better choice, and why?

- Gabor

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Teco Boot
Sent: Friday, August 10, 2012 6:03 AM
To: [email-masked]
Subject: [paws] XML schema versus JSON, vCard & iCal

Teco
_______________________________________________
paws mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/paws

---

From: "Benjamin A. Rolfe" <[email-masked]>
Date: Fri, 10 Aug 2012 09:10:21 -0700

Compactness of messages is important, but it is also important (to me at 
least) to be realizable in an implementation with limited resources, 
such as embedded devices in what are now popularly called "M2M" 
applications.  A lot of these devices could use IP all the end to end, 
but may have a very compact, simple stack and applications (i.e.  no 
browser).  Is JSON typically implemented when there is no browser?   
Would it be hard to do in a resource constrained device (i.e. where we 
talk about memory size in Kilo-bytes still).
Thanks
Ben

> On valid times: can we use same format as certificates? They have similar simple requirements: valid notBefore&  notAfter.

---

From: Teco Boot <[email-masked]>
Date: Sat, 11 Aug 2012 11:30:37 +0200

Op 10 aug. 2012, om 18:10 heeft Benjamin A. Rolfe het volgende geschreven:

> Compactness of messages is important, but it is also important (to me at least) to be realizable in an implementation with limited resources, such as embedded devices in what are now popularly called "M2M" applications.  A lot of these devices could use IP all the end to end, but may have a very compact, simple stack and applications (i.e.  no browser).  Is JSON typically implemented when there is no browser?   Would it be hard to do in a resource constrained device (i.e. where we talk about memory size in Kilo-bytes still).

In use cases and requirements document, there are no requirements for protocol performance. I guess OS/IP/TCP/TLS code size supersedes needs for JSON or XML. 

Same for timing: TCP/TLS connection setup will take more than the PAWS message exchange, I think. This may be of importance when using satcom links.

Because PAWS runs between master and database, over core network, performance is not our primary concern. But as always, it is good to keep an eye on efficiency.

Teco

---

From: Peter Stanforth <[email-masked]>
Date: Sat, 11 Aug 2012 07:12:55 -0400

Not all masters run over the core network.
Some of the Use cases have a master talking to another OTA
We should not assume that all Masters are attached to utility power so we
should be sympathetic to processing energy use also.

On SatAug/11/12 Sat Aug 11, 5:30 AM, "Teco Boot" <[email-masked]> wrote:

>> Compactness of messages is important, but it is also important (to me
>>at least) to be realizable in an implementation with limited resources,
>In use cases and requirements document, there are no requirements for
>protocol performance. I guess OS/IP/TCP/TLS code size supersedes needs
>for JSON or XML. 
>
>Same for timing: TCP/TLS connection setup will take more than the PAWS
>message exchange, I think. This may be of importance when using satcom
>links.
>
>Because PAWS runs between master and database, over core network,
>performance is not our primary concern. But as always, it is good to keep
>an eye on efficiency.
>
>Teco
>
>> Thanks
>> Ben
>> 
>> 
>>> On valid times: can we use same format as certificates? They have
>>>similar simple requirements: valid notBefore&  notAfter.