Subject: Re: [Pce] draft-dhody-pce-pcep-domain-sequence-01

From: "Daniel King" <[email-masked]>
Date: Thu, 2 Feb 2012 15:21:00 -0000

Cool, thanks Dhruv. 

Can I suggest that when you submit the new version of
draft-dhody-pce-pcep-domain-sequence, you also propose some text for
draft-ietf-pce-inter-area-as-applicability, that describes the
motivation/scope/requirements for the domain sequence
representation/encoding. 

Br, Dan. 

-----Original Message-----
From: dhruv [mailto:[email-masked]] 
Sent: 02 February 2012 12:57
To: 'Ramon Casellas'; 'Daniel King'
Cc: [email-masked]
Subject: RE: [Pce] draft-dhody-pce-pcep-domain-sequence-01 (applicability to
draft-ietf-pce-inter-area-as-applicability)

Dear Dan, Ramon and All, 

A new update of the draft is on the way which will close all open issues. I
will hope for WG adoption after that. 
Bunch of other inter-domain effort in WG (HPCE, P2MP, etc) already
references this document. As the role of
"draft-ietf-pce-inter-area-as-applicability" to cover inter-domain
applicability in a broad sense, IMHO, this work could be included/referenced
now or in later stage. 

Regards,
Dhruv

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ramon
Casellas
Sent: Thursday, February 02, 2012 5:02 PM
To: Daniel King
Cc: [email-masked]
Subject: Re: [Pce] draft-dhody-pce-pcep-domain-sequence-01 (applicability to
draft-ietf-pce-inter-area-as-applicability)

On 02/02/2012 11:57 AM, Daniel King wrote:
> Hi Ramon, All,
>
> We can widen the draft-ietf-pce-inter-area-as-applicability scope to
include
> "gaps", one of which may include domain sequence representation. As 
> usual though, we need to be able to demonstrate that new protocol 
> developments
are
> clearly required.

Dear Dan, all

You are right that draft-dhody should be included / referenced if/when it
becomes a wg document. I will let Dhruv comment on the issues as I was not
in Taipei, IIRC, there were some past emails on its need?.

For what is worth, I personally think that what is addressed in the draft
(i.e., the need to encode sequences, the need to constrain them and the need
to convey some order semantics) is needed. I won't be so bold to state
whether the current encoding / solution is to be retained :-), at least yet,
and we can allow some time to mature. If I may, what is your view on this?
Do you think it is addressing a non-issue?

> The work (draft-dhody-pce-pcep-domain-sequence) is interesting, but 
> the document is not a WG draft and if I remember
correctly
> has multiple open issues/options that need to be distilled.
I am afraid I don't have a clear list of them. Dhruv?

>
> 1. Does the working group need to standardise domain sequence 
> representation? If so, then I agree
FWIW, I say yes. A personal use case is a constrain in the H-PCE computation
(IRO + order semantics). I bought Dhruv's idea that working with domains is
more flexible than working with PCE_IDs (both in hpce, and md-p2mp )

> 2. Is draft-dhody-pce-pcep-domain-sequence a suitable solution?
If it isn't we would gladly address what is needed :).

> 3. Should we adopt as a WG document?
Until now, I have not considered requesting adoption. Personally, I can wait
until it is further discussed and matures.

Thanks for your comments
R

_______________________________________________
Pce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pce

---

From: dhruv <[email-masked]>
Date: Fri, 03 Feb 2012 11:23:11 +0530

Dear Dan, 

Once I submit the new version of my draft, I will send you the suggested
text for "draft-ietf-pce-inter-area-as-applicability". 
Both of which will be done by next week. Thanks! 

Regards,
Dhruv

-----Original Message-----
From: Daniel King [mailto:[email-masked]] 
Sent: Thursday, February 02, 2012 8:51 PM
To: [email-masked]; 'Ramon Casellas'
Cc: [email-masked]
Subject: RE: [Pce] draft-dhody-pce-pcep-domain-sequence-01

Cool, thanks Dhruv. 

Br, Dan. 

-----Original Message-----
From: dhruv [mailto:[email-masked]] 
Sent: 02 February 2012 12:57
To: 'Ramon Casellas'; 'Daniel King'
Cc: [email-masked]
Subject: RE: [Pce] draft-dhody-pce-pcep-domain-sequence-01 (applicability to

Dear Dan, Ramon and All, 

Regards,
Dhruv

-----Original Message-----

include
are

Dear Dan, all

correctly

Thanks for your comments
R