Subject: [Pce] FW: New Version Notification for draft-zhang-pce-pcep-stateful-pce-gmpls-00.txt

From: "Zhangxian (Xian)" <[email-masked]>
Date: Mon, 9 Jul 2012 02:15:55 +0000

Hi, Dear PCErs, 

   We've just posted a new I-D about PCEP extension for stateful PCE usage in GMPLS networks.
   
   You could find the I-D here: http://www.ietf.org/internet-drafts/draft-zhang-pce-pcep-stateful-pce-gmpls-00.txt

   Your feedbacks and comments would be very much appreciated.

Best Regards,

Xian et al.

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2012年7月9日 10:00
收件人: Zhangxian (Xian)
抄送: [email-masked]; [email-masked]; Leeyoung
主题: New Version Notification for draft-zhang-pce-pcep-stateful-pce-gmpls-00.txt

A new version of I-D, draft-zhang-pce-pcep-stateful-pce-gmpls-00.txt
has been successfully submitted by Xian Zhang and posted to the
IETF repository.

Filename:	 draft-zhang-pce-pcep-stateful-pce-gmpls
Revision:	 00
Title:		 Path Computation Element (PCE) Protocol Extension for Stateful PCE Usage in GMPLS Networks
Creation date:	 2012-07-07
WG ID:		 Individual Submission
Number of pages: 15
URL:             http://www.ietf.org/internet-drafts/draft-zhang-pce-pcep-stateful-pce-gmpls-00.txt
Status:          http://datatracker.ietf.org/doc/draft-zhang-pce-pcep-stateful-pce-gmpls
Htmlized:        http://tools.ietf.org/html/draft-zhang-pce-pcep-stateful-pce-gmpls-00

Abstract:
   The Path Computation Element (PCE) facilitates Traffic Engineering
   (TE) based path calculation in large, multi-domain, multi-region, or
   multi-layer networks. PCE can be stateless or stateful. With the LSP
   state information acquired from the network, a stateful PCE exhibits
   superiority in facilitating a wide variety of applications,
   especially in GMPLS networks, such as impairment-aware routing and
   wavelength assignment in wavelength-switched optical networks (WSON),
   time-based scheduling applications. This memo provides extensions
   required for PCE communication protocol (i.e. PCEP) so as to enable
   the usage of a stateful PCE capability in GMPLS networks. To be more
   specific, the PCEP extensions specified in this memo include not
   only new objects but also modification of existing objects in PCEP
   messages, with regard to stateful PCE usage in GMPLS networks.

The IETF Secretariat

---

From: Robert Varga <[email-masked]>
Date: Tue, 10 Jul 2012 11:10:22 +0200

Hi,

upon briefly skimming the draft, I would like to suggest splitting 
application-specific extensions into separate drafts.

Especially section 2.6.1 (time-based scheduling) merits its own draft 
because of all the issues one runs into when dealing with distributed 
systems and time. It is obvious that PCC and PCE clocks need to be 
somehow synchronized -- which is a new operational requirement not 
considered in PCEP. I think race windows, security implications and the 
impact of loss of synchronization needs to be described, too.

Bye,
Robert

On 07/09/2012 04:15 AM, Zhangxian (Xian) wrote:
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce