Subject: Re: [Pce] Stateful PCE Capability discovery draft: request for review & adoption as a WG document

From: Ina Minei <[email-masked]>
Date: Wed, 3 Apr 2013 16:08:45 +0000

This is useful and straightforward functionality that is much needed for a deployment and completes the solution.

I support this draft's adoption as a WG document (but I guess we will wait for the chairs to send the official poll, right?)

Ina 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jan Medved (jmedved)
Sent: Wednesday, March 27, 2013 3:49 PM
To: [email-masked]
Subject: [Pce] Stateful PCE Capability discovery draft: request for review & adoption as a WG document

Dear PCE'rs,

can you please review draft-sivabalan-pce-disco-stateful and send your comments to the list? The draft is at: http://datatracker.ietf.org/doc/draft-sivabalan-pce-disco-stateful/.

Also, can you please let us know if you are in favor/opposed to adopting draft-sivabalan-pce-disco-stateful as a PCE WG document? 

Thanks a lot in advance,
Siva and Jan
_______________________________________________
Pce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pce

---

From: Dhruv Dhody <[email-masked]>
Date: Wed, 3 Apr 2013 22:23:30 +0530

Hi,

I agree that, it is a needed functionality.

*Question on Process - *
Does this belong in a separate ID or better suited in the *
ietf-pce-stateful-pce* as before?
I am taking cue from other RFC that added new capability like RFC6006.

*Few comments -
*
(1) Bit 9, 10 are already used
9Global Concurrent Optimization (GCO)[RFC5557<http://www.iana.org/go/rfc5557>
]10P2MP path computation[RFC6006 <http://www.iana.org/go/rfc6006>](2) Since
both PCEP open message and IGP PCE discovery can be used to notify PCE
stateful nature, some text should be added to handle it, For ex how should
the implementation behave if there is a difference in the capability
between what PCC learned via  IGP flooding and open message?

(3) BGP-LS
   A PCC could listen to IGP updates, or use other mechanisms that carry

   IGP information to interested clients, such as BGP-LS
   ([I-D.ietf-idr-ls-distribution]).

Can BGP-LS be used to advertise PCE? As far as i remember it allow the
TE information to be carried in BGP and not PCE Discovery TLVs?

Jan: Since you are the author of BGP-LS, maybe you can clarify.

Dhruv

On Wed, Apr 3, 2013 at 9:38 PM, Ina Minei <[email-masked]> wrote:

> I support this draft's adoption as a WG document (but I guess we will wait
> for the chairs to send the official poll, right?)
>
> Ina
>
> can you please review draft-sivabalan-pce-disco-stateful and send your
> comments to the list? The draft is at:
> http://datatracker.ietf.org/doc/draft-sivabalan-pce-disco-stateful/.
>
> Also, can you please let us know if you are in favor/opposed to adopting
> draft-sivabalan-pce-disco-stateful as a PCE WG document?
>
>
>
> Thanks a lot in advance,
> Siva and Jan

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Wed, 3 Apr 2013 17:30:16 +0000

Hi- 

I agree. Indeed a much needed draft.

Thanks

Regards Š Zafar

-----Original Message-----
From: Ina Minei <[email-masked]>
Date: Wednesday, April 3, 2013 12:08 PM
To: "Jan Medved (jmedved)" <[email-masked]>, "[email-masked]"
<[email-masked]>
Subject: Re: [Pce] Stateful PCE Capability discovery draft: request for
review & adoption as a WG document

>I support this draft's adoption as a WG document (but I guess we will
>wait for the chairs to send the official poll, right?)
>
>Ina 
>

---

From: Edward Crabbe <[email-masked]>
Date: Wed, 3 Apr 2013 10:35:41 -0700

Ditto: I support this draft's adoption as a WG document.

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Thu, 4 Apr 2013 04:09:19 +0000

Hi, All, 

    Agree; This is part of the basic extensions needed for implementing stateful PCE and should be considered for adoption by WG. 

Regards,

Xian (speaking as co-author)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ina Minei
Sent: 2013年4月4日 0:09
To: Jan Medved (jmedved); [email-masked]
Subject: Re: [Pce] Stateful PCE Capability discovery draft: request for review & adoption as a WG document

Ina 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jan Medved (jmedved)
Sent: Wednesday, March 27, 2013 3:49 PM
To: [email-masked]
Subject: [Pce] Stateful PCE Capability discovery draft: request for review & adoption as a WG document

Dear PCE'rs,

Thanks a lot in advance,
Siva and Jan

---

From: Julien Meuric <[email-masked]>
Date: Thu, 04 Apr 2013 14:32:30 +0200

Hi Ina.

Indeed, there is no poll for WG adoption in progress, which remains in 
the hands of the chairs. One may interpret Silva and Jan's message as a 
clever way to get feedback from the WG, but the use of "adopting" is an 
unfortunate wording. In this context, comments like "support" or 
"useless" need to be backed up.

Thanks,

Julien

On 04/03/2013 18:08, Ina Minei wrote:
> (but I guess we will wait for the chairs to send the official poll, right?)
>
> Ina
>

---

From: Fatai Zhang <[email-masked]>
Date: Sun, 7 Apr 2013 09:00:37 +0000

Hi Jan,

I would say this draft is useful and I am in favor of this draft, even though I know this is not an official poll. 

Best Regards

Fatai

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jan Medved (jmedved)
Sent: Thursday, March 28, 2013 6:49 AM
To: [email-masked]
Subject: [Pce] Stateful PCE Capability discovery draft: request for review & adoption as a WG document

Dear PCE'rs,

Thanks a lot in advance,
Siva and Jan