Subject: Re: [Pce] I-D Action: draft-ietf-pce-stateful-sync-optimizations-09.txt

From: Girish Birajdar <[email-masked]>
Date: Fri, 3 Mar 2017 12:49:44 -0800

Dear Authors,

Suggested TLV values conflict with in other PCE drafts. I could find 2
conflicts, there may be more. Is there a way the PCE WG can manage TLV
values across drafts? For compatibility between vendors and different
software release from same vendor - keeping these values unchanged is
critical.

8.3.  STATEFUL-PCE-CAPABILITY TLV
    *TBD11 (suggested* value 26) TRIGGERED-INITIAL-SYNC    This document
*    TBD12 (suggested* value 28) TRIGGERED-RESYNC          This document

https://tools.ietf.org/html/draft-ietf-pce-segment-routing-08#section-9.4 -
SR-PCE-CAPABILITY is 26

https://tools.ietf.org/html/draft-ietf-pce-lsp-setup-type-03#section-6.1
PATH-SETUP-TYPE is 28

Thanks,

Girish

On Tue, Feb 28, 2017 at 6:08 AM, <[email-masked]> wrote:

>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> This draft is a work item of the Path Computation Element of the IETF.
>
>         Title           : Optimizations of Label Switched Path State
> Synchronization Procedures for a Stateful PCE
>         Authors         : Edward Crabbe
>                           Ina Minei
>                           Jan Medved
>                           Robert Varga
>                           Xian Zhang
>                           Dhruv Dhody
>         Filename        : draft-ietf-pce-stateful-sync-
> optimizations-09.txt
>         Pages           : 25
>         Date            : 2017-02-28
>
> Abstract:
>    A stateful Path Computation Element (PCE) has access to not only the
>    information disseminated by the network's Interior Gateway Protocol
>    (IGP), but also the set of active paths and their reserved resources
>    for its computation.  The additional Label Switched Path (LSP) state
>    information allows the PCE to compute constrained paths while
>    considering individual LSPs and their interactions.  This requires a
>    state synchronization mechanism between the PCE and the network, PCE
>    and path computation clients (PCCs), and between cooperating PCEs.
>    The basic mechanism for state synchronization is part of the stateful
>    PCE specification.  This document presents motivations for
>    optimizations to the base state synchronization procedure and
>    specifies the required Path Computation Element Communication
>    Protocol (PCEP) extensions.
>
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-pce-stateful-
> sync-optimizations/
>
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-ietf-pce-stateful-sync-optimizations-09
>
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-pce-stateful-
> sync-optimizations-09
>
>
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce
>

---

From: Dhruv Dhody <[email-masked]>
Date: Sat, 4 Mar 2017 03:25:58 +0000

Hi Girish,

(1)    You are comparing two different things -

https://tools.ietf.org/html/draft-ietf-pce-stateful-sync-optimizations-09#section-8.3

is for bit inside the STATEFUL-PCE-CAPABILITY TLV i.e. bit no 26

where as https://tools.ietf.org/html/draft-ietf-pce-segment-routing-08#section-9.3

is for the TLV Type i.e TLV Type = 26
We have done our best to keep the codepoints align across all stateful PCE drafts.
But note that these are only suggestions and final authority is with IANA.

(2)    The IANA early allocation [RFC7120] is the best way to make sure implementations use the right code points with no confusion.

Chairs have done that for the stateful PCE, SR, Initiated and path setup type drafts. Those are visible at - http://www.iana.org/assignments/pcep/pcep.xhtml.
         As this draft goes to the RFC editor, the IANA would block the codepoints for this draft too.

(3)    There is a draft asking for experimental code points in PCEP - https://tools.ietf.org/html/draft-dhody-pce-pcep-exp-codepoints-02 ; do review and suggest if you find that useful for early experimentation of ideas.

Thanks!
Dhruv

From: Pce [mailto:[email-masked]] On Behalf Of Girish Birajdar
Sent: 04 March 2017 02:20
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Pce] I-D Action: draft-ietf-pce-stateful-sync-optimizations-09.txt

Dear Authors,
Suggested TLV values conflict with in other PCE drafts. I could find 2 conflicts, there may be more. Is there a way the PCE WG can manage TLV values across drafts? For compatibility between vendors and different software release from same vendor - keeping these values unchanged is critical.

8.3.  STATEFUL-PCE-CAPABILITY TLV
    TBD11 (suggested value 26) TRIGGERED-INITIAL-SYNC    This document
    TBD12 (suggested value 28) TRIGGERED-RESYNC          This document

Thanks,

Girish

On Tue, Feb 28, 2017 at 6:08 AM, <[email-masked]<mailto:[email-masked]>> wrote:

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Path Computation Element of the IETF.

        Title           : Optimizations of Label Switched Path State Synchronization Procedures for a Stateful PCE
        Authors         : Edward Crabbe
                          Ina Minei
                          Jan Medved
                          Robert Varga
                          Xian Zhang
                          Dhruv Dhody
        Filename        : draft-ietf-pce-stateful-sync-optimizations-09.txt
        Pages           : 25
        Date            : 2017-02-28

Abstract:

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-pce-stateful-sync-optimizations/

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-pce-stateful-sync-optimizations-09

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

_______________________________________________
Pce mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pce