Subject: [Pce] Working group last call for draft-ietf-pce-rfc6006bis-00

From: Jonathan Hardwick <[email-masked]>
Date: Fri, 10 Mar 2017 13:54:42 +0000

Dear PCE working group,

This email starts a working group last call for draft-ietf-pce-rfc6006bis-00.

https://datatracker.ietf.org/doc/draft-ietf-pce-rfc6006bis/

Please read the document and reply to the PCE mailing list whether you believe this document is ready to be published, or not (including any comments on why not).  The last call will end on Monday 20 March.

Best regards
Jon, JP and Julien

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 28 Mar 2017 23:18:10 +0100

Hi Jon,
 
I see that WG last call completed in silence. Possibly a function of
people preparing for IETF-98. Maybe just means that everyone thinks 
it is obvious to update the RFC and move on.
 
Anyway, since I'm sitting in a WG meeting where the discussion is a
little too esoteric even for me, here is a quick (but late) review.
 
Cheers,
Adrian
 
===
 
Unfortunate effect of a bis is that the author count has gone OTT.
 
---
 
A bit odd to wipe the Acknowledgements of the people who contributed to
RFC 6006.
 
---
 
Why has Zafar disappeared from the Authors' Addresses (but remains on
the front page)?
 
---
 
Good job picking up the five errata that are on file.
I was a little surprised to see some additional changes that have not
been flagged to the WG nor noted anywhere in the document (e.g., in a
changes section such as Appendix A).
 
---
 
I see you added some text to 3.4. I see that this text is to explain
the RBNF that follows, so that is probably OK.
 
---
 
I must have missed the discussion of Errata Report 4867. Sorry about
that.
 
There are three issues, I think
1. Trying to pack all RBNF into the spec as though the RBNF was the
   normative definition of the message format. It isn't and was never
   intended to be.
   Doing this gets infinitely complicated as more objects are added.
   Doesn't mean what you have done is wrong, wrt svec-list, just not
   necessary.
2. Removal of <BANDWIDTH> from <RRO-List> is wrong, I think.
   As I see it:
     You can apply <BANDWIDTH> to the whole <RRO-List> by placing it
     after the <RRO-List>.
     If you want one <RRO> in an <RRO-List> to have a different
     <BANDWIDTH> you can include a separate <BANDWIDTH> after the
     <RRO>.
   I think you have *changed* the specification so that the way this
   function is achieved is to pull the <RRO> that has a different
   <BANDWIDTH> out into a different <RRO-List>.
   That's functional and can be changed if that is what people want
   and have discussed, but doing it with an Errata is a mistake because
   it was not an error in the document.
3. You also see to think that <BANDWIDTH> cannot be applied to the
   <END-POINTS> unless an <RRO-LIST> is present. I think that is
   wrong, too.  If it makes sense to have <END-POINTS> without an
   an <RRO-List> why would you not allow each instance of <END-POINTS>
   to have its own <BANDWIDTH>? This also seems to be a change of
   substance rather than an error in the document. Again, the WG is
   free to make this change, but surely not without discussion.
 
---
 
I see you have added some text to 3.5. This also seems to be just
explanation and is probably OK.
 
---
 
The fix in 3.12 looks good, but was not flagged to the WG.
 
From: Pce [mailto:[email-masked]] On Behalf Of Jonathan Hardwick
Sent: 10 March 2017 13:55
To: [email-masked]
Subject: [Pce] Working group last call for draft-ietf-pce-rfc6006bis-00
 
Dear PCE working group,

Please read the document and reply to the PCE mailing list whether you believe
this document is ready to be published, or not (including any comments on why
not).  The last call will end on Monday 20 March.
 
Best regards
Jon, JP and Julien

---

From: Jonathan Hardwick <[email-masked]>
Date: Tue, 28 Mar 2017 22:59:34 +0000

Hi Adrian,

Many thanks for your comments.  I will let the document authors reply to your points, but I just wanted to clarify the process that we've followed.

The draft, and a summary of the changes it introduced, was advertised to the working group with an email to the list on 3 Nov last year.  The authors followed this up with a presentation at IETF 97, where they asked for guidance on how to proceed with the issues they were raising.  The options we considered were to either raise a new erratum or publish this bis-draft as a new RFC.  After discussion we decided to do both, which is why the proposed changes are now in the errata system.  I do understand your points and I tend to agree on reflection that some of the changes in erratum 4867 are not really suitable for an Errata Report.  However I must stress that the erratum was raised _after_ the changes were announced and discussed, and there did seem to be consensus behind those changes (or at least, no dissention).

Best regards
Jon

From: Adrian Farrel [mailto:[email-masked]]
Sent: 28 March 2017 17:18
To: Jonathan Hardwick <[email-masked]>; [email-masked]
Subject: RE: [Pce] Working group last call for draft-ietf-pce-rfc6006bis-00

Hi Jon,

Cheers,
Adrian

===

---

---

---

---

---

---

---

From: Pce [mailto:[email-masked]] On Behalf Of Jonathan Hardwick
Sent: 10 March 2017 13:55
To: [email-masked]<mailto:[email-masked]>
Subject: [Pce] Working group last call for draft-ietf-pce-rfc6006bis-00

Dear PCE working group,

Best regards
Jon, JP and Julien

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 29 Mar 2017 01:03:58 +0100

OK.
Got it. 
Thanks.
Adrian
--
Support an author and your imagination.
Tales from the Wood - Eighteen new fairy tales.
More Tales from the Wood - Eighteen MORE new fairy tales.
https://www.feedaread.com/profiles/8604/
http://www.amazon.co.uk/Tales-Wood-Adrian-Farrel/dp/1786100924
Or buy from me direct.

From: Jonathan Hardwick [mailto:[email-masked]] 
Sent: 29 March 2017 00:00
To: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Pce] Working group last call for draft-ietf-pce-rfc6006bis-00
 
Hi Adrian,
 
Many thanks for your comments.  I will let the document authors reply to your
points, but I just wanted to clarify the process that we've followed.
 
The draft, and a summary of the changes it introduced, was advertised to the
working group with an email to the list on 3 Nov last year.  The authors
followed this up with a presentation at IETF 97, where they asked for guidance
on how to proceed with the issues they were raising.  The options we considered
were to either raise a new erratum or publish this bis-draft as a new RFC.
After discussion we decided to do both, which is why the proposed changes are
now in the errata system.  I do understand your points and I tend to agree on
reflection that some of the changes in erratum 4867 are not really suitable for
an Errata Report.  However I must stress that the erratum was raised _after_ the
changes were announced and discussed, and there did seem to be consensus behind
those changes (or at least, no dissention).
 
Best regards
Jon

Hi Jon,

 
Cheers,
Adrian
 
===

---

---

---

---

---

 
---

---

 
Dear PCE working group,

 
Best regards
Jon, JP and Julien

---

From: Dhruv Dhody <[email-masked]>
Date: Wed, 29 Mar 2017 00:55:07 +0000

Hi WG,

Adrian, Jon and I had a quick chat (the benefit of getting comments during the IETF week).
See inline for details...

From: Pce [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: 28 March 2017 17:18
To: 'Jonathan Hardwick' <[email-masked]>; [email-masked]
Subject: Re: [Pce] Working group last call for draft-ietf-pce-rfc6006bis-00

Hi Jon,

Cheers,
Adrian

===

[Dhruv] Yes, I think this can be added in the shepherd report and hopefully that should be fine.
---

[Dhruv] Ack
---

[Dhruv] Oops, my mistake. Fixed.
---

---

---

[Dhruv] https://tools.ietf.org//rfcdiff?url1=RFC6006&url2=draft-ietf-pce-rfc6006bis-00<https://tools.ietf.org/rfcdiff?url1=RFC6006&url2=draft-ietf-pce-rfc6006bis-00>

-        BANDWIDTH object is for the full P2MP tree i.e. for all destinations, we do not need different bandwidth for each destination/RRO.

-        The re-optimization bandwidth needs to be included only with the RRO; this is same as RFC5440

So the changes in the RBNF were done to fix it.

---

---

I will upload a new version as well.

Thanks!
Dhruv

Dear PCE working group,

Best regards
Jon, JP and Julien

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 29 Mar 2017 06:48:13 +0100

Just an ack to Dhruv's email
 
A

 
From: Dhruv Dhody [mailto:[email-masked]] 
Sent: 29 March 2017 01:55
To: [email-masked]; 'Jonathan Hardwick'; [email-masked]
Cc: Dhruv Dhody
Subject: RE: [Pce] Working group last call for draft-ietf-pce-rfc6006bis-00
 
Hi WG, 
 
Adrian, Jon and I had a quick chat (the benefit of getting comments during the
IETF week).  
See inline for details. 

Hi Jon,

 
Cheers,
Adrian
 
===

[Dhruv] Yes, I think this can be added in the shepherd report and hopefully that
should be fine. 
---

[Dhruv] Ack
---

 
 
---

---

 
[Dhruv] https://tools.ietf.org//rfcdiff?url1=RFC6006
<https://tools.ietf.org/rfcdiff?url1=RFC6006&url2=draft-ietf-pce-rfc6006bis-00>
&url2=draft-ietf-pce-rfc6006bis-00

-        BANDWIDTH object is for the full P2MP tree i.e. for all destinations,
we do not need different bandwidth for each destination/RRO. 
-        The re-optimization bandwidth needs to be included only with the RRO;
this is same as RFC5440 

---

---

 
Thanks!
Dhruv

Dear PCE working group,

 
Best regards
Jon, JP and Julien