Subject: [Pce] [Editorial Errata Reported] RFC5440 (4956)

From: RFC Errata System <[email-masked]>
Date: Wed, 1 Mar 2017 02:29:53 -0800 (PST)

The following errata report has been submitted for RFC5440,
"Path Computation Element (PCE) Communication Protocol (PCEP)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5440&eid=4956

--------------------------------------
Type: Editorial
Reported by: Adrian Farrel <[email-masked]>

Section: 9.3

Original Text
-------------

Corrected Text
--------------

Notes
-----
This section does not tell IANA the range for the Object-Types to be registered for each Object-Class, nor what to do with the values not assigned in this document.

IANA has correctly recognised that the top value is 15, and that the values between those shown here and 15 should be marked as "Unassigned." 

However, there is confusion over the value 0 for an Object-Type. The old entries (arising from RFC 5440) do not mention 0. Newer entries for RFC 7470 and several I-Ds in the pipe mark 0 as Unassigned.

For consistency, ALL 0 Object-Types should be marked "Reserved".

(This might need an Errata Report against some other RFCs if you are particularly fussy, but I think we can do it all on this report.)

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5440 (draft-ietf-pce-pcep-19)
--------------------------------------
Title               : Path Computation Element (PCE) Communication Protocol (PCEP)
Publication Date    : March 2009
Author(s)           : JP. Vasseur, Ed., JL. Le Roux, Ed.
Category            : PROPOSED STANDARD
Source              : Path Computation Element
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 1 Mar 2017 10:45:45 -0000

Looking at the IANA section for draft-ietf-pce-inter-layer-ext-12.txt which is
in flight with the IANA team, we discovered that the Object-Type value of 0 is
not mentioned in nearly every entry at
https://www.iana.org/assignments/pcep/pcep.xhtml#pcep-objects

Looking back at RFC 5440 (and at some more recent RFCs) I think the intention
was that an Object-Type of 0 should not be used (perhaps the first PCEP
implementation was written in Pascal?).

Thus, this Errata Report proposes that IANA be instructed to mark ALL
Object-Type 0 entries as "Reserved".

Largely speaking, this just fills in missing information, but it changes the 0
values for:

LSP draft-ietf-pce-stateful-pce (0 currently "Unassigned") 
SRP draft-ietf-pce-stateful-pce (0 currently "Unassigned")
VENDOR-INFORMATION RFC 7470 (0 is "Unassigned")
BU draft-ietf-pce-pcep-service-aware (0 currently "Unassigned")

It would also be wise to mark the unassigned Object Classes to read...
OLD
36-255 Unassigned 1-15: Unassigned 
NEW
36-255 Unassigned 0: Reserved
                                        1-15: Unassigned 

Since two of these documents are in late-stage RFC Editor processing, I suggest
the ADs would do well to act SOON.

Adrian

> -----Original Message-----
> From: Pce [mailto:[email-masked]] On Behalf Of RFC Errata System
> Sent: 01 March 2017 10:30
> To: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Cc: [email-masked]; text/[email-masked]; [email-masked]
> Type; [email-masked]; charset=[email-masked]
> Subject: [Pce] [Editorial Errata Reported] RFC5440 (4956)
> 
> This section does not tell IANA the range for the Object-Types to be
registered
> for each Object-Class, nor what to do with the values not assigned in this
> document.
> 
> IANA has correctly recognised that the top value is 15, and that the values
> between those shown here and 15 should be marked as "Unassigned."
> 
> However, there is confusion over the value 0 for an Object-Type. The old
entries
> (arising from RFC 5440) do not mention 0. Newer entries for RFC 7470 and
several
> I-Ds in the pipe mark 0 as Unassigned.
> 
> (This might need an Errata Report against some other RFCs if you are
particularly
> fussy, but I think we can do it all on this report.)
> 
> Instructions:
> -------------
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 2 Mar 2017 22:05:10 -0000

Thanks, very timely.

I think you need to pass this on to IANA and ask them to act.
Explicit communication needed because they don't follow Errata.

Adrian

> From: BRUNGARD, DEBORAH A [mailto:[email-masked]]
> Sent: 02 March 2017 21:25
> To: [email-masked]; [email-masked]; [email-masked]
> Subject: RE: [Pce] [Editorial Errata Reported] RFC5440 (4956)
> 
> Hi Adrian,
> 
> Much thanks for the catch. I've verified - hopefully this meets your criteria
for
> SOON as I would not want to be an example in your draft:-)
> 
> Deborah
> 
> 
> > From: Adrian Farrel [mailto:[email-masked]]
> > Sent: Wednesday, March 01, 2017 5:46 AM
> > To: [email-masked]; [email-masked]
> > Subject: RE: [Pce] [Editorial Errata Reported] RFC5440 (4956)
> >
> > https://urldefense.proofpoint.com/v2/url?u=https-
> > 3A__www.iana.org_assignments_pcep_pcep.xhtml-23pcep-
> > 2Dobjects&d=DQICAg&c=LFYZ-
> > o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=zTpEpsMI7ID2Y51iuu
> > MuyeVi5EQRlmaSiZu972Yo_5w&s=NE2thC9Tljil9xWVP8oIBIXIM2nY4X5Vel0ElRI
> > B2zw&e=
> >
> > > https://urldefense.proofpoint.com/v2/url?u=http-3A__www.rfc-
> > 2Deditor.org_errata-5Fsearch.php-3Frfc-3D5440-26eid-
> > 3D4956&d=DQICAg&c=LFYZ-
> > o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=zTpEpsMI7ID2Y51iuu
> > MuyeVi5EQRlmaSiZu972Yo_5w&s=nD7-oTxeqDLDwDFIhk-
> > taL1kYPVOoqBVUEVETZwUdMk&e=
> > >
> > > Title               : Path Computation Element (PCE) Communication
Protocol
> > (PCEP)
> > > https://urldefense.proofpoint.com/v2/url?u=https-
> > 3A__www.ietf.org_mailman_listinfo_pce&d=DQICAg&c=LFYZ-
> > o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=zTpEpsMI7ID2Y51iuu
> > MuyeVi5EQRlmaSiZu972Yo_5w&s=dNNwtvf5IuP6oBe28khBLWrQenNDCXUiFxT
> > BBnzEZo0&e=

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Thu, 2 Mar 2017 21:25:20 +0000

Hi Adrian,

Much thanks for the catch. I've verified - hopefully this meets your criteria for SOON as I would not want to be an example in your draft:-)

Deborah