Subject: [Pce] Request for review on <draft-pce-mib-extensions-01>

From: Dheeraj Parchuru <[email-masked]>
Date: Sat, 8 Apr 2017 01:14:27 +0000

Hi,

Please take a few minutes to write a review to the below draft for PCEP MIB Extensions. Thank you !

Name:                  draft-pce-mib-extensions

Revision:              01

Title:                      Extensions to the Path Computation Element Protocol(PCEP) Management Information Base(MIB) Module

Document date:               2016-10-07

Group:                  Individual Submission

Pages:                   22

URL:            https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_internet-2Ddrafts_draft-2Dpce-2Dmib-2Dextensions-2D01.txt&d=DQICaQ&c=IL_XqQWOjubgfqINi2jTzg&r=ZkEFLDwLRPKreZ18Kptz_z547aAkiIkkoJfsKoKt6pQ&m=Iwpd2O0WWICXlZdaioTBE5dalfw7mmu7XITogSst-k8&s=nZ9JKuHe-KrMUtz_f5ImB7_F0LT6pXc8oPww-CIqgKI&e=

Status:         https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dpce-2Dmib-2Dextensions_&d=DQICaQ&c=IL_XqQWOjubgfqINi2jTzg&r=ZkEFLDwLRPKreZ18Kptz_z547aAkiIkkoJfsKoKt6pQ&m=Iwpd2O0WWICXlZdaioTBE5dalfw7mmu7XITogSst-k8&s=JtRLQcjMpzcbJZzY_c0QJhiGAj7d4YjaixuJactmsyA&e=

Htmlized:       https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dpce-2Dmib-2Dextensions-2D01&d=DQICaQ&c=IL_XqQWOjubgfqINi2jTzg&r=ZkEFLDwLRPKreZ18Kptz_z547aAkiIkkoJfsKoKt6pQ&m=Iwpd2O0WWICXlZdaioTBE5dalfw7mmu7XITogSst-k8&s=Z1Z50_bGtB0IfVEG889281Y2IVdeuEu4vY12OOMBYEo&e=

Diff:           https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dpce-2Dmib-2Dextensions-2D01&d=DQICaQ&c=IL_XqQWOjubgfqINi2jTzg&r=ZkEFLDwLRPKreZ18Kptz_z547aAkiIkkoJfsKoKt6pQ&m=Iwpd2O0WWICXlZdaioTBE5dalfw7mmu7XITogSst-k8&s=5hDsoNhKRRKG3ev6r67OOMQYv2OiUp-6tp4iZGlsqyA&e=

Abstract:

   This memo defines a portion of the Management Information Base (MIB)

   for use with network management protocols in the Internet community.

   In particular, it describes extensions to the managed objects for

   modeling of the Path Computation Element Communication Protocol

   (PCEP) for communications between a Path Computation Client (PCC) and

   a Path Computation Element (PCE), or between two PCEs, that support

   stateful capabilities.

- Regards
Dheeraj

---

From: t.petch <[email-masked]>
Date: Sat, 8 Apr 2017 12:00:59 +0100

----- Original Message -----
From: "Dheeraj Parchuru" <[email-masked]>
Sent: Saturday, April 08, 2017 2:14 AM

"Expires: April 10, 2017 "

I suggest that you submit a -02 (no changes unless the tools system
forces them on you:-( lest people get frustrated trying to find it and
so refrain from commenting.

Tom Petch

> Title:                      Extensions to the Path Computation Element
Protocol(PCEP) Management Information Base(MIB) Module
> Group:                  Individual Submission

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

> URL:
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_intern
et-2Ddrafts_draft-2Dpce-2Dmib-2Dextensions-2D01.txt&d=DQICaQ&c=IL_XqQWOj
ubgfqINi2jTzg&r=ZkEFLDwLRPKreZ18Kptz_z547aAkiIkkoJfsKoKt6pQ&m=Iwpd2O0WWI
CXlZdaioTBE5dalfw7mmu7XITogSst-k8&s=nZ9JKuHe-KrMUtz_f5ImB7_F0LT6pXc8oPww
-CIqgKI&e=
> Status:
https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.or
g_doc_draft-2Dpce-2Dmib-2Dextensions_&d=DQICaQ&c=IL_XqQWOjubgfqINi2jTzg&
r=ZkEFLDwLRPKreZ18Kptz_z547aAkiIkkoJfsKoKt6pQ&m=Iwpd2O0WWICXlZdaioTBE5da
lfw7mmu7XITogSst-k8&s=JtRLQcjMpzcbJZzY_c0QJhiGAj7d4YjaixuJactmsyA&e=
> Htmlized:
https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html
_draft-2Dpce-2Dmib-2Dextensions-2D01&d=DQICaQ&c=IL_XqQWOjubgfqINi2jTzg&r
=ZkEFLDwLRPKreZ18Kptz_z547aAkiIkkoJfsKoKt6pQ&m=Iwpd2O0WWICXlZdaioTBE5dal
fw7mmu7XITogSst-k8&s=Z1Z50_bGtB0IfVEG889281Y2IVdeuEu4vY12OOMBYEo&e=
> Diff:
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdif
f-3Furl2-3Ddraft-2Dpce-2Dmib-2Dextensions-2D01&d=DQICaQ&c=IL_XqQWOjubgfq
INi2jTzg&r=ZkEFLDwLRPKreZ18Kptz_z547aAkiIkkoJfsKoKt6pQ&m=Iwpd2O0WWICXlZd
aioTBE5dalfw7mmu7XITogSst-k8&s=5hDsoNhKRRKG3ev6r67OOMQYv2OiUp-6tp4iZGlsq
yA&e=
>    a Path Computation Element (PCE), or between two PCEs, that support

------------------------------------------------------------------------
--------

> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce
>

---

From: Dhruv Dhody <[email-masked]>
Date: Sat, 8 Apr 2017 22:37:41 +0530

Hi Dheeraj,

(1) It would be good to ask the WG, if there is a will to continue to work
on the MIBs.
In the past, the feedback was to move towards Yang.

(2)  It would be nice, if we can maintain consistency between the MIB and
the Yang models.
The yang can be found at -
https://datatracker.ietf.org/doc/draft-ietf-pce-pcep-yang/
If you would like to see some changes in Yang, lets discuss them.

(3) You need to link the new extended pcePcepXEntityEntry/
pcePcepXPeerEntry/ pcePcepXSessEntry created a new table with the existing
entries in the entity/peer/session table.

Regards,
Dhruv

On Sat, Apr 8, 2017 at 6:44 AM, Dheeraj Parchuru <[email-masked]>
wrote:

> URL:            https://urldefense.proofpoint.com/v2/url?u=https-3A__www.
> ietf.org_internet-2Ddrafts_draft-2Dpce-2Dmib-2Dextensions-2D01.txt&d=
> DQICaQ&c=IL_XqQWOjubgfqINi2jTzg&r=ZkEFLDwLRPKreZ18Kptz_
> z547aAkiIkkoJfsKoKt6pQ&m=Iwpd2O0WWICXlZdaioTBE5dalfw7mm
> u7XITogSst-k8&s=nZ9JKuHe-KrMUtz_f5ImB7_F0LT6pXc8oPww-CIqgKI&e=
>
> Status:         https://urldefense.proofpoint.com/v2/url?u=https-3A__
> datatracker.ietf.org_doc_draft-2Dpce-2Dmib-2Dextensions_&d=DQICaQ&c=IL_
> XqQWOjubgfqINi2jTzg&r=ZkEFLDwLRPKreZ18Kptz_z547aAkiIkkoJfsKoKt6pQ&m=
> Iwpd2O0WWICXlZdaioTBE5dalfw7mmu7XITogSst-k8&s=JtRLQcjMpzcbJZzY_
> c0QJhiGAj7d4YjaixuJactmsyA&e=
>
> Htmlized:       https://urldefense.proofpoint.
> com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dpce-
> 2Dmib-2Dextensions-2D01&d=DQICaQ&c=IL_XqQWOjubgfqINi2jTzg&r=
> ZkEFLDwLRPKreZ18Kptz_z547aAkiIkkoJfsKoKt6pQ&m=
> Iwpd2O0WWICXlZdaioTBE5dalfw7mmu7XITogSst-k8&s=Z1Z50_
> bGtB0IfVEG889281Y2IVdeuEu4vY12OOMBYEo&e=
>
> Diff:           https://urldefense.proofpoint.com/v2/url?u=https-3A__www.
> ietf.org_rfcdiff-3Furl2-3Ddraft-2Dpce-2Dmib-2Dextensions-2D01&d=DQICaQ&c=
> IL_XqQWOjubgfqINi2jTzg&r=ZkEFLDwLRPKreZ18Kptz_z547aAkiIkkoJfsKoKt6pQ&m=
> Iwpd2O0WWICXlZdaioTBE5dalfw7mmu7XITogSst-k8&s=
> 5hDsoNhKRRKG3ev6r67OOMQYv2OiUp-6tp4iZGlsqyA&e=
>
>
>
> Abstract:
>

---

From: Vaidya Ramany <[email-masked]>
Date: Mon, 10 Apr 2017 03:18:25 +0000

Hi Dhruv,

Thanks for the feedback.
For the questions below:

(1) It would be good to ask the WG, if there is a will to continue to work on the MIBs.
In the past, the feedback was to move towards Yang.
OK. This sounds reasonable.
Would you be aware of any existing discussion threads on this topic that we can refer to?

(2)  It would be nice, if we can maintain consistency between the MIB and the Yang models.
This would be contingent on the answer to (1) I believe.

(3) You need to link the new extended pcePcepXEntityEntry/ pcePcepXPeerEntry/ pcePcepXSessEntry created a new table with the existing entries in the entity/peer/session table.
We are using the AUGMENTS feature to extend the existing tables. Did you have something else in mind?

Thanks,
Vaidya

From: Pce [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: Saturday, April 08, 2017 10:38 PM
To: Dheeraj Parchuru <[email-masked]>
Cc: Dilip Kumar <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [Pce] Request for review on <draft-pce-mib-extensions-01>

Hi Dheeraj,

(1) It would be good to ask the WG, if there is a will to continue to work on the MIBs.
In the past, the feedback was to move towards Yang.

(2)  It would be nice, if we can maintain consistency between the MIB and the Yang models.
The yang can be found at - https://datatracker.ietf.org/doc/draft-ietf-pce-pcep-yang/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dpce-2Dpcep-2Dyang_&d=DwMFaQ&c=IL_XqQWOjubgfqINi2jTzg&r=g28q3pOgXDY3WFHMMERBxxQaNJXIW2JQWKz6oovJTVo&m=7DYiV1Uzc9iEq0-DKzFODx56_v3x_ehr06BMQ3e1xCo&s=Ld9cpbSyMYh1HeoujQoImgEd3zVNDPiaFEblH_Cjf4U&e=>
If you would like to see some changes in Yang, lets discuss them.

(3) You need to link the new extended pcePcepXEntityEntry/ pcePcepXPeerEntry/ pcePcepXSessEntry created a new table with the existing entries in the entity/peer/session table.

Regards,
Dhruv

On Sat, Apr 8, 2017 at 6:44 AM, Dheeraj Parchuru <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Revision:              01

Pages:                   22

Abstract:

   stateful capabilities.

- Regards
Dheeraj

_______________________________________________
Pce mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pce<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_pce&d=DwMFaQ&c=IL_XqQWOjubgfqINi2jTzg&r=g28q3pOgXDY3WFHMMERBxxQaNJXIW2JQWKz6oovJTVo&m=7DYiV1Uzc9iEq0-DKzFODx56_v3x_ehr06BMQ3e1xCo&s=iZKw21qVSfOusmzSLrKrtu5kDzT_If3MIOcMks5mPqU&e=>

---

From: Dhruv Dhody <[email-masked]>
Date: Mon, 10 Apr 2017 09:13:54 +0530

Hi Vaidya,

See inline..

> Would you be aware of any existing discussion threads on this topic that

[Dhruv]: In the past, there were other MIB extensions -
https://tools.ietf.org/id/draft-zhao-pce-pcep-p2mp-mib-04.txt
https://tools.ietf.org/id/draft-dhody-pce-pcep-pathkey-mib-04.txt

You can find some discussion around them.

It would be good to ask the WG, if there is interest in continuing to
update our MIBs.
If you or other vendors plan to implement this in production
​,​
or if a service provider is asking
​for this MIB extention​
,
​that information ​
would help the WG in making this decision.

> (2)  It would b
e nice, if we can maintain consistency between the MIB and the Yang models.
> This would be contingent on the answer to (1) I believe.

[Dhruv]: You can look into Yang, that support stateful PCE anyways. We
welcome comments
​​
:)

> pcePcepXPeerEntry/ pcePcepXSessEntry created a new table with the
> existing entries in the entity/peer/session table.
>

[Dhruv]: Got it!
I was thinking that this is a table for only peers/sessions with Stateful
feature.
With augment these parameters are added to *all*.

​Regards,
Dhruv​

>
> Thanks,
>
> Vaidya
>
>
>
> *From:* Pce [mailto:[email-masked]] *On Behalf Of *Dhruv Dhody
> *Sent:* Saturday, April 08, 2017 10:38 PM
> *To:* Dheeraj Parchuru <[email-masked]>
> *Cc:* Dilip Kumar <[email-masked]>; [email-masked]; [email-masked]
> *Subject:* Re: [Pce] Request for review on <draft-pce-mib-extensions-01>
>
>
>
> Hi Dheeraj,
>
>
>
> The yang can be found at - https://datatracker.ietf.
> org/doc/draft-ietf-pce-pcep-yang/
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dpce-2Dpcep-2Dyang_&d=DwMFaQ&c=IL_XqQWOjubgfqINi2jTzg&r=g28q3pOgXDY3WFHMMERBxxQaNJXIW2JQWKz6oovJTVo&m=7DYiV1Uzc9iEq0-DKzFODx56_v3x_ehr06BMQ3e1xCo&s=Ld9cpbSyMYh1HeoujQoImgEd3zVNDPiaFEblH_Cjf4U&e=>
>
> pcePcepXPeerEntry/ pcePcepXSessEntry created a new table with the
> existing entries in the entity/peer/session table.
>
>
>
> Regards,
>
> Dhruv
>
>
>
>
>
>
>
>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_pce&d=DwMFaQ&c=IL_XqQWOjubgfqINi2jTzg&r=g28q3pOgXDY3WFHMMERBxxQaNJXIW2JQWKz6oovJTVo&m=7DYiV1Uzc9iEq0-DKzFODx56_v3x_ehr06BMQ3e1xCo&s=iZKw21qVSfOusmzSLrKrtu5kDzT_If3MIOcMks5mPqU&e=>
>
>
>