Subject: [Pce] My Comment on draft-lee-pce-flexible-grid

From: Julien Meuric <[email-masked]>
Date: Thu, 20 Jul 2017 10:28:04 +0200

Hi,

The discussion during the meeting suggests that I need to clarify my
comment about draft-lee-pce-flexible-grid.

This I-D is very similar to draft-ietf-pce-wson-rwa-ext, which addresses
the exact same problem over a slightly different WDM label space
(running a side-by-side diff between them appears to be very practical).
This new I-D requests the creation of one object and 3 TLVs, which are
identical to the ones created in the WSON.
As a result, I believe the latter should be reused as a starting popint.
Covering the flexi-grid case may just need to allocate new flag in the
object header to identify the WDM type we're dealing with, and document
the flexi-grid-specific assumptions (if any).

Thanks,

Julien

---

From: Leeyoung <[email-masked]>
Date: Thu, 20 Jul 2017 08:41:15 +0000

Hi Julien,

I agree. A New flag on the object header (WA Object, I assume that is what you are pointing to) where we have a flag to indicate if this is fixed (WSON) or flexi-grid is reasonable instead of creating a new object for a new Spectrum Assignment Object.

TLVs require a bit different encoding due to the nature of additional parameters for flexi-grid. So strict re-use of WSON TLV may not be sufficient for some cases in flexi-grid. 

Best regards,
Young

-----Original Message-----
From: Julien Meuric [mailto:[email-masked]] 
Sent: Thursday, July 20, 2017 10:28 AM
To: [email-masked]; [email-masked]
Subject: My Comment on draft-lee-pce-flexible-grid

Hi,

The discussion during the meeting suggests that I need to clarify my comment about draft-lee-pce-flexible-grid.

This I-D is very similar to draft-ietf-pce-wson-rwa-ext, which addresses the exact same problem over a slightly different WDM label space (running a side-by-side diff between them appears to be very practical).
This new I-D requests the creation of one object and 3 TLVs, which are identical to the ones created in the WSON.
As a result, I believe the latter should be reused as a starting popint.
Covering the flexi-grid case may just need to allocate new flag in the object header to identify the WDM type we're dealing with, and document the flexi-grid-specific assumptions (if any).

Thanks,

Julien

---

From: Zhenghaomian <[email-masked]>
Date: Thu, 20 Jul 2017 09:04:20 +0000

Hi, Julien and Young, 

I fully agree on that we should try our best on reusing the existing object/TLVs. FYI, when we are working on GMPLS extensions from fixed-grid (WSON) to flexi-grid, we have some TLVs in parallel (switching types) for fixed/flexi-grid. 

I assume this is exactly what we are doing in this draft, the split occurs when it is difficult to use existing TLV to represent the new features. In some cases, the meaning of flags/TLVs need to be changed to support different scenarios, so the similarity on object does not necessarily mean the equivalent on functionality. 

My 2 cents, 
Haomian

-----邮件原件-----
发件人: Pce [mailto:[email-masked]] 代表 Leeyoung
发送时间: 2017年7月20日 16:41
收件人: Julien Meuric; [email-masked]; [email-masked]
主题: Re: [Pce] My Comment on draft-lee-pce-flexible-grid

Hi Julien,

Best regards,
Young

-----Original Message-----
From: Julien Meuric [mailto:[email-masked]] 
Sent: Thursday, July 20, 2017 10:28 AM
To: [email-masked]; [email-masked]
Subject: My Comment on draft-lee-pce-flexible-grid

Hi,

Thanks,

Julien

_______________________________________________
Pce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pce

---

From: Dieter Beller <[email-masked]>
Date: Thu, 20 Jul 2017 11:35:06 +0200

Hi all,

the description of the available spectrum in
draft-lee-pce-flexible-grid should in my opinion be consistent
with the available spectrum

description in draft-ietf-ccamp-flexible-grid-ospf-ext. Please
note that the available spectrum is advertised in terms of
available central

frequencies!

A central frequency f_c is available only if the spectrum is
available in the interval [f_c - f_minSlotWidth/2, fc + f_minSlotWidth/2]

If the flexgrid granularity is 6.25GHz and the minSlotWidth is
12.5GHz this means leads to: [f_c - 6.25GHz, f_c + 6.25 GHz]

This is different from advertising spectrum slots like for example
[f_c_n-1, fc_n].

Please note that a modulated optical carrier occupies spectrum
symmetrical around the central frequency.

Thanks,

Dieter

On 20.07.2017 11:04, Zhenghaomian
wrote:

Hi, Julien and Young,

My 2 cents,
Haomian

-----邮件原件-----
发件人: Pce [mailto:[email-masked]] 代表 Leeyoung
发送时间: 2017年7月20日 16:41
收件人: Julien Meuric; [email-masked]; [email-masked]
主题: Re: [Pce] My Comment on draft-lee-pce-flexible-grid

Hi Julien,

Best regards,
Young

-----Original Message-----
From: Julien Meuric [mailto:[email-masked]]
Sent: Thursday, July 20, 2017 10:28 AM
To: [email-masked]; [email-masked]
Subject: My Comment on draft-lee-pce-flexible-grid

Hi,

Thanks,

Julien

--

Dieter Beller

Open Agent & Routing Project Manager

IP/Optical Networks, Optics, Nokia

t: +49 711 821 43125 | m : +49 175 7266874 | OnNet: 259 43125

[email-masked]

Alcatel-Lucent
Deutschland AG | Lorenzstr. 10 | 70435 Stuttgart

Sitz
der Gesellschaft | Domicile of the Company: Stuttgart ·
Amtsgericht Stuttgart HRB 4026

Vorsitzender des Aufsichtsrates | Chairman of the Supervisory
Board: Prof. J. Menno Harms

Vorstand | Board of Management: Wilhelm Dresselhaus
(Vorsitzender | Chairman) · Ralf Niederberger

This e-mail and its attachments, if any, may contain
confidential information.

If you have received this e-mail in error, please notify us and
delete or destroy the e-mail and its attachments, if any,
immediately.

If you have received this e-mail in error, you must not forward
or make use of the e-mail and its attachments, if any.

---

From: Leeyoung <[email-masked]>
Date: Thu, 20 Jul 2017 09:41:14 +0000

Hi Dieter,

I agree. In this draft, we refer to https://tools.ietf.org/html/draft-ietf-ccamp-flexible-grid-ospf-ext-09#section-4.1.1 for the available spectrum encoding. Is this what you are referring to, or more than that?

Thanks.
Young

From: Dieter Beller [mailto:[email-masked]]
Sent: Thursday, July 20, 2017 11:35 AM
To: Zhenghaomian <[email-masked]>; Leeyoung <[email-masked]>; Julien Meuric <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [Pce] 答复: My Comment on draft-lee-pce-flexible-grid

Hi all,

the description of the available spectrum in draft-lee-pce-flexible-grid should in my opinion be consistent with the available spectrum
description in draft-ietf-ccamp-flexible-grid-ospf-ext. Please note that the available spectrum is advertised in terms of available central
frequencies!

A central frequency f_c is available only if the spectrum is available in the interval [f_c - f_minSlotWidth/2, fc + f_minSlotWidth/2]

If the flexgrid granularity is 6.25GHz and the minSlotWidth is 12.5GHz this means leads to: [f_c - 6.25GHz, f_c + 6.25 GHz]

This is different from advertising spectrum slots like for example [f_c_n-1, fc_n].

Please note that a modulated optical carrier occupies spectrum symmetrical around the central frequency.

Thanks,
Dieter

On 20.07.2017 11:04, Zhenghaomian wrote:

Hi, Julien and Young,

My 2 cents,

Haomian

-----邮件原件-----

发送时间: 2017年7月20日 16:41

收件人: Julien Meuric; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Hi Julien,

Best regards,

Young

-----Original Message-----

To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Hi,

Thanks,

Julien

Pce mailing list

[email-masked]<mailto:[email-masked]>

Pce mailing list

[email-masked]<mailto:[email-masked]>

--

Dieter Beller

t: +49 711 821 43125 | m : +49 175 7266874 | OnNet: 259 43125
[email-masked]<mailto:[email-masked]>
Alcatel-Lucent Deutschland AG | Lorenzstr. 10 | 70435 Stuttgart
Sitz der Gesellschaft | Domicile of the Company: Stuttgart ・ Amtsgericht Stuttgart HRB 4026
Vorsitzender des Aufsichtsrates | Chairman of the Supervisory Board: Prof. J. Menno Harms
Vorstand | Board of Management: Wilhelm Dresselhaus (Vorsitzender | Chairman) ・ Ralf Niederberger

This e-mail and its attachments, if any, may contain confidential information.
If you have received this e-mail in error, please notify us and delete or destroy the e-mail and its attachments, if any, immediately.
If you have received this e-mail in error, you must not forward or make use of the e-mail and its attachments, if any.

---

From: Dieter Beller <[email-masked]>
Date: Thu, 20 Jul 2017 12:23:12 +0200

Hi Young,

On 20.07.2017 11:41, Leeyoung wrote:

Hi
Dieter,

I
agree. In this draft, we refer to

https://tools.ietf.org/html/draft-ietf-ccamp-flexible-grid-ospf-ext-09#section-4.1.1
for the available spectrum encoding. Is this what you are
referring to, or more than that?

[DB>] no, I am exactly referring to
draft-ietf-ccamp-flexible-grid-ospf-ext that is referenced in your
pce draft.

[DB>] I just wanted to point out that you have to clearly define
what a frequency slot is as it could be interpreted in

[DB>] different ways (see below).

Thanks,

Dieter

Thanks.

Young

From:
Dieter Beller [mailto:[email-masked]]

To: Zhenghaomian <[email-masked]>;
Leeyoung <[email-masked]>; Julien Meuric
<[email-masked]>; [email-masked];
[email-masked]

Subject: Re: [Pce] 答复:
My Comment on draft-lee-pce-flexible-grid

Hi all,

the description of the available spectrum in
draft-lee-pce-flexible-grid should in my opinion be
consistent with the available spectrum

description in draft-ietf-ccamp-flexible-grid-ospf-ext.
Please note that the available spectrum is advertised in
terms of available central

frequencies!

A central frequency f_c is available only if the spectrum is
available in the interval [f_c - f_minSlotWidth/2, fc +
f_minSlotWidth/2]

If the flexgrid granularity is 6.25GHz and the minSlotWidth
is 12.5GHz this means leads to: [f_c - 6.25GHz, f_c + 6.25
GHz]

This is different from advertising spectrum slots like for
example [f_c_n-1, fc_n].

Please note that a modulated optical carrier occupies
spectrum symmetrical around the central frequency.

Thanks,

Dieter

Hi, Julien and Young,

My 2 cents,

Haomian

-----邮件原件-----

发送时间: 2017年7月20日 16:41

Hi Julien,

Best regards,

Young

-----Original Message-----

Hi,

Thanks,

Julien

Pce mailing list

[email-masked]

Pce mailing list

[email-masked]

---

From: Leeyoung <[email-masked]>
Date: Thu, 20 Jul 2017 11:33:57 +0000

Hi Dieter,

I got it. We will clearly state what a frequency slot really means in the document.

Thanks
Young

From: Dieter Beller [mailto:[email-masked]]
Sent: Thursday, July 20, 2017 12:23 PM
To: Leeyoung <[email-masked]>; Zhenghaomian <[email-masked]>; Julien Meuric <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [Pce] 答复: My Comment on draft-lee-pce-flexible-grid

Hi Young,

[DB>] no, I am exactly referring to draft-ietf-ccamp-flexible-grid-ospf-ext that is referenced in your pce draft.
[DB>] I just wanted to point out that you have to clearly define what a frequency slot is as it could be interpreted in
[DB>] different ways (see below).

Thanks,
Dieter

Thanks.
Young

From: Dieter Beller [mailto:[email-masked]]
Sent: Thursday, July 20, 2017 11:35 AM
To: Zhenghaomian <[email-masked]><mailto:[email-masked]>; Leeyoung <[email-masked]><mailto:[email-masked]>; Julien Meuric <[email-masked]><mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Pce] 答复: My Comment on draft-lee-pce-flexible-grid

Hi all,

Thanks,
Dieter

Hi, Julien and Young,

My 2 cents,

Haomian

-----邮件原件-----

发送时间: 2017年7月20日 16:41

Hi Julien,

Best regards,

Young

-----Original Message-----

Hi,

Thanks,

Julien

Pce mailing list

Pce mailing list