Subject: [Pce] EKR Discuss on draft-ietf-pce-pceps (was RE: Alexey Melnikov's Discuss on draft-ietf-pce-pceps-15: (with DISCUSS and COMMENT))

From: Dhruv Dhody <[email-masked]>
Date: Wed, 23 Aug 2017 05:43:59 +0000

Hi EKR,

I have been told that my response [1] to your mail [2] has not reach some of the mailboxes.

Thus on advice of our AD, I am starting a new thread to reach closure on this.

The open point is -
EKR suggested that we use the StartTLS message to indicate the local policy if the PCEP speaker is willing to connect without TLS. Whereas the current document does this by using the error message in case it is unwilling or unable to start the TLS.

EKR proposal works, but will require us to add a new PCEP object - StartTLS object, as unfortunately there is no way to carry the information in the current message/objects format defined.

As an editor, my opinion was to avoid making a change in encoding if possible, especially if the benefit is not big and the default setting is strict TLS.

But if the opinion is towards "mandating" making the change, I can put out a version for review soon.

All the other comments are handled in -16 [3]. Thanks for all the comments and discussions!

Regards,
Dhruv

[1] https://www.ietf.org/mail-archive/web/pce/current/msg05487.html
[2] https://www.ietf.org/mail-archive/web/pce/current/msg05486.html
[3] https://tools.ietf.org/html/draft-ietf-pce-pceps-16

---

From: Eric Rescorla <[email-masked]>
Date: Sat, 26 Aug 2017 07:02:07 -0700

I'd like to hear from the AD and chairs here. It seems to me that the
design I am suggesting is better, and if the primary argument is that the
editors don't want to make the change at this date, that's not very strong.
Conversely, I agree that this is a WG decision, so if you're telling me
that the WG considered this flavor and rejected it, then I think that's
reasonable and I'll remove my discuss.

-Ekr

On Tue, Aug 22, 2017 at 10:43 PM, Dhruv Dhody <[email-masked]>
wrote:

> EKR suggested that we use the StartTLS message to indicate the local
> policy if the PCEP speaker is willing to connect without TLS. Whereas the
> current document does this by using the error message in case it is
> unwilling or unable to start the TLS.
>
>
>
> EKR proposal works, but will require us to add a new PCEP object -
> StartTLS object, as unfortunately there is no way to carry the information
> in the current message/objects format defined.
>
>
>
> As an editor, my opinion was to avoid making a change in encoding if
> possible, especially if the benefit is not big and the default setting is
> strict TLS.
>
>
>
> But if the opinion is towards “mandating” making the change, I can put out
> a version for review soon.
>
>
>