Subject: [Pce] Alvaro Retana's No Objection on draft-ietf-pce-rfc6006bis-03: (with COMMENT)

From: Alvaro Retana <[email-masked]>
Date: Fri, 25 Aug 2017 09:50:21 -0700

Alvaro Retana has entered the following ballot position for
draft-ietf-pce-rfc6006bis-03: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-pce-rfc6006bis/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I don't object the publication of this document.

However, I want to call attention to the latest IPR declaration [1] which seems
to have resulted in a very, very, very late claim against this document *and*
rfc6006.  Not only was the declaration done recently, but I don't think the WG
was explicitly made aware of it.  I did look at the archive and this is what I
found:

- WG Chair asked the authors to update the system to reflect that the IPR
claimed against rfc6006 also applies to this document [2]

- a new IPR statement [1] was filed, which updated the previous one [3]

The problem is that the most recent statement [1] points to a patent ("US
12/404100") which is different from the one in the original statement [3] ("US
12/708048").  I take this update to mean that there is more IP than originally
claimed -- resulting in a very, very, very late statement.  Note that it came
in after the WGLC concluded and just a couple of days before the document was
submitted to the IESG for Publication.

I'll let the WG chairs and the responsible AD take appropriate actions.

[1] https://datatracker.ietf.org/ipr/2983/
[2]
https://mailarchive.ietf.org/arch/msg/pce/4rxUbSO16PU22ThiMHBf66M73yA/?qid=222caa9caf467838c3c40466e1de7e7e
[3] https://datatracker.ietf.org/ipr/1686/

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Wed, 30 Aug 2017 16:58:53 +0000

Hi Alvaro,

It seems the PCE Chairs and Document Shepherd (one of the PCE Chairs) are on vacation as not responding.

The disclosure was after the WG Last Call as during Document Shepherd review, the Shepherd realized the IPR on RFC6006 was not posted against the bis. He requested it to be updated and it was immediately done. The IPR is noted as applying against both RFC6006 and RFC6006bis and it was done as an update.

As you can note from the PCE email archive, the authors did respond immediately to the Shepherd's request (to the list), the IPR disclosure was announced to the list (4/24), and the authors sent mail (to the list) on their knowledge of the IPR disclosure (April 24, May 2).

The IETF Last Call announcement (August) also noted the IPR.

So while the WG may not have been aware of it during WG Last Call, they have been made (explicitly) aware of it. There was no further discussion on it by the WG. In PCE (as with most of the Routing Area), if no negative concerns are raised on notification of IPR, it is interpreted as no concerns. The content is not explicitly discussed (e.g. details of the update) or require positive acknowledgement from the list.

Based on this, I support the document continuing on the publication track. If the IESG is concerned, I can pull the document, return it to the WG for another WG Last Call and IETF Last Call.

Thanks,
Deborah

> -----Original Message-----
> From: iesg [mailto:[email-masked]] On Behalf Of Alvaro Retana
> Sent: Friday, August 25, 2017 12:50 PM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: Alvaro Retana's No Objection on draft-ietf-pce-rfc6006bis-03: (with
> COMMENT)
> 
> Please refer to https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_iesg_statement_discuss-
> 2Dcriteria.html&d=DwICaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=-
> ufLqOntt6LejLMTbN3QpjYHxsObxmPKRhiF3FnmoI0&m=HKk9YVI7vp8bZdau9jl5
> cV7HWSb2DtnVWoLPR8oQf9U&s=kabJdQT7BsV7hbfqJES60T-
> emRSkJNt5T3VqMdC7ozg&e=
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_draft-2Dietf-2Dpce-
> 2Drfc6006bis_&d=DwICaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=-
> ufLqOntt6LejLMTbN3QpjYHxsObxmPKRhiF3FnmoI0&m=HKk9YVI7vp8bZdau9jl5
> cV7HWSb2DtnVWoLPR8oQf9U&s=5nVCiaNNK4zlu0T5nitwvGbXPqF-
> WgRkp0JmfPRKX8k&e=
> 
> 
> 
> [1] https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_ipr_2983_&d=DwICaQ&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=-
> ufLqOntt6LejLMTbN3QpjYHxsObxmPKRhiF3FnmoI0&m=HKk9YVI7vp8bZdau9jl5
> cV7HWSb2DtnVWoLPR8oQf9U&s=2gaI4rHkf4_NwuZr8E07NONtudeAxJFbA5by
> D7TX6FU&e=
> [2]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__mailarchive.ietf.org_arch_msg_pce_4rxUbSO16PU22ThiMHBf66M73yA_-
> 3Fqid-3D222caa9caf467838c3c40466e1de7e7e&d=DwICaQ&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=-
> ufLqOntt6LejLMTbN3QpjYHxsObxmPKRhiF3FnmoI0&m=HKk9YVI7vp8bZdau9jl5
> cV7HWSb2DtnVWoLPR8oQf9U&s=tKX8i571v6NPBGVk3gq5kUJg28qzd6FFtmZr2
> wmhsyk&e=
> [3] https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_ipr_1686_&d=DwICaQ&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=-
> ufLqOntt6LejLMTbN3QpjYHxsObxmPKRhiF3FnmoI0&m=HKk9YVI7vp8bZdau9jl5
> cV7HWSb2DtnVWoLPR8oQf9U&s=a91ew0lMJN8HFNL_1bpXtoainC2XjIjUC_M3
> p-qD0fs&e=
>