Subject: [Pce] I-D Action: draft-ietf-pce-stateful-pce-lsp-scheduling-01.txt

From: [email-masked]
Date: Sun, 15 Oct 2017 19:29:02 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Path Computation Element WG of the IETF.

        Title           : PCEP Extensions for LSP scheduling with stateful PCE
        Authors         : Huaimo Chen
                          Yan Zhuang
                          Qin Wu
                          Dhruv Dhody
                          Daniele Ceccarelli
	Filename        : draft-ietf-pce-stateful-pce-lsp-scheduling-01.txt
	Pages           : 23
	Date            : 2017-10-15

Abstract:
   This document proposes a set of extensions needed to the stateful
   Path Computation Element (PCE) communication Protocol (PCEP), so as
   to enable Labeled Switched Path (LSP) scheduling for path computation
   and LSP setup/deletion based on the actual network resource usage
   duration of a traffic service in a centralized network environment as
   stated in [I.D.ietf-teas-scheduled-resources].

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-pce-stateful-pce-lsp-scheduling/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-pce-stateful-pce-lsp-scheduling-01
https://datatracker.ietf.org/doc/html/draft-ietf-pce-stateful-pce-lsp-scheduling-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-pce-stateful-pce-lsp-scheduling-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Dhruv Dhody <[email-masked]>
Date: Thu, 19 Oct 2017 10:20:30 +0000

Hi WG, 

Here is the summary of the changes that were made with this update. 

- Sections were re-arranged for better readability
- Use of delegation (via PCRpt) made mandatory for scheduled LSPs (so that PCE can make changes at a later time)
- Alignment with the procedures in RFC8231 and draft-ietf-pce-pce-initiated-lsp
- For state synchronization between PCEs will use the procedures set out in draft-litkowski-pce-state-sync.  

See https://tools.ietf.org/rfcdiff?url2=draft-ietf-pce-stateful-pce-lsp-scheduling-01.txt

Regards,
Dhruv (on behalf of co-authors)

> -----Original Message-----
> From: Pce [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: 16 October 2017 07:59
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Pce] I-D Action: draft-ietf-pce-stateful-pce-lsp-scheduling-
> 01.txt
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
> 
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce