Subject: Re: [Pce] Mirja Kühlewind's No Objection on draft-ietf-pce-pce-initiated-lsp-10: (with COMMENT)

From: Jonathan Hardwick <[email-masked]>
Date: Wed, 4 Oct 2017 16:00:45 +0000

Hi Mirja

Many thanks for these comments.  I'm picking up this thread and replying as PCE working group chair, as the authors are unavailable.  I am very sorry for the delay.

Please see my proposed resolutions inline below, marked with "Jon>"

Best regards
Jon

<snip>

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

1) I'm wondering why this spec is not part of I-D.ietf-pce-stateful-pce as it is also not published yet...?

Jon> It has been published now.  The main reasons were
- it took longer for PCE-initiated LSPs to be accepted into the PCE WG, and the authors did not want to hold up work on the base draft
- I-D.ietf-pce-stateful-pce was a self-contained set of function and it was envisioned that there was a class of device that would not implement the LSP initiation extensions
- I-D.ietf-pce-stateful-pce was already fairly long and complex, and merging them would have been an editing / reviewing headache.

2) I-D.ietf-pce-stateful-sync-optimizations should also be a normative references, given a flag is used in section 4.1 and a TLV is used in section
5.3.2 that are defined in that draft.

Jon> Good catch! Will fix it.

3) sec 5.4: "A PLSP-ID of zero removes all LSPs that were initiated by the PCE." and
   "If the PLSP-ID specified in the PCInitiate message was not created by a
   PCE.."
  -> This means that the PCC must remember which LSP was created by which PCE
  at instantiation time. This could be stated more explicitly.

Jon> I think the first sentence ought to say "A PLSP-ID of zero removes all LSPs that are delegated to the PCE."  I will fix the sentence.

_______________________________________________
Pce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pce

---

From: Julien Meuric <[email-masked]>
Date: Wed, 4 Oct 2017 18:34:00 +0200

Hi all,

We may add on top of the reasons below the strong impact PCE-initiation
has from the implementation's perspective (which is somehow linked to
the first 2 items).
Up to I-D.ietf-pce-stateful-pce, it was all about configuration on PCCs,
just allowing PCEs to trigger actions. I-D.ietf-pce-pce-initiated-lsp is
a significant change: it enables PCEs to create on PCCs states which are
not part of operator-specified PCCs' configuration. As a result, there
has already been some commercial implementations at the stage described
by the 2nd item.

My 2 cents,

Julien